Search found 24 matches

by spacewan
Thu Feb 11, 2010 11:32 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Wie meinst du das? Wir setzten hier auch NIS ein, aber nicht für web sachen wie Faq, Apache, Samba und co, die authentifizieren sich alle an LDAP. Also falls du auf phpmyfaq abzielst - nein kein NIS nur LDAP Grüße P.S. Bis nächsten Mittwoch bin ich nun out of order, Karneval in Kölle ist angesagt ;-...
by spacewan
Thu Feb 11, 2010 10:14 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Ok, super.

Test dann gerne weiter, das bekommen wir schon hin.

Grüße
by spacewan
Wed Feb 10, 2010 11:41 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

So hier die beiden Files,
Danke und Grüße
by spacewan
Tue Feb 09, 2010 11:30 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

So läuft nun wieder, bekommen nun keinen Fehler, wenn ich aber einen LDAP user wähle kommt: Keine solche Loginkombination gefunden. Es scheint aber ein ldap verbindungsaufbau stattzufinden, das steht im ldap logfile: Feb 9 13:27:00 sv23 slapd[21214]: conn=29840 fd=27 ACCEPT from IP=127.0.0.1:52868 (...
by spacewan
Tue Feb 09, 2010 11:23 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

So habe auch gerade mal logging für php aktiviert...auch nichts...kein Fehler Ok, ich war's ;-) Tue Feb 09 11:22:46 2010] [error] [client 131.220.xxx.xxx] PHP Parse error: syntax error, unexpected '}' in /daten/www/faq2/inc/Ldap.php on line 210, referer: http://faq2 Wie ich schon vermutet habe, werd...
by spacewan
Tue Feb 09, 2010 11:12 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Es gibt keinen Eintrag außer: [Tue Feb 09 10:51:45 2010] [error] [client 131.220.xx.xxx] File does not exist: /daten/www/faq2/favicon.ico Aber sag mir doch bitte kurz - da ich ja von php keine Ahnung habe- ob man und wenn ja wie das ldap.patch mit einer syntax reinpatchen kann. Oder war es "richtig"...
by spacewan
Tue Feb 09, 2010 11:05 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

So also da ich nicht wusste was ich mit den patch file machen sollte, habe ich es nun nach besten wissen und gewissen da rausgefummelt und in die Ldap.php und AuthLdap.php wieder reingefummelt. Zumindest gibt es keine Fehlermeldung mehr, aber nur noch eine weiße Seite nach dem login. Ich habe jedoch...
by spacewan
Tue Feb 09, 2010 10:32 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Hi Thorsten,
hab es mir gerade gezogen und werde es testen.
Gebe so schnell wie möglich bescheid.
Danke und Grüße

P.S. Was mache ich mit dem ldap.patch file? Muss ich mir die Codeschnipsel da rausfriemeln und neu in die Ldap.php einsetzen?
by spacewan
Wed Feb 03, 2010 12:38 pm
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Noch kurz als Ergänzung:
Ich biete mich also gerne als "Versuchskanichen" an.
Wenn die LDAP Sachen dann unter Linux laufen könnt ihr es ins nächste Release mit übernehmen.

Grüße
by spacewan
Tue Feb 02, 2010 12:28 pm
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Yay!
Ok,
ich gebe Euch auch ein paar Tage mehr, es ist ja schön das es überhaupt eine Lösung gibt. :-)

Danke und Grüße
by spacewan
Tue Feb 02, 2010 10:19 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

ldapsearch -x -D 'cn=admin,dc=subdomain,dc=mydomain,dc=de' -W -b 'dc=subdomain,dc=mydomain,dc=de' '(uid=*)'

gibt auch alle user aus und klappt einwandfrei
by spacewan
Tue Feb 02, 2010 10:08 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Ohne -x geht es nicht, nutze kein SASL. Was geht ist: ldapsearch -x -b 'dc=subdomain,dc=mydomain,dc=de' '(object=*)' (also als anoymous user) Ausgabe: # extended LDIF # # LDAPv3 # base <dc=subdomain,dc=mydomain,dc=de> with scope subtree # filter: (object=*) # requesting: ALL # # search result search...
by spacewan
Tue Feb 02, 2010 9:46 am
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Hi Torsten,

ldapsearch -x -D 'cn=admin,dc=subdomain,dc=mydomain,dc=de' -b 'dc=subdomain,dc=mydomain,dc=de' -h localhost -p 389 -W '(object=*)'
gibt nach der Passworteingabe diesen Fehler aus:
ldap_bind: Invalid credentials (49)

P.S ich setze OpenLDAP V. 2.3.30 ein
by spacewan
Mon Feb 01, 2010 3:00 pm
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Ja ok, aber wie sollte die denn sonst aussehen??? Also klar heisst mein LDAP nicht "dc=subdomain,dc=mydomain,dc=de" - wollte ich im Web nicht posten, aber die Struktur ist so. Es geht ja hier um die Base DN, klar gibt es dann als Unterestruktur noch: ou=people ou=machines usw. Also wenn er meint das...
by spacewan
Mon Feb 01, 2010 1:11 pm
Forum: General discussions
Topic: LDAP macht mit 2.6.1 Probleme
Replies: 38
Views: 14779

Re: LDAP macht mit 2.6.1 Probleme

Ja, ich setze LAM ein