Search found 9 matches

by nawiiwan
Thu Aug 07, 2014 9:22 am
Forum: Webserver and configuration
Topic: IIS 7.5 + LDAP + SSO Windows Authentication -Active Directo
Replies: 26
Views: 21571

Re: IIS 7.5 + LDAP + SSO Windows Authentication -Active Dire

Hi Thorsten,
will you have a chance to implement changes in beta?

Regards,
Maciej
by nawiiwan
Tue Jul 15, 2014 7:32 pm
Forum: Webserver and configuration
Topic: IIS 7.5 + LDAP + SSO Windows Authentication -Active Directo
Replies: 26
Views: 21571

Re: IIS 7.5 + LDAP + SSO Windows Authentication -Active Dire

Hi, if I understand your question correctly then $user in changePassword() is defined in original 2.8.11 code. I did only one chage, add line "$this->add($login, $pass);" like it is in Ldap.php. $user = $remoteUser[1]; or $user = $remoteUser[0]; or $user = $_SERVER['REMOTE_USER']; I upload both modi...
by nawiiwan
Tue Jul 15, 2014 8:01 am
Forum: Webserver and configuration
Topic: IIS 7.5 + LDAP + SSO Windows Authentication -Active Directo
Replies: 26
Views: 21571

Re: IIS 7.5 + LDAP + SSO Windows Authentication -Active Dire

Hi,
ok, I'll wait for message from you.

Thanks for your great support!

Regards,
Maciej
by nawiiwan
Tue Jul 15, 2014 6:52 am
Forum: Webserver and configuration
Topic: IIS 7.5 + LDAP + SSO Windows Authentication -Active Directo
Replies: 26
Views: 21571

Re: IIS 7.5 + LDAP + SSO Windows Authentication -Active Dire

Hi, now it's clear. What do you think about below changes, is it looks correct? I already implement it and looks that works fine. inc/PMF/User/CurrentUser: // Additional code for LDAP: user\\domain if ($this->config->get('security.ldapSupport') && function_exists('ldap_connect') && isset($this->_lda...
by nawiiwan
Mon Jul 14, 2014 8:38 am
Forum: Webserver and configuration
Topic: IIS 7.5 + LDAP + SSO Windows Authentication -Active Directo
Replies: 26
Views: 21571

Re: IIS 7.5 + LDAP + SSO Windows Authentication -Active Dire

Hi, I did first tests and recognize some small problems -when user login using SSO with my patch then column faquser.auth_source = "ldap" but I think that should be eqal to "sso" -when LDAP is disabled and SSO is enabled then SSO is not working. I did small investigation and going to create "patch"....
by nawiiwan
Sun Jul 13, 2014 7:33 pm
Forum: Webserver and configuration
Topic: IIS 7.5 + LDAP + SSO Windows Authentication -Active Directo
Replies: 26
Views: 21571

Re: IIS 7.5 + LDAP + SSO Windows Authentication -Active Dire

Hi, thank you for sugestion. I implement it, maybe somebody else can test SSO + AD as well. My configuration is: config/ldap.php: // Main LDAP server $PMF_LDAP['ldap_server'] = 'active directory domain server name'; $PMF_LDAP['ldap_port'] = 389; $PMF_LDAP['ldap_user'] = 'AD_username@domain_name'; $P...
by nawiiwan
Sun Jul 13, 2014 11:32 am
Forum: Webserver and configuration
Topic: IIS 7.5 + LDAP + SSO Windows Authentication -Active Directo
Replies: 26
Views: 21571

Re: IIS 7.5 + LDAP + SSO Windows Authentication -Active Dire

Hi, thank you! I will give you a feedback in next days/weeks Please let me know, is it possible to read $faqConfig->get('security.ssoSupport') in inc/PMF/Auth/Ldap.php to check SSO enabled in this way: if ($faqConfig->get('security.ssoSupport') && isset($_SERVER['REMOTE_USER'])) { instead of my work...
by nawiiwan
Sun Jul 13, 2014 10:51 am
Forum: Webserver and configuration
Topic: IIS 7.5 + LDAP + SSO Windows Authentication -Active Directo
Replies: 26
Views: 21571

Re: IIS 7.5 + LDAP + SSO Windows Authentication -Active Dire

Hi,
I did it on test server last week, and today modified a little bit. It looks that it is working fine.

I plan to implement on the pro server in next days and test it deeper in next 2-4 weeks.

Regards,
Maciej
by nawiiwan
Sun Jul 13, 2014 10:18 am
Forum: Webserver and configuration
Topic: IIS 7.5 + LDAP + SSO Windows Authentication -Active Directo
Replies: 26
Views: 21571

Re: IIS 7.5 + LDAP + SSO Windows Authentication -Active Dire

Hi, I have the same issue, I mean: -LDAP (Active Directory) is working fine, -SSO (on IIS) is working fine. I instal phpMyFAQ is phpmyfaq-2.8.11.zip What I found? Theare are two situations: -User exisits in PMF database then after login using SSO username is visible. -User doesn't exists in PMF data...