Issues upgrading from 2.6.15 to 2.8.29

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
toddm
Posts: 6
Joined: Sun Oct 04, 2020 1:34 am

Issues upgrading from 2.6.15 to 2.8.29

Post by toddm » Sun Oct 04, 2020 1:54 am

Hello,

First of all I'd like to say thank you for developing such great software.

I recently inherited management of an existing phpMyFAQ installation that is quite out of date (version 2.6.15) at http://www.faxtalk.com/support/kb/index.php. I wanted to bring this installation up to date, so I had planned to perform a series of step updates to get to version 3.0.4 (2.6.15 > 2.8.29 > 3.04). I followed the documented process to update from version 2.6.15 to version 2.8.29 as the first step and after performing the update I seem to be encountering some odd issues that I'm hoping you might be able to help (I attached some screenshots too if they help at all).
  1. After the update when visitors access phpMyFAQ they get a home page that does not display any topics available (tested with Chrome and the new MS Edge). I can manually enter in a document number in the search field and it will actually display without issue but if I go to the "Home" page the "News", "Most popular FAQs" and "Latest FAQs" sections all report that there are no FAQs. The page also reports that there are "No categories found" on the menu on the left.

    I noticed that the language defaulted to "American English" for the page and I thought that might be related as I don't remember seeing "American English" as an option with version 2.6.15. However, if I change the language selector to just "English" I'm presented with a blank white screen. In further testing found that if I modify the Chrome settings and change the order so "English (United States)" is after "English" in the languages list I do see all of the topics when I visit the phpMyFAQ URL. This leads me to believe that I need to update the FAQ documents to include support for both "English" and "American English" to cover both possible use cases but I run into significant issues in trying to do that.
  1. If I try to add an additional language to a category (as an attempt to solve the languages issue highlighted in #1) by selecting the Translate option and then take a FAQ category that is currently in "English" and translate it to "American English" I encounter an error "You are not authorized" - I am logged in as the administrator at the time.
  1. If I try to edit a "News" FAQ I'm given the ability to edit the record and after clicking "Save" it reports that the record has been updated but when I display the news page as a user it does not show any updates.

Given the number of separate issues that I'm experiencing I starting to wonder if it would be better to start with a separate, clean installation of 3.0.4 but I'm unsure if I can just simply point a clean 3.0.4 installation to the existing MySQL database and have the existing documents automatically appear in the new installation. Is this possible? Should I attempt to upgrade from the existing 2.8.29 installation to the current 3.0.4 version regardless of the issues I'm encountering and then see if the issues remain or what new issues appear? I'm especially concerned of the "You are not authorized" error I'm seeing.

If starting with a fresh installation of phpMyFAQ while somehow being able to incorporate the existing MySQL database is the best option I'm happy to do that but I would very much appreciate any guidance as to what process to follow to best attempt to keep the existing SQL data.

Regards,
Todd
You do not have the required permissions to view the files attached to this post.

Thorsten
Posts: 15091
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by Thorsten » Sun Oct 04, 2020 11:24 am

Hi,

I think these issues are mainly because of the stupid idea of introducing the American English translation. The rest should be fixable.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

toddm
Posts: 6
Joined: Sun Oct 04, 2020 1:34 am

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by toddm » Mon Oct 12, 2020 11:04 pm

Hello Thorsten,

Through trial and error as well as reading through the support forum for help with things like "Invalid database: MySQL" and I am now running 2.9.13. I'm planning to make one more upgrade to 3.0.4 as soon as I get the PHP on the site upgraded from 5.6.x to 7.4.x. I've also managed to resolve the issues with the home page display not showing topics/news as well as the issues with the English vs. American English languages. I've also resolved the "You are not authorized" issues I was encountering.

For the most part everything appears to be working, I need to learn this new theme support you are using in 2.9/3.x and customize things.

There are a couple of minor issues that I'm still encountering that I am hoping you can help with:

1. I'm experiencing an issue where there are small squares/rectangles displayed next to commands and text within the Admin portal (I attached a screen shot). I came across an old post in the support forum where you mentioned using FontAwesome and as a test I tried adding the files from the file referenced in that post but that did not resolve the issue.

2. When I click on the option to edit an existing FAQ under the Content section in the Admin portal I get an "unthemed" navigation display (see screenshot) instead of something using the phpMyFAQ theme. If I scroll down the list of navigation items I do eventually come acoss a HTML list of FAQ documents and if I click on one of the listed items I then go into a phpMyFAQ themed editor. The issues seems to be specific to displaying the overall list of FAQ documents available for editing.

Thank you again for your help.

Regards,
Todd
You do not have the required permissions to view the files attached to this post.

Thorsten
Posts: 15091
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by Thorsten » Wed Oct 14, 2020 6:02 am

Hi,

for these both issues I need to see what happens in the browser dev tools, looks like the icon font is not loading as well the CSS for the admin site.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Thorsten
Posts: 15091
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by Thorsten » Wed Oct 14, 2020 7:31 pm

Hi,

could you post what did you have to change to fix the issues you had in the beginning? Thanks in advance!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

toddm
Posts: 6
Joined: Sun Oct 04, 2020 1:34 am

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by toddm » Sat Oct 17, 2020 7:15 am

Hello Thorsten,

For the font issue, the Developer Tools did list some issues which seem to detail the display problem but I'm not sure what the errors mean:

Access to font at 'https://www.faxtalk.com/support/kb/admi ... f2?v=4.7.0' from origin 'http://www.faxtalk.com' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

GET https://www.faxtalk.com/support/kb/admi ... f2?v=4.7.0 net::ERR_FAILED

session.keepalive.php?lang=en:37 Uncaught DOMException: Blocked a frame with origin "https://www.faxtalk.com" from accessing a cross-origin frame.
at window.onload (https://www.faxtalk.com/support/kb/admi ... g=en:37:26)
window.onload @ session.keepalive.php?lang=en:37
load (async)
(anonymous) @ session.keepalive.php?lang=en:34

Access to font at 'https://www.faxtalk.com/support/kb/admi ... ff?v=4.7.0' from origin 'http://www.faxtalk.com' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

GET https://www.faxtalk.com/support/kb/admi ... ff?v=4.7.0 net::ERR_FAILED

Access to font at 'https://www.faxtalk.com/support/kb/admi ... tf?v=4.7.0' from origin 'http://www.faxtalk.com' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

GET https://www.faxtalk.com/support/kb/admi ... tf?v=4.7.0 net::ERR_FAILED


Perhaps an issue with the web server configuration?
You do not have the required permissions to view the files attached to this post.

toddm
Posts: 6
Joined: Sun Oct 04, 2020 1:34 am

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by toddm » Sat Oct 17, 2020 7:22 am

Thorsten,

Another strange set of errors for the Edit Category page:

Mixed Content: The page at 'https://www.faxtalk.com/support/kb/admin/?action=view' was loaded over HTTPS, but requested an insecure stylesheet 'http://www.faxtalk.com/support/kb/admin ... le.css?v=1'. This request has been blocked; the content must be served over HTTPS.

Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure script '<URL>'. This request has been blocked; the content must be served over HTTPS.
/support/kb/admin/?action=view:1 Mixed Content: The page at 'https://www.faxtalk.com/support/kb/admin/?action=view' was loaded over HTTPS, but requested an insecure script 'http://www.faxtalk.com/support/kb/asset ... izr.min.js'. This request has been blocked; the content must be served over HTTPS.
/support/kb/admin/?action=view:1 Mixed Content: The page at 'https://www.faxtalk.com/support/kb/admin/?action=view' was loaded over HTTPS, but requested an insecure script 'http://www.faxtalk.com/support/kb/asset ... faq.min.js'. This request has been blocked; the content must be served over HTTPS.
/support/kb/admin/?action=view:1 Mixed Content: The page at 'https://www.faxtalk.com/support/kb/admin/?action=view' was loaded over HTTPS, but requested an insecure script 'http://www.faxtalk.com/support/kb/admin ... sidebar.js'. This request has been blocked; the content must be served over HTTPS.
/support/kb/admin/?action=view:1 Mixed Content: The page at 'https://www.faxtalk.com/support/kb/admin/?action=view' was loaded over HTTPS, but requested an insecure script 'http://www.faxtalk.com/support/kb/admin ... 1602915426'. This request has been blocked; the content must be served over HTTPS.
?action=view:1 Mixed Content: The page at 'https://www.faxtalk.com/support/kb/admin/?action=view' was loaded over HTTPS, but requested an insecure script 'http://www.faxtalk.com/support/kb/admin ... /record.js'. This request has been blocked; the content must be served over HTTPS.

Mixed Content: The page at 'https://www.faxtalk.com/support/kb/admin/?action=view' was loaded over a secure connection, but contains a form that targets an insecure endpoint 'http://www.faxtalk.com/support/kb/admin ... ction=view'. This endpoint should be made available over a secure connection.

Mixed Content: The page at 'https://www.faxtalk.com/support/kb/admin/?action=view' was loaded over HTTPS, but requested an insecure frame 'http://www.faxtalk.com/support/kb/admin ... hp?lang=en'. This request has been blocked; the content must be served over HTTPS.
You do not have the required permissions to view the files attached to this post.

toddm
Posts: 6
Joined: Sun Oct 04, 2020 1:34 am

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by toddm » Sat Oct 17, 2020 7:28 am

Hi Thorsten,

In terms of the things I did to resolve the original set of problems I did the following:

Took the _htaccess file and made a copy and renamed the copy to .htaccess
Upgraded to version 2.9.13 (initially ran into issues with the MySQL reference in database.php but renamed the MySQL to "mysqli")
Deleted the English - American language file

There might have been some other things I did (I tried so many things along the way) but those are what I remember.

Thorsten
Posts: 15091
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by Thorsten » Sat Oct 17, 2020 7:39 am

Hi,

the issue with

Code: Select all

CORS policy: No 'Access-Control-Allow-Origin'
should be fixed with our .htaccess file as it configures CORS correctly.

The mixed content should not be possible if the HTTPS page is used in the admin configruation.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

toddm
Posts: 6
Joined: Sun Oct 04, 2020 1:34 am

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by toddm » Sat Oct 17, 2020 7:11 pm

Hello Thorsten,

Thank you for your reply. I'm going to upgrade to 3.0.4 and make sure that the .htaccess file is in place and let's see if the issues continue.

Regards

Thorsten
Posts: 15091
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Issues upgrading from 2.6.15 to 2.8.29

Post by Thorsten » Sun Oct 18, 2020 7:06 am

Hi,

you can use 3.0.5, just released yesterday.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply