Benutzerverwaltung

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
Sh4d0wL3x
Posts: 25
Joined: Sat Jul 09, 2016 10:41 am

Benutzerverwaltung

Post by Sh4d0wL3x » Fri Jul 15, 2016 12:16 am

Hallo,

Ich hab heute festgestellt, dass bei mir die manuelle Aktivierung von Benutzern (auch mit deaktiviertem AdBlocker, nutze den Privatemodus ohne Addons) nicht funktioniert.

Ich klicke auf den "Aktivieren" - Button, bestätige den JS confirm und der Button verschwindet. Nach einem F5 ist der Button wieder da
und der User ist auch nicht aktiv. In der DB haben die User den status Blocked. Scheinbar gehen keine Emails an die User raus, was im
Moment nur 2t Ranging ist, doch was hat es mit der Aktivierung auf sich?

Der AJAX-Call geht raus, und der Response liefert ein "active" (inkl der "") zurück.

Was genau muss ich in der DB manuell setzen, damit die User aktiv sind?

Lg

Thorsten
Posts: 14705
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Benutzerverwaltung

Post by Thorsten » Sat Jul 16, 2016 11:57 am

Hi,

ist ein Bug, fixe ich. Der Wert ist "active" in der Spalte "account_status" in der Tabelle "faquser".

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Sh4d0wL3x
Posts: 25
Joined: Sat Jul 09, 2016 10:41 am

Re: Benutzerverwaltung

Post by Sh4d0wL3x » Sat Jul 16, 2016 5:31 pm

Super danke dir, kann ich mir den Bugfix irgendwo ziehen?

Hab das Problem auch wenns darum geht User zu bearbeiten. Nach dem klick auf Speichern sagt mir das Protal als Rückmeldung "Keine ID angegeben".

EDIT:// Hab grade versucht einer Userin das PW manuell zu setzen mit "Override Password"... seit dem geht mein eigenes nicht mehr... so langsam wirds anstrengend
das alles in der Db zu machen

Thorsten
Posts: 14705
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Benutzerverwaltung

Post by Thorsten » Sat Jul 16, 2016 6:55 pm

Hi,

hier ist der Fix: https://github.com/thorsten/phpMyFAQ/co ... 23ff9a6eff

Das andere guck ich mir gleich an.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Sh4d0wL3x
Posts: 25
Joined: Sat Jul 09, 2016 10:41 am

Re: Benutzerverwaltung

Post by Sh4d0wL3x » Mon Dec 05, 2016 10:26 pm

Hi,

Gibt es irgend ein Update? Es ist inzwischen echt mühsam dass man nichts speichern kann. Egal ob ich die Rechte eines Users oder einer Gruppe bearbeiten möchte.
Egal of Firefox oder Chrome, AddBlock an oder aus, es wird einfach nichts gespeichert. Permanent erhalte ich die Fehlermeldung "Keine ID Angegeben".

Ist da in naher Zukunft mit Abhilfe zu rechnen? Ein System dass über die Datenbank administriert werden muss ist für mich bei der
Größe des Projektes inzwischen unbrauchbar.

// Edit
Auch das Anzeigen der User funktioniert leider nicht. Es werden falsche Daten angezeigt.
Bei 3 Usern, sind die ersten 2 korrekt, der 3te hat fälschlicherweiße name und email des 2ten users angezeigt. Der Benutzername stimmt komischerweiße.
Als würde es bei der Ausgabe in einer Schleife die Werte des letzten Durchlaufes behalten. Die Daten in der DB sind korrekt, nur die Ausgabe ist falsch.

Lg

Thorsten
Posts: 14705
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Benutzerverwaltung

Post by Thorsten » Tue Dec 06, 2016 8:22 pm

Hi,

ich habe gerade wenig Zeit. Könnte ich mir das auf deiner FAQ ansehen?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Sh4d0wL3x
Posts: 25
Joined: Sat Jul 09, 2016 10:41 am

Re: Benutzerverwaltung

Post by Sh4d0wL3x » Tue Dec 06, 2016 10:04 pm

Hab dir den Zugang via PN gschickt. Einrichten konnte ich den indem ich den IE her nahm. Ohne Plugins ohne irgendwas (benutze ich ja nie)
Aber kaum nehme ich Firefox oder Chrome geht garnichst mehr.

Lg

Thorsten
Posts: 14705
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Benutzerverwaltung

Post by Thorsten » Sat Dec 10, 2016 7:57 pm

Hi,

ich gucke es mir an. Danke!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Sh4d0wL3x
Posts: 25
Joined: Sat Jul 09, 2016 10:41 am

Re: Benutzerverwaltung

Post by Sh4d0wL3x » Tue Dec 20, 2016 8:50 pm

Irgendwas neues?

Lg

Thorsten
Posts: 14705
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Benutzerverwaltung

Post by Thorsten » Wed Dec 21, 2016 7:02 pm

Hi,

ich komme erst über die Feiertag dazu, mir das anzusehen. Bin grad beruflich und privat arg eingespannt.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply