[solved] Blank page after update to 2.9.3 // 2.9.4

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
RoHB
Posts: 4
Joined: Sun May 15, 2016 6:23 pm

[solved] Blank page after update to 2.9.3 // 2.9.4

Post by RoHB » Thu Aug 04, 2016 9:44 am

Hello,
after updating from 2.9.2 to 2.9.3 (and later 2.9.4) frontend shows a blank page - backend works well. Any ideas what went wrong?
Regards,
Robert
Last edited by RoHB on Mon Aug 08, 2016 7:57 pm, edited 1 time in total.

Thorsten
Posts: 14710
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Blank page after update to 2.9.3 // 2.9.4

Post by Thorsten » Fri Aug 05, 2016 6:15 am

Hi,

please activate the DEBUG mode in inc/Bootstrap.php.

Thanks!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

RoHB
Posts: 4
Joined: Sun May 15, 2016 6:23 pm

Re: Blank page after update to 2.9.3 // 2.9.4

Post by RoHB » Fri Aug 05, 2016 2:44 pm

Ok, it says:

Fatal error: Call to a member function fetch_object() on boolean in XXXX/faq/inc/PMF/DB/Mysqli.php on line 153

Regards,
Robert

Thorsten
Posts: 14710
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Blank page after update to 2.9.3 // 2.9.4

Post by Thorsten » Fri Aug 05, 2016 6:54 pm

Hi,

please open this file and change the method on this line to

Code: Select all

public function fetchObject($result)
    {
        debug_print_backtrace();
        return $result->fetch_object();
    }
and try it again. It should produce a stacktrace.

Thanks!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

RoHB
Posts: 4
Joined: Sun May 15, 2016 6:23 pm

Re: Blank page after update to 2.9.3 // 2.9.4

Post by RoHB » Mon Aug 08, 2016 7:55 pm

Thanks for immediate help! Problem solved.
Robert

Post Reply