Email Delivery Issues

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
skumar96
Posts: 48
Joined: Wed Nov 16, 2016 7:27 pm

Email Delivery Issues

Post by skumar96 » Wed Nov 23, 2016 7:48 pm

Hello,
i am facing some issues with email delivery and notifications. The issues are

1. When a user registers, the admin is getting notification that a new user is registers and to activate the user, but the user never gets an email/notification stating registration activated or access details, etc. In this case how the user is going to login and submit questions.

2. User is not getting notifications of the question he/she posted or when his/her question is answered.

3. Admin not getting notifications of a new question posted

Please note: i have set up the mail settings in the portal and have checked and is working fine.
The next query is, is it possible to auto activate the user instead of admin activating the user?

Thanks

Thorsten
Posts: 14722
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Email Delivery Issues

Post by Thorsten » Thu Nov 24, 2016 8:30 pm

Hi,

do you see any log entries in your mail server log?

About auto-activating: Add a group with permissions you want to give users and set the auto-join checkbox.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

skumar96
Posts: 48
Joined: Wed Nov 16, 2016 7:27 pm

Re: Email Delivery Issues

Post by skumar96 » Mon Nov 28, 2016 9:14 pm

Dear Thorsten,
i have one more question, the emails delivered by the application for all the communications to admin as well as users i.e. new registration, password, question answered, etc all shows the actual email id that i have set up. I need your help on this issue. I want instead of the email id, the receiver should see the application name.
For e.g. when a question is answered or when a question is post, the user as well as the admin see the email xyz@domain.com (as from) with the subject, instead of that the user and the admin should see Application Name (as from) and the subject in the email box.

Please advise

Thanks
Sapan

Thorsten
Posts: 14722
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Email Delivery Issues

Post by Thorsten » Wed Nov 30, 2016 7:44 pm

HI,

for all e-mails? If yes, please search the source code for the PMF_Mail class, there you can set the "from" setting

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

skumar96
Posts: 48
Joined: Wed Nov 16, 2016 7:27 pm

Re: Email Delivery Issues

Post by skumar96 » Wed Nov 30, 2016 8:58 pm

which page/file

dtascher
Posts: 5
Joined: Fri Dec 02, 2016 7:53 pm

Re: Email Delivery Issues

Post by dtascher » Fri Dec 02, 2016 7:54 pm

I am also having the same issue. I am getting emails to the administrator user but users are not getting emails when they register with their credentials when they are activated.

Thorsten
Posts: 14722
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Email Delivery Issues

Post by Thorsten » Mon Dec 05, 2016 8:06 pm

Hi,

do you have a log of your mail server?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

dtascher
Posts: 5
Joined: Fri Dec 02, 2016 7:53 pm

Re: Email Delivery Issues

Post by dtascher » Tue Dec 06, 2016 10:36 pm

Yeah, its not even hitting the mail server. There are no entries at all for user email.

dtascher
Posts: 5
Joined: Fri Dec 02, 2016 7:53 pm

Re: Email Delivery Issues

Post by dtascher » Thu Dec 08, 2016 3:27 pm

Can you tell me where in the code it is sending the email when a new user registers so I can take a look at what might be wrong?

dtascher
Posts: 5
Joined: Fri Dec 02, 2016 7:53 pm

Re: Email Delivery Issues

Post by dtascher » Fri Dec 09, 2016 11:09 pm

For the other people with this issue, I fixed it by doing the following changes:

update line 72 in admin/ajax.user.php to:

Code: Select all

case 'activate_user':
            $user->getUserById($userId, true);
            $user->setStatus('blocked');
            $user->activateUser();
            echo json_encode($user->getStatus());
            break;
update line 23 in in/pmf/mail/swiftsmtp.php to:

Code: Select all

require_once __DIR__ . '/../../libs/swiftmailer/swift_required.php';

Thorsten
Posts: 14722
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Email Delivery Issues

Post by Thorsten » Sat Dec 10, 2016 8:05 pm

Hi,

thanks for the fixes, I added your patches to the upcoming version 2.9.6.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

skumar96
Posts: 48
Joined: Wed Nov 16, 2016 7:27 pm

Re: Email Delivery Issues

Post by skumar96 » Sat Dec 10, 2016 10:39 pm

But how a user get notifications of the question he/she posted or when his/her question is answered

dtascher
Posts: 5
Joined: Fri Dec 02, 2016 7:53 pm

Re: Email Delivery Issues

Post by dtascher » Mon Dec 12, 2016 2:07 pm

I haven't gotten that far with the product yet, once I get that far I'll check to see why it isn't sending.

Post Reply