Suddenly Can't See FAQs

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
soulkeeper
Posts: 7
Joined: Wed Dec 14, 2016 2:43 pm

Suddenly Can't See FAQs

Post by soulkeeper » Wed Dec 14, 2016 3:05 pm

So, I installed yesterday to test it out, admin only account.

Created 2 test categories, added 2 random faqs (1 to each category) and was able to see them with admin.

Not thinking, I didn't visit the site with an anon logged out account...

I then added a test account, no permissions, logged in and could see the categories, but not the faqs...click did nothing. I assume based on no perms, this is correct.
Then I realized that if this WAS correct, it also this means the faqs are not readable from an anon visitor... and that made me wonder if something was wrong.

So I gave my user full permissions, and... I could still not see the faqs...click did nothing.
So I tested again with me admin... and that's why I am here.

Not sure what I did, but I clearly messed something up. I can easily re-install, its only a test server (internal, no outside access) but I like what I see and may want to use this, so I'm looking to see what I might have done, so I don't do it again.

soulkeeper
Posts: 7
Joined: Wed Dec 14, 2016 2:43 pm

Re: Suddenly Can't See FAQs

Post by soulkeeper » Wed Dec 14, 2016 7:09 pm

Few more details on this:

I can confirm (and eventually found in another post) that the reason the anon cannot see any FAQs is due to the "group" security feature.

I cannot however determine why, even in a group with full permissions, my test user cannot see the FAQs. If I disable "group" security, it all works again.

I have gone so far as to give my user full permission and the group, and still nothing.

NOTE:

I created a new FAQ (post group permission settings) and I can see that... this seems to be affecting only FAQs created before the group settings. Is this a bug?

Thorsten
Posts: 14722
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Suddenly Can't See FAQs

Post by Thorsten » Thu Dec 15, 2016 8:32 pm

HI,

did you create the FAQs with basic permissions and then later change the permissions to "group" support? If yes, you have to re-save all FAQs again with the group permissions.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

soulkeeper
Posts: 7
Joined: Wed Dec 14, 2016 2:43 pm

Re: Suddenly Can't See FAQs

Post by soulkeeper » Fri Dec 16, 2016 1:59 pm

You are correct, I did. Is this documented somewhere, I don't recall seeing this. May not hurt to have it alert you when you make this change.

Thorsten
Posts: 14722
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Suddenly Can't See FAQs

Post by Thorsten » Sat Dec 17, 2016 8:09 am

Hi,

good question, a hint would be useful. We plan to improve this behaviour in 2.10: https://github.com/thorsten/phpMyFAQ/issues/1099

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply