neue öffentliche Fragen können nicht gespeichert werden

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
RePao
Posts: 6
Joined: Sun Aug 02, 2020 8:09 am

neue öffentliche Fragen können nicht gespeichert werden

Post by RePao » Sun Aug 02, 2020 8:14 am

Erst mal herzlichen Dank für die tolle FAQ-Lösung :)
Nun musste ich leider feststellen, dass keine öffentlichen Anfragen gespeichert werden können, an was kann das liegen

Link zum Testen: https://14e.ch/myfaq/ask.html und hier ein Screenshot: https://www.screenpresso.com/de/cloud/ntBtc/

Besten Dank

PS: es läuft da 3.0.4 mit php 7.2 heute früh komplett neu installiert

Thorsten
Posts: 15150
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: neue öffentliche Fragen können nicht gespeichert werden

Post by Thorsten » Sun Aug 02, 2020 9:22 am

Hi,

da fliegt ein 500er Fehler im Backend. Könntest du mal bitte den DEBUG-Mode aktivieren, dann sieht man wahrscheinlich, was da schief läuft.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

RePao
Posts: 6
Joined: Sun Aug 02, 2020 8:09 am

Re: neue öffentliche Fragen können nicht gespeichert werden

Post by RePao » Sun Aug 02, 2020 10:37 am

Lieben Dank für die Rückmeldung,
den Debug mod im Backend der myFAQ? (wo kann ich das setzen? nicht gefunden, shame on me...)

PS: /myfaq/admin/?action=system dreht übrigens auch ewig ohne dass was angezeigt würde...
---

Hab jetzt mal in den PHP Optionen das Logging auf Alles gestellt und error_logs aktiviert, da kam dann sowas raus: (was soll roundcube damit zu tun haben)

[23-Feb-2020 17:59:47 Europe/Zurich] Unexpected condition from IMAP server, closed or corrupt connection to IMAP. Possible mailbox corruption.
[23-Feb-2020 17:59:47 Europe/Zurich] PHP Warning: fclose() expects parameter 1 to be resource, null given in /usr/local/cpanel/base/3rdparty/roundcube/program/lib/Roundcube/rcube_imap_generic.php on line 226

Wie kann ich das Mailing Testen? möchte nicht unbedingt SMTP einrichten...
sieht derzeit so aus: https://www.screenpresso.com/=t85fe
Kann also gut sein dass da der sprichwörtliche und begraben liegt?
Last edited by RePao on Wed Aug 05, 2020 12:43 pm, edited 1 time in total.

Thorsten
Posts: 15150
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: neue öffentliche Fragen können nicht gespeichert werden

Post by Thorsten » Sun Aug 02, 2020 11:11 am

Hi,

die Fehler sind auch vom 23. Februar.

Den DEBUG-Modus kannst du in der src/Bootstrap.php aktivieren.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

RePao
Posts: 6
Joined: Sun Aug 02, 2020 8:09 am

Re: neue öffentliche Fragen können nicht gespeichert werden

Post by RePao » Wed Aug 05, 2020 9:48 am

Besten Dank, das kommt hier jetzt raus... (Bitte nach Analyse dann gerne löschen)
...und es bleibt natürlich alles dabei (Laufleiste erscheint Prozess findet aber kein Ende und kommt auch nix zum Admin)
... übrigens das Kontaktformular funktioniert, scheint also nicht grundsätzlich am send zu scheitern..

DANKE

DEBUG INFORMATION
EXCEPTIONS
DATABASE QUERIES
/home/___/public_html/myfaq/src/Bootstrap.php:
phpMyFAQ\Configuration->getAll() in line 140: SELECT config_name, config_value FROM pmfcg_faqconfig
/home/___/public_html/myfaq/index.php:
phpMyFAQ\Session->checkSessionId() in line 240: SELECT sid FROM pmfcg_faqsessions WHERE sid = 9 AND ip = '###.###.###.###' AND time > 1596530691
/home/___/public_html/myfaq/index.php:
phpMyFAQ\Session->checkSessionId() in line 240: UPDATE pmfcg_faqsessions SET time = 1596617091, user_id = -1 WHERE sid = 9 AND ip = '###.###.###.###'
/home/___/public_html/myfaq/src/phpMyFAQ/Category.php:
phpMyFAQ\Category->getOrderedCategories() in line 141: SELECT fc.id AS id, fc.lang AS lang, fc.parent_id AS parent_id, fc.name AS name, fc.description AS description, fc.user_id AS user_id, fc.group_id AS group_id, fc.active AS active, fc.image AS image, fc.show_home AS show_home FROM pmfcg_faqcategories fc LEFT JOIN pmfcg_faqcategory_group fg ON fc.id = fg.category_id LEFT JOIN pmfcg_faqcategory_user fu ON fc.id = fu.category_id WHERE ( fg.group_id IN (-1) OR (fu.user_id = -1 AND fg.group_id IN (-1))) AND fc.active = 1 AND fc.lang = 'de' GROUP BY fc.id, fc.lang, fc.parent_id, fc.name, fc.description, fc.user_id, fc.group_id, fc.active, fc.image, fc.show_home ORDER BY fc.parent_id, fc.id
/home/____/public_html/myfaq/src/phpMyFAQ/Helper/CategoryHelper.php:
phpMyFAQ\Category\CategoryRelation->getNumberOfFaqsPerCategory() in line 44: SELECT fcr.category_id AS category_id, COUNT(fcr.record_id) AS number FROM pmfcg_faqcategoryrelations fcr, pmfcg_faqdata fd WHERE fcr.record_id = fd.id AND fcr.record_lang = fd.lang GROUP BY fcr.category_id
/home/____/public_html/myfaq/src/phpMyFAQ/User.php:
phpMyFAQ\User\UserData->get() in line 937: SELECT display_name FROM pmfcg_faquserdata WHERE user_id = 0
/home/____/public_html/myfaq/src/phpMyFAQ/Helper/CategoryHelper.php:
phpMyFAQ\Category\CategoryRelation->getNumberOfFaqsPerCategory() in line 44: SELECT fcr.category_id AS category_id, COUNT(fcr.record_id) AS number FROM pmfcg_faqcategoryrelations fcr, pmfcg_faqdata fd WHERE fcr.record_id = fd.id AND fcr.record_lang = fd.lang GROUP BY fcr.category_id
/home/____/public_html/myfaq/src/phpMyFAQ/Tags.php:
phpMyFAQ\Tags->getAllTags() in line 405: SELECT MIN(t.tagging_id) AS tagging_id, t.tagging_name AS tagging_name FROM pmfcg_faqtags t LEFT JOIN pmfcg_faqdata_tags dt ON dt.tagging_id = t.tagging_id LEFT JOIN pmfcg_faqdata d ON d.id = dt.record_id WHERE 1=1 AND d.active = 'yes' GROUP BY tagging_name ORDER BY tagging_name ASC
/home/____/public_html/myfaq/index.php:
phpMyFAQ\Faq->getRecordsWithoutPagingByCategoryId() in line 675: SELECT fd.id AS id, fd.lang AS lang, fd.thema AS thema, fcr.category_id AS category_id, fv.visits AS visits FROM pmfcg_faqdata fd LEFT JOIN pmfcg_faqcategoryrelations fcr ON fd.id = fcr.record_id AND fd.lang = fcr.record_lang LEFT JOIN pmfcg_faqvisits fv ON fd.id = fv.id AND fv.lang = fd.lang LEFT JOIN pmfcg_faqdata_group fdg ON fd.id = fdg.record_id LEFT JOIN pmfcg_faqdata_user fdu ON fd.id = fdu.record_id WHERE fd.date_start <= '20200805104451' AND fd.date_end >= '20200805104451' AND fd.active = 'yes' AND fcr.category_id = 0 AND fd.lang = 'de' AND fdu.user_id = -1 GROUP BY fd.id,fd.lang,fcr.category_id,fv.visits ORDER BY id DESC
Last edited by RePao on Wed Aug 05, 2020 12:46 pm, edited 1 time in total.

Thorsten
Posts: 15150
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: neue öffentliche Fragen können nicht gespeichert werden

Post by Thorsten » Wed Aug 05, 2020 9:54 am

Hi,

du müsstest in den Browser Dev Tools nachsehen, was da passiert. Der Aufruf funktioniert per Ajax.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

RePao
Posts: 6
Joined: Sun Aug 02, 2020 8:09 am

Re: neue öffentliche Fragen können nicht gespeichert werden

Post by RePao » Wed Aug 05, 2020 10:04 am

uff ich fürchte da reichen meine Möglichkeiten nicht :(
kannst du ev. bereits etwas erkennen, wenn du das einfach als nicht eingeloggter User durchspielst?
Da das Ganze noch komplett frisch ist könnte ich auch ein SUA anlegen für dich falls das die Sache erleichtert (per PN)
Hab auch eine info.php da hochgelegt, ev. kannst du da was erkennen...

Besten Dank

RePao
Posts: 6
Joined: Sun Aug 02, 2020 8:09 am

Re: neue öffentliche Fragen können nicht gespeichert werden

Post by RePao » Wed Aug 05, 2020 10:06 am

hier noch was aus der myFAQ/error.log von meinen heutigen Versuchen..

[05-Aug-2020 10:45:20 Europe/Berlin] phpMyFAQ notice: Undefined index: core.elasticsearch in /home/____/public_html/myfaq/src/phpMyFAQ/Configuration.php on line 378
[05-Aug-2020 10:45:20 Europe/Berlin] PHP Fatal error: Uncaught TypeError: Return value of phpMyFAQ\Configuration::getElasticsearch() must be an instance of Elasticsearch\Client, null returned in /home/____/public_html/myfaq/src/phpMyFAQ/Configuration.php:378
Stack trace:
#0 /home/____/public_html/myfaq/src/phpMyFAQ/Search/Elasticsearch.php(60): phpMyFAQ\Configuration->getElasticsearch()
#1 /home/____/public_html/myfaq/src/phpMyFAQ/Search.php(209): phpMyFAQ\Search\Elasticsearch->__construct(Object(phpMyFAQ\Configuration))
#2 /home/____/public_html/myfaq/src/phpMyFAQ/Search.php(103): phpMyFAQ\Search->searchElasticsearch('test', false)
#3 /home/____/public_html/myfaq/ajaxservice.php(549): phpMyFAQ\Search->search('test', false)
#4 {main}
thrown in /home/____/public_html/myfaq/src/phpMyFAQ/Configuration.php on line 378
Last edited by RePao on Wed Aug 05, 2020 12:48 pm, edited 1 time in total.

RePao
Posts: 6
Joined: Sun Aug 02, 2020 8:09 am

[gelöst] Re: neue öffentliche Fragen können nicht gespeichert werden

Post by RePao » Wed Aug 05, 2020 10:11 am

ah, gefunden :)

Der Hacken bei ElasticSearch muss raus dann geht's!
Wohl unerwünschter Nebeneffekt. Für mich aber kein Weltuntergang.

So long & hold on great work

Post Reply