Words in glossary break URL links in page code displayed by

Please report bugs here!

Moderator: Thorsten

Post Reply
pt20100201
Posts: 133
Joined: Mon Feb 01, 2010 2:11 pm
Location: Porto . Portugal
Contact:

Words in glossary break URL links in page code displayed by

Post by pt20100201 » Mon May 09, 2011 5:53 pm

.
Words in glossary break URL links in page code displayed by a browser

Dear Thorsten

One of our users tried to insert a movie in a FAQ record without success.

After an analysis, we found that
  • As we knew, the editor uses standard XHTML so it cleans the code removing (in this case) the “embed” tag - a good feature. "Screenshot 1";
  • The code generated by TinyMCE - using the standard tag “object” - seems OK. "Screenshot 1";
  • The resulting page is not rendered correctly. "Screenshot 2";
  • phpMyFAQ replace the original code by inserting “abbr” tags (and content) if it found a term present on the glossary, thus breaking the code.
    Affected terms (examples): “http” ; up ; png, ... "Screenshot 3";

Kind regards

2011-04-27
pt20100201
.
Screenshot 1 - Source code cleaned by TinyMCE

[attachment=2]pt20100201-20110509-screenshot-01-20110506-xhtml-in-editor.png[/attachment]
Screenshot 2 - Resulting page displayed on the browser

[attachment=1]pt20100201-20110509-screenshot-02-20110506-page-preview-in-browser.png[/attachment]
Screenshot 3 -Code present on the displayed page – changed by phpMyFAQ: introduced “abbr” tags in “http” ; “up” ; “png”, …

[attachment=0]pt20100201-20110509-screenshot-03-xhtml-code-in-browser.png[/attachment]

.
You do not have the required permissions to view the files attached to this post.

Post Reply