2.8 brach HEAD stable?

Please report bugs here!

Moderator: Thorsten

Post Reply
CCTJNII
Posts: 9
Joined: Thu Oct 23, 2014 4:30 pm

2.8 brach HEAD stable?

Post by CCTJNII » Fri Oct 24, 2014 10:39 pm

I downloaded 2.8 branch HEAD (4356da3132) to try and get latest patches. It returned a 200 but didn't render any HTML. Is it stable?

$ curl http://127.0.0.1:1080 -ILXGET
HTTP/1.1 200 OK
Date: Fri, 24 Oct 2014 21:38:36 GMT
Server: Apache/2.2.15 (CentOS)
X-Powered-By: PHP/5.4.32
Content-Length: 0
Connection: close
Content-Type: text/html; charset=UTF-8

Thorsten
Posts: 14720
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2.8 brach HEAD stable?

Post by Thorsten » Sat Oct 25, 2014 5:06 pm

Hi,

did you ran

Code: Select all

$ git clone git://github.com/thorsten/phpMyFAQ.git
$ cd phpMyFAQ
$ curl -s https://getcomposer.org/installer | php
$ php composer.phar install
$ npm install
$ grunt
on the console?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

CCTJNII
Posts: 9
Joined: Thu Oct 23, 2014 4:30 pm

Re: 2.8 brach HEAD stable?

Post by CCTJNII » Mon Oct 27, 2014 8:13 pm

Aah, so there is more to a release than just bundling up the code in git, I didn't read the documentation throughly enough.

When I try and run Grunt, though, I'm getting a file not found error:

Code: Select all

Running "less:development" (less) task
>> FileError: '../../../../vendor/fontawesome/build/assets/font-awesome/less/font-awesome.less' wasn't found in phpmyfaq/admin/assets/less/style.less on line 25, column 1:
>> 24 //
>> 25 @import "../../../../vendor/fontawesome/build/assets/font-awesome/less/font-awesome.less";
>> 26 @FontAwesomePath: "../font";
Warning: Error compiling LESS. Use --force to continue.
I'm using Docker for sandboxing, so here is exactly what I'm running from by Dockerfile:

Code: Select all

# Docker container for the PHPMyFaq Knowledgebase
# http://www.phpmyfaq.de/

FROM centos:centos6

MAINTAINER TJNII

RUN yum install -y git curl wget tar

# PhpMyFaq requires PHP 5.4.4+
# Current in RHEL is PHP 5.3
# Install PHP5.4 from IUS (https://iuscommunity.org)
RUN cd /tmp; wget http://dl.iuscommunity.org/pub/ius/stable/CentOS/6/x86_64/ius-release-1.0-13.ius.centos6.noarch.rpm && yum install -y /tmp/ius-release-1.0-13.ius.centos6.noarch.rpm
RUN yum install -y php54 php54-mysql php54-gd php54-xml

# Node from yum has dependency errors, so install Node from a tarball.
RUN cd /tmp/; wget http://nodejs.org/dist/v0.10.32/node-v0.10.32-linux-x64.tar.gz
# Per README.md in node-v0.10.31-linux-x64.tar.gz
RUN cd /usr/local && tar --strip-components 1 -xzf /tmp/node-v0.10.32-linux-x64.tar.gz

# http://forum.phpmyfaq.de/viewtopic.php?f=3&t=16624&sid=155675baaf712909037d7ecdb8aafcc0
RUN git clone git://github.com/thorsten/phpMyFAQ.git && cd phpMyFAQ && git checkout 2.8
RUN cd phpMyFAQ; curl -s https://getcomposer.org/installer | php && php composer.phar install
# Run with --unsafe-perm as we're building in a Docker container as root.
RUN cd phpMyFAQ; /usr/local/bin/npm install --unsafe-perm
RUN cd phpMyFAQ; grunt

Thorsten
Posts: 14720
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2.8 brach HEAD stable?

Post by Thorsten » Tue Oct 28, 2014 9:15 am

Hi,

looks like composer install didn't installed Font Awesome... I'll take a look at it.

Oh, you're using Docker with phpMyFAQ? Pretty cool!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

gkoerk
Posts: 1
Joined: Sun Nov 18, 2018 8:34 pm

Re: 2.8 brach HEAD stable?

Post by gkoerk » Sun Nov 18, 2018 8:59 pm

Hey folks - I'm also working to get phpMyFAQ working in docker. However, I'm having only one key problem:

When I try to start up the container, the phpmyfaq image fails to start and gives the following error, which I cannot for the life of me fix myself!

Code: Select all

Enabling module rewrite.,
Enabling module headers.,
To activate the new configuration, you need to run:,
  service apache2 restart,
cp: cannot stat '_.htaccess': No such file or directory,
Also - I think one of the dependencies (sass) has been updated and broken the docker image. I had to make a minor modification to the Gruntfile and the package.json files.

Thorsten
Posts: 14720
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2.8 brach HEAD stable?

Post by Thorsten » Mon Nov 19, 2018 7:41 pm

Hi,

phpMyFAQ 2.8 is out of support and is not supported for using with Docker.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply