Translation not saved

Please report bugs here!

Moderator: Thorsten

Post Reply
laurent HADJADJ
Posts: 3
Joined: Tue Mar 29, 2016 3:47 pm

Translation not saved

Post by laurent HADJADJ » Fri May 13, 2016 11:56 am

Hello,
I just upgraded phpMyFAQ version of 2.9RC2 to RC4. Bravo, many bugs I encountered were corrected, however, there is always blocking problems on recording data such as :
- recording a question remains blocked while in Version 2.8.7 it works fine. The question is not saved in base!
- There is still much fields not saved in the setup menu such as the field "Custom PDF Footer". Nothing in base!

But the most visible concerns the translation of menu, the recording button not working. No changes are recorded in the language file, while creating a new translation file works.

I'm still stuck with this version 2.9 for 3 months, impossible to make a proper demo without being ridiculous.

Of course I have no error messages (apache and php)! So if someone wants have the kindness to help me until Tuesday (I have to present the results of my work) he will be very nice.

I am under debian linux, with an apache server, php and mysql 5.6.20. The server runs on a VM with NAT.

I thank you in advance.

In chrome i have two errors messages :

1 - /admin/?action=transedit&translang=fr ------------------> Uncaught syntaxerror : missionf ) argument list
2 - /admin/?action=transedit&translang=fr:384 -------------> Uncaught ReferenceError : Save is not defined

In firfox with finebug :
SyntaxError: missing ) after argument list http://192.168.56.129/admin/?action=tra ... anslang=fr Line 476
...ata_indicator').html('Erreur lors de l'enregistrement de ce fichier de langue')

Thorsten
Posts: 14434
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Translation not saved

Post by Thorsten » Fri May 13, 2016 7:46 pm

Hi,

I couldn't reproduce your errors, sorry.

2.9.0 final was released some minutes ago. Please test with this version, all issues should be fixed. If not, please drop me a note.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

laurent HADJADJ
Posts: 3
Joined: Tue Mar 29, 2016 3:47 pm

Re: Translation not saved

Post by laurent HADJADJ » Mon May 16, 2016 10:59 pm

Hi, i have just update to 2.9.0. But i don't understand why i can't save any questions, FAQs, Stops word or translation. I can save catégories, comment,...
I don't find the problem, it's a problem of my apache config ? Php ? a problem on my VM ? A don't know. phpmyfaq 2.8 work fine on this config, but with the 2.9 it's not working.
What can i do to debug my problem, i have just some error on my firebug console.
Please help me

laurent HADJADJ
Posts: 3
Joined: Tue Mar 29, 2016 3:47 pm

Re: Translation not saved

Post by laurent HADJADJ » Mon May 16, 2016 11:33 pm

Hi, with the administrateur user i can save a question but not with a user. The rights are on the group and not on the user. But even with the administrateur user the field "main.custimPdfFooter' can not be saved ! should i reinstall the version 2.9 from sratch (drop database and all data, remove the app) ? Have you a matrix of user/role rights ?
Bonne nuit.

Thorsten
Posts: 14434
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Translation not saved

Post by Thorsten » Tue May 17, 2016 5:05 am

Hi,

please post the errors you see on the JavaScript console, maybe that's the issue.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

alaksandus
Posts: 4
Joined: Tue Aug 23, 2016 1:19 pm

Re: Translation not saved

Post by alaksandus » Wed Dec 21, 2016 8:49 am

I have the same problem. The following errors appear in my browser console when I try to save a new translation:

phpmyfaq.min.js:28 Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
send @ phpmyfaq.min.js:28
ajax @ phpmyfaq.min.js:28
savePageBuffer @ ?action=transedit&translang=nl:473
save @ ?action=transedit&translang=nl:504
onclick @ ?action=transedit&translang=nl:420

Used version of phpMyFAQ 2.9.4

Thorsten
Posts: 14434
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Translation not saved

Post by Thorsten » Wed Dec 21, 2016 6:57 pm

Hi,

which browser do you use? Did you try version 2.9.5 as well?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

alaksandus
Posts: 4
Joined: Tue Aug 23, 2016 1:19 pm

Re: Translation not saved

Post by alaksandus » Tue Dec 27, 2016 2:12 pm

I'm using Chrome and Firefox, both latest version. Did not test yet with 2.9.5.

Thorsten
Posts: 14434
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Translation not saved

Post by Thorsten » Tue Dec 27, 2016 7:36 pm

Hi,

please upgrade to 2.9.5 first.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

alaksandus
Posts: 4
Joined: Tue Aug 23, 2016 1:19 pm

Re: Translation not saved

Post by alaksandus » Wed Dec 28, 2016 11:18 am

Thorsten wrote:Hi,

please upgrade to 2.9.5 first.

bye
Thorsten
Same result:

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
send @ phpmyfaq.min.js:28
ajax @ phpmyfaq.min.js:28
savePageBuffer @ ?action=transedit&translang=nl:473
save @ ?action=transedit&translang=nl:504
onclick @ ?action=transedit&translang=nl:420

alaksandus
Posts: 4
Joined: Tue Aug 23, 2016 1:19 pm

Re: Translation not saved

Post by alaksandus » Wed Jan 04, 2017 12:15 pm

Thorsten wrote:Hi,

please upgrade to 2.9.5 first.

bye
Thorsten
Any suggestions?

Thorsten
Posts: 14434
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Translation not saved

Post by Thorsten » Thu Jan 05, 2017 8:57 pm

Hi,

I will take a look at it.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest