Upgrad from 2.8 to 2.9 issue

Please report bugs here!

Moderator: Thorsten

Post Reply
romainp
Posts: 21
Joined: Mon May 09, 2016 4:14 pm

Upgrad from 2.8 to 2.9 issue

Post by romainp » Sat May 14, 2016 3:52 pm

Hi,
I got this error running the upgrade:

DB error: ERROR: syntax error at or near "(" LINE 1: ALTER TABLE faquser ADD success INT(1) NULL DEFAULT 1 ^

Can you help?
Thanks!
R.

romainp
Posts: 21
Joined: Mon May 09, 2016 4:14 pm

Re: Upgrad from 2.8 to 2.9 issue

Post by romainp » Sat May 14, 2016 3:58 pm

Hi,
I was able to run the sql command by habd without any issue and the setup finished ok but now I have a blank page when I access my phpmyfaq site.
The logs show this:

[Sat May 14 10:56:24.971410 2016] [:error] [pid 27589] [client 192.168.1.61:60246] phpMyFAQ warning: pg_query(): Query failed: ERROR: column fc.group_id does not exist\nLINE 9: fc.group_id AS group_id,\n ^ in /var/www/html/phpmyfaq/inc/PMF/DB/Pgsql.php on line 112
[Sat May 14 10:56:25.003291 2016] [:error] [pid 27589] [client 192.168.1.61:60246] phpMyFAQ warning: pg_query(): Query failed: ERROR: column fd.updated does not exist\nLINE 5: fd.updated AS updated,\n ^ in /var/www/html/phpmyfaq/inc/PMF/DB/Pgsql.php on line 112
[Sat May 14 10:56:25.003371 2016] [:error] [pid 27589] [client 192.168.1.61:60246] phpMyFAQ warning: pg_fetch_object() expects parameter 1 to be resource, boolean given in /var/www/html/phpmyfaq/inc/PMF/DB/Pgsql.php on line 142
[Sat May 14 10:56:25.005605 2016] [:error] [pid 27589] [client 192.168.1.61:60246] phpMyFAQ warning: pg_query(): Query failed: ERROR: column fd.updated does not exist\nLINE 7: fd.updated AS updated,\n ^ in /var/www/html/phpmyfaq/inc/PMF/DB/Pgsql.php on line 112
[Sat May 14 10:56:25.005659 2016] [:error] [pid 27589] [client 192.168.1.61:60246] phpMyFAQ warning: pg_fetch_object() expects parameter 1 to be resource, boolean given in /var/www/html/phpmyfaq/inc/PMF/DB/Pgsql.php on line 142

Thorsten
Posts: 14776
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrad from 2.8 to 2.9 issue

Post by Thorsten » Sat May 14, 2016 7:37 pm

Hi,

well, other update queries are now missing. I fixed the query for 2.9.1.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

romainp
Posts: 21
Joined: Mon May 09, 2016 4:14 pm

Re: Upgrad from 2.8 to 2.9 issue

Post by romainp » Sat May 14, 2016 9:36 pm

No problem, I will wait for the 2.9.1 :) Thanks!
R.

Post Reply