Upgrade from 2.8.3 to 2.9.6 Failed

Please report bugs here!

Moderator: Thorsten

Post Reply
grason
Posts: 8
Joined: Mon Feb 03, 2014 8:46 pm

Upgrade from 2.8.3 to 2.9.6 Failed

Post by grason » Fri Feb 17, 2017 12:44 pm

Good Morning.

This morning I attempted an upgrade from 2.8.3 to 2.9.6 using the Softaculous Installer but the process did not
work properly.

The first error I encountered was that the installer reported that the PHP Version Number needed to be 5.5.0 or later.
We corrected that problem using the CPANEL Feature which allows the site owner to change the version number to 5.5.

I then ran the Softaculous Installer and, as there were no longer a version error, permitted to run.
The process appeared to run to completion and updated the Installer to report that the version was now 2.9.6.
I was then presented with the screen which provided the instructions on how to complete the update using the path
../setup/updated.php.

This path did not work and gave a 404 Error.

After spending more time troubleshooting it was concluded that the installation was, somehow, corrupted.
The application still ran, showing Version 2.8.3, but Softaculous reported 2.9.6....and then "recognized" that there
was a version mismatch.

Attached please find screenshots of the problems.

Any help will be appreciated.
However, it may be easier to install a new copy of PHPMYFAQ and "point" to the existing DBMS....

Thanks,

Mike
Grason Software & Systems, Inc.
You do not have the required permissions to view the files attached to this post.
======================================
Grason Software & Systems, Inc.
Where Business & Technology Come Together

Thorsten
Posts: 14434
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade from 2.8.3 to 2.9.6 Failed

Post by Thorsten » Sat Feb 18, 2017 8:06 pm

Hi,

I don't know what Softaculous is changing in the software, but if phpMyFAQ reports 2.8 it is still on 2.8. Maybe you use the normal package from our homepage.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

grason
Posts: 8
Joined: Mon Feb 03, 2014 8:46 pm

Re: Upgrade from 2.8.3 to 2.9.6 Failed

Post by grason » Sun Feb 19, 2017 7:34 pm

Thoreston,

Thank you for the reply.
Please feel free to archive this post, as there seemed to be a one-off problem
associated with the hosted server.

I am resolving the problem by exporting the FAQCategories table, removing the
original (i.e., the 2.8.3) installation, and performing a new installation of 2.9.6.

Thank you

Mike
======================================
Grason Software & Systems, Inc.
Where Business & Technology Come Together

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest