Problem: activation elasticsearch

Please report bugs here!

Moderator: Thorsten

circa138
Posts: 27
Joined: Wed Mar 15, 2017 10:27 am

Problem: activation elasticsearch

Post by circa138 » Fri Mar 17, 2017 11:05 am

Hello,

my instance of your FAQ is working very well so far.
When im going to activate the elasticsearch-plugin in the admin configuration menu, the "System Information" and the new "Elasticsearch configuration" menu just showing a blank page (uploaded Attachement).
I´ve successful started an elastic-search-service with starting the elasticsearch.bat, with the correct IP like in the config file.
What did i wrong ?

btw. : Is it true that none of your Demo FAQ´s got an active elasticsearchplugin?

Thanks
You do not have the required permissions to view the files attached to this post.

Thorsten
Posts: 14400
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem: activation elasticsearch

Post by Thorsten » Sun Mar 19, 2017 1:02 pm

Hi,

we don't have any Elasticsearch instance running in our demos.

Please enable the debug mode to see the errors regarding Elasticsearch.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

circa138
Posts: 27
Joined: Wed Mar 15, 2017 10:27 am

Re: Problem: activation elasticsearch

Post by circa138 » Mon Mar 20, 2017 7:59 am

Hi, 2.9.6, on the configuration Elasticsearch page:
phpMyFAQ notice [8]: Undefined index: core.elasticsearch in C:\xampp\htdocs\faq\inc\PMF\Configuration.php on line 321

phpMyFAQ notice [8]: Undefined index: core.elasticsearch in C:\xampp\htdocs\faq\inc\PMF\Configuration.php on line 321

phpMyFAQ notice [8]: Undefined index: core.elasticsearch in C:\xampp\htdocs\faq\inc\PMF\Configuration.php on line 321

Fatal error: Call to a member function indices() on null in C:\xampp\htdocs\faq\admin\elasticsearch.php on line 37

In System Information:
phpMyFAQ notice [8]: Undefined index: core.elasticsearch in C:\xampp\htdocs\faq\inc\PMF\Configuration.php on line 321

Fatal error: Call to a member function cat() on null in C:\xampp\htdocs\faq\admin\system.php on line 38

Thorsten
Posts: 14400
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem: activation elasticsearch

Post by Thorsten » Wed Mar 22, 2017 7:13 am

Hi,

did you create an index in the admin backend?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

circa138
Posts: 27
Joined: Wed Mar 15, 2017 10:27 am

Re: Problem: activation elasticsearch

Post by circa138 » Wed Mar 22, 2017 9:13 am

hi,

no, should i ? and where do i can manipulate indices anyway :D

Thorsten
Posts: 14400
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem: activation elasticsearch

Post by Thorsten » Wed Mar 22, 2017 9:14 am

Hi,

yes, you have to! Otherwise there's no index. :)

You can manipulate the index after creation.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

circa138
Posts: 27
Joined: Wed Mar 15, 2017 10:27 am

Re: Problem: activation elasticsearch

Post by circa138 » Wed Mar 22, 2017 9:33 am

thanks for the quick answer.

in the database ? cause theres no entry in the backend or im just blind?

Thorsten
Posts: 14400
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem: activation elasticsearch

Post by Thorsten » Wed Mar 22, 2017 9:37 am

Hi,
Bildschirmfoto 2017-03-22 um 09.34.48.png
you can enable the support in the admin search configuration. After adding the elasticsearch.php configuration file in /config you should see the Elastic search configuration panel in the admin section. The config/elasticsearch.php file could look like this:

Code: Select all

<?php
$PMF_ES['hosts'] = ['127.0.0.1:9200'];
$PMF_ES['index'] = 'phpmyfaq';
$PMF_ES['type'] = 'faqs';
bye
Thorsten
You do not have the required permissions to view the files attached to this post.
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

circa138
Posts: 27
Joined: Wed Mar 15, 2017 10:27 am

Re: Problem: activation elasticsearch

Post by circa138 » Wed Mar 22, 2017 9:42 am

ah nvm, of course i activated the elasticsearch support, otherwise the menu in my uploaded screenshot would be invisible and i couldnt even reach the elasticsearch configuration page that leads to a blank page. :/
phpMyFAQ notice [8]: Undefined index: core.elasticsearch in C:\xampp\htdocs\faq\inc\PMF\Configuration.php on line 321

phpMyFAQ notice [8]: Undefined index: core.elasticsearch in C:\xampp\htdocs\faq\inc\PMF\Configuration.php on line 321

phpMyFAQ notice [8]: Undefined index: core.elasticsearch in C:\xampp\htdocs\faq\inc\PMF\Configuration.php on line 321

Fatal error: Call to a member function indices() on null in C:\xampp\htdocs\faq\admin\elasticsearch.php on line 37

Thorsten
Posts: 14400
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem: activation elasticsearch

Post by Thorsten » Wed Mar 22, 2017 9:44 am

Hi,

can you please try to add an index manually in Elasticsearch?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Thorsten
Posts: 14400
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem: activation elasticsearch

Post by Thorsten » Wed Mar 22, 2017 10:07 am

Hi,

re-checked the source code. Did you have the config file config/elasticsearch.php?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

circa138
Posts: 27
Joined: Wed Mar 15, 2017 10:27 am

Re: Problem: activation elasticsearch

Post by circa138 » Wed Mar 22, 2017 1:03 pm

Hi,

nope, just the "original" ;)
You do not have the required permissions to view the files attached to this post.

Thorsten
Posts: 14400
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem: activation elasticsearch

Post by Thorsten » Wed Mar 22, 2017 1:04 pm

Hi,

you need that file :)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

circa138
Posts: 27
Joined: Wed Mar 15, 2017 10:27 am

Re: Problem: activation elasticsearch

Post by circa138 » Wed Mar 22, 2017 1:08 pm

Thorsten wrote:Hi,

you need that file :)

bye
Thorsten
so i just rename the file and remove the ".original"?
Im feeling dumb now, but that wasnt really obvious for me :D

Thorsten
Posts: 14400
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem: activation elasticsearch

Post by Thorsten » Wed Mar 22, 2017 1:09 pm

Hi,

no worries. Just add it like I posted above.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest