Fehlerhafte Suchergebnisse bei Artikeln mit Bildern (base64)

Please report bugs here!

Moderator: Thorsten

Post Reply
dk123
Posts: 1
Joined: Mon Apr 24, 2017 11:51 pm

Fehlerhafte Suchergebnisse bei Artikeln mit Bildern (base64)

Post by dk123 » Tue Apr 25, 2017 12:04 am

Hallo,

folgender Fehler tritt auf:

Wenn ich die Suchfunktion verwende, bekomme ich teilweise Suchergebnisse angezeigt, die gar nichts mit dem Thema zu tun haben.
Ein Beispiel:
Ich gebe in der Suche nfl ein und bekomme FAQ-Einträge angezeigt, wo im kompletten Text überhaupt kein nfl vorkommt.
Nach stundenlangem Suchen wo der Fehler liegen könnte, meine ich, diesen nun gefunden zu haben. Im oben genannten Beispiel wird mir mit STRG+F im FAQ-Eintrag kein nfl angezeigt, schaue ich mir aber den Quelltext des entsprechenden FAQ-Eintrages an, und suche in diesem, bekomme ich haufenweise Matches zu nfl, allerdings NUR im Base64-String der Bilder.

Besteht die Möglichkeit, die Suche irgendwie anzupassen, dass sie nicht in <img> Tags sowie in Base64-Strings sucht?
Oder eine Möglichkeit, die Bilder anders einzubinden, dass diese nicht als Base64 codiert werden?

Betreffende phpmyadmin Version ist sowohl 2.9.5 als auch 2.9.7 (hatte gehofft, mit der neuen Version verschwindet der Fehler, aber nach der Übernahme einiger FAQ-Einträge und erstem Suchen trat der Fehler wieder auf)

Falls noch weitere Infos benötigt werden oder der Fehler unklar ist, einfach fragen.

Edit: Problem tritt bei 2.9.7 sowohl ohne Elasticsearch als auch mit Elasticsearch auf.
Edit 2: Und es ist egal, ob man die Ajax-Suche oder die Erweiterte Suche verwendet, Fehler tritt bei beidem auf.

Thorsten
Posts: 14431
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Fehlerhafte Suchergebnisse bei Artikeln mit Bildern (base64)

Post by Thorsten » Tue Apr 25, 2017 7:02 pm

Hi,

ich glaube, es wäre wohl besser, beim Indizieren des Textes der FAQ in Elasticsearch alles an HTML herauszufiltern. Das baue ich mal ein.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Thorsten
Posts: 14431
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Fehlerhafte Suchergebnisse bei Artikeln mit Bildern (base64)

Post by Thorsten » Tue Apr 25, 2017 7:06 pm

Hi,

das ist der Bugfix: https://github.com/thorsten/phpMyFAQ/co ... e0d6291bdb

Feedback wäre klasse!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests