Gruppenrechte in 2.0.8 nicht setzbar

Please report bugs here!

Moderator: Thorsten

Post Reply
stylus740
Posts: 64
Joined: Sat Apr 01, 2006 6:29 pm

Gruppenrechte in 2.0.8 nicht setzbar

Post by stylus740 » Sat Sep 27, 2008 10:15 am

Hallo,

Nur, um mich zu vergewissern: Um Gruppenrechte zu setzen, klicke ich im linken Fenster "Gruppen" die gewünschte Gruppe an und wähle dann ganz rechts dir gewünschten Rechte aus, zuletzt wird auf 'Speichern' in der Rechte-Box geklickt. Klicke ich dann auf die Gruppe, werden die gewählten Rechte gezeigt, richtig?

So geht das jedenfalls bei einer bestehenen 2.0.2 FAQ

Das funktioniert NICHT bei meiner 2.0.8 Version. Hier haben alle Gruppen immer volle Admin Rechte. Egal, was ich wegnehme, oder wie die Gruppe heisst, egal was ich klicke: Am Ende hat die Gruppe immer volle Adminrechte.

Bye

Lidio
Posts: 25
Joined: Mon Dec 10, 2007 9:26 pm

Post by Lidio » Wed Oct 08, 2008 11:18 pm

Sorry I had to use google translate on this post -- I have the same issue that ALL rights show up for every user and every group after upgrading to 2.0.8. Although looking at the "rights" tables in the DB with phpMyAdmin does reveal correct rights. It seems the "actions" for adding/removing rights appear to be functioning, just the display is not correct.

Lidio.

Thorsten
Posts: 14759
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Fri Oct 10, 2008 10:51 am

Hi,

I fixed this bug in SVN. The 2.0.9 release will include this bugfix.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Lidio
Posts: 25
Joined: Mon Dec 10, 2007 9:26 pm

Post by Lidio » Fri Oct 10, 2008 3:49 pm

Thorsten wrote:Hi,

I fixed this bug in SVN. The 2.0.9 release will include this bugfix.

bye
Thorsten
Hi Thorsten,

thanks for the fix (I'll check the SVN), as always your fixes are much appreciated. I also had tracked it down to recent changes to 2.0.8 to ./inc/PMF_User/PermBasic.php and ./inc/PMF_User/PermMedium.php and the test for results after the query. To me the part was from the PHP docs "Use mysql_num_rows() to find out how many rows were returned for a SELECT statement" which is how it was being handled in version 2.0.7 and earlier. I fixed it in my test version by replacing these two with the older version as there were no other changes in the file.

Regards,
Lidio

Thorsten
Posts: 14759
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Fri Oct 10, 2008 3:52 pm

Hi,

we had some problems with the move from CVS to SVN between 2.0.7 and 2.0.8. If you see any problems in SVN, please report them to me.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

johntan2005
Posts: 1
Joined: Mon Nov 17, 2008 3:29 am

Post by johntan2005 » Mon Nov 17, 2008 3:24 pm

Hi, this bug still exist in version 2.0.9

Thorsten
Posts: 14759
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Tue Nov 18, 2008 8:14 am

Hi,

I take a look at it.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply