Immer Error 404

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
pekawe
Posts: 7
Joined: Mon Oct 12, 2009 10:51 am

Immer Error 404

Post by pekawe » Mon Oct 12, 2009 11:08 am

Hi,

ich habe eben versucht phpMyFAQ auf Windows zum laufen zu bringen. Das funktionierte dank der super Doku sehr schnell und einfach.
Nun habe ich mal einen Testeintrag erstellt und musste feststellen dass ich diese nicht öffnen kann. Genauer gesagt funktioniert praktisch kein Link der Startseite.
Diese verweise alle auf Seiten, die es in meiner Installation garnicht gibt. Z.B.: http://x.x.x.x/faq/showcat.html oder der Artikel: http://x.x.x.x/faq/content/2/1/de/was-i ... tlich.html

Wenn ich über den Adminlogin den Artikel ändern will ist das kein Problem, dannn wird aber auch nicht direkt auf ein HTML verlinkt sondern: http://x.x.x.x/faq/admin/index.php?acti ... =1&lang=de

Ich habe nun mal im Netz geschaut und einige FAQs powerd by phpMyFAQ gefunden. Sowohl welche die über die Index.php mit parametern arbeiten: (z.B.: http://www.ibk-group.de/faq/Index.php?action=show&cat=9) als auch welche die direkt auf die HTML-Seite verweisen (http://webmasterwiki.net/phpmyfaq/category/8/unix.html)


Wahrscheinlich ist es nur ein Kleinigkeit die ich verkehrt mache, aber ich habe abolut keine Idee.

Ich wäre begeistert wenn mir jemand helfen kann.

Danke im voraus.

Gruß,
Peter

Thorsten
Posts: 14730
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Immer Error 404

Post by Thorsten » Mon Oct 12, 2009 11:23 am

Hi,

deaktiviere im Adminbereich einfach die Einstellung für mod_rewrite.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pekawe
Posts: 7
Joined: Mon Oct 12, 2009 10:51 am

Re: Immer Error 404

Post by pekawe » Mon Oct 12, 2009 1:23 pm

Ich bin ja auch sooo doof! Hab extra noch die _.htaccess und die Konfiguration des Apache kontrolliert, aber an den Haken natürlich nicht mehr gedacht.

Vielen Dank.
Nun werde ich mir dein Baby mal weiter anschauen.

Gruß,
Peter

P.S.: Ich hab auf einer Seite rechts eine Tagcloud gesehen. Ist das Standardfunktionalität von phpMyFAQ?

Thorsten
Posts: 14730
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Immer Error 404

Post by Thorsten » Mon Oct 12, 2009 1:26 pm

Hi,
pekawe wrote:P.S.: Ich hab auf einer Seite rechts eine Tagcloud gesehen. Ist das Standardfunktionalität von phpMyFAQ?
ja klar. :-)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pekawe
Posts: 7
Joined: Mon Oct 12, 2009 10:51 am

Re: Immer Error 404

Post by pekawe » Mon Oct 12, 2009 1:45 pm

Cool. Respekt!

Ich habe das Problem immer noch wenn ich den Absenden-Button verwende. Zum Beispiel beim stellen einer Frage (http://x.x.x.x/faq/?action=savequestion) oder speichern einer neuen FAQ (http://x.x.x.x/faq/?action=save)

Sag nicht dafür brauche ich mod_rewrite? :)

Sorry wenn ich hier etwas doof frage, ich habe mit webapps, apache und php noch nicht vel zu tun gehabt.

Gruß,
Peter

Thorsten
Posts: 14730
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Immer Error 404

Post by Thorsten » Mon Oct 12, 2009 1:52 pm

Hi,
pekawe wrote:Ich habe das Problem immer noch wenn ich den Absenden-Button verwende. Zum Beispiel beim stellen einer Frage (http://x.x.x.x/faq/?action=savequestion) oder speichern einer neuen FAQ (http://x.x.x.x/faq/?action=save)

Sag nicht dafür brauche ich mod_rewrite? :)
nein... bekommst du da einen 404er?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pekawe
Posts: 7
Joined: Mon Oct 12, 2009 10:51 am

Re: Immer Error 404

Post by pekawe » Mon Oct 12, 2009 4:11 pm

Ja, eben jener wieder.

Gruß,
Peter

Thorsten
Posts: 14730
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Immer Error 404

Post by Thorsten » Mon Oct 12, 2009 5:01 pm

Hi,

dann fehlt dir ein DirectoryIndex in deiner httpd.conf vom Apachen.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pekawe
Posts: 7
Joined: Mon Oct 12, 2009 10:51 am

Re: Immer Error 404

Post by pekawe » Wed Dec 16, 2009 11:30 am

Hi,

sorry, dass ich so lange nicht geantwortet habe. Ich durfte einige Zeit im Krankenhaus verbringen.

In der httpd.conf habe ich folgendes gefunden:

#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
#
<IfModule dir_module>
DirectoryIndex index.html
</IfModule>


und

LoadModule dir_module modules/mod_dir.so

Da ich mit phpMyFAQ auch das erste mal mit Apache zu tun habe sagt mir das leider gar nichts.
Ist das so richtig? Muss ich noch etwas tun?

Noch eine Frage zur Tagcloud. Muss ich die rgendwo einschalten oder so?

Danke und Gruß,
Peter

Thorsten
Posts: 14730
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Immer Error 404

Post by Thorsten » Wed Dec 16, 2009 11:34 am

Hi,
pekawe wrote:sorry, dass ich so lange nicht geantwortet habe. Ich durfte einige Zeit im Krankenhaus verbringen.
oh, ich hoffe, es geht dir wieder besser.

Der DirectoryIndex muss so aussehen:

Code: Select all

#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
#
<IfModule dir_module>
    DirectoryIndex index.html index.php
</IfModule>
Dann ist der 404er weg.
pekawe wrote:Noch eine Frage zur Tagcloud. Muss ich die rgendwo einschalten oder so?
Nein, die erscheint, wenn du Tags hast, automatisch.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pekawe
Posts: 7
Joined: Mon Oct 12, 2009 10:51 am

Re: Immer Error 404

Post by pekawe » Mon Dec 21, 2009 4:13 pm

Hi,

vielen Dank, das funktioniert jetzt auch.
Das mit den Tags habe ich gefunden. Die werden im Standard wohl nur angezeigt wenn man eine Suche durchgeführt hat.
Ich wollte die Tagcloude gern gleich auf der Startseite haben. Wenn ich sie in den rechten Seitenbereich schiebe funktioniert das auch bestens. im linken Seitenbereich, der bei mir nicht so überfrachtet ist, wird der Platzhalter für die Tagcloude leider nicht aufgelöst.

Gibt es hier einen Trick?

Gruß,
Peter.

P.S.: Hatte mir den Fuß etwas zerstört. Nichts was man mit einer OP und viel Physiotherapie nicht hinbekommen würde.;-)

Thorsten
Posts: 14730
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Immer Error 404

Post by Thorsten » Mon Dec 21, 2009 6:41 pm

Hi,

da musst du etwas vom Code ändern, sonst geht das nicht. Ich kann dir aber gerne zeigen, was du ändern musst.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pekawe
Posts: 7
Joined: Mon Oct 12, 2009 10:51 am

Re: Immer Error 404

Post by pekawe » Wed Dec 23, 2009 10:51 am

Hi Thorsten,

das wäre super wenn Du mir da ein wenig helfen könntest.
Ich habe schon ein wenig gebraucht um die Templates zu verstehen, welches wofür zuständig ist und so. ;-)
Ich habe mit Webprogrammierung nicht viel am Hut.

Mein Gedanke war das standardlayout so zu lassen wie es ist und die Tagcloud schon auf der Startseite unten links mit anzuzeigen.

Danke und Gruß,
Peter

Post Reply