Voting issue

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
der.vogt
Posts: 11
Joined: Thu Jan 07, 2010 4:05 pm
Location: Amsterdam
Contact:

Voting issue

Post by der.vogt » Thu Jan 07, 2010 4:15 pm

Hello,

I am currently experiencing a strange issue with the voting functionality on my phpmyFaq 2.5.6.

I am constantly receiving a 404 Error when I am logged in to PhpmyFaq when trying to vote for a particular FAQ entry.
When I am not logged in, everything works fine and the Votes are visible in the backend.
What I could have seen is the fact, that the URL get rewritten when I am logged in to the following value:

Code: Select all

http://vogt-familie.nl/nedstatkb/Index.phpindex.php?action=savevoting
It doubles the index.php in the case of logged in voting.The reqrite option is currently not enabled, but I have also tested it with activated rewrite with usage of the "standard" httpd.ini.

When a user is not logged in, the vote works as normal and the URL is not getting rewritten.

The same problem occurs, when I try to edit a FAQ entry from the frontend instead of editing from the admin-backend

Here the overview from the Backend Dashboard to give some technical params:

Code: Select all

    phpMyFAQ 2.5.6
Server Software
    Microsoft-IIS/6.0
PHP Version
    PHP 5.2.6
Register Globals
    off
Safe Mode
    off
Open Basedir
    off
Database Server
    Mysql
Database Client Version
    5.0.22
Database Server Version
    5.0.45-community-nt
Webserver Interface
    ISAPI
PHP Extensions
    bcmath, calendar, com_dotnet, ctype, session, filter, ftp, hash, iconv, json, odbc, pcre, Reflection, date, libxml, standard, tokenizer, zlib, SimpleXML, dom, SPL, wddx, xml, xmlreader, xmlwriter, ISAPI, curl, gd, gettext, imap, mbstring, mssql, mysql, PDO, pdo_sqlite, sockets, SQLite, xsl
Any idea how to fix this? If you people need further information (techical or so) please do not hesitate to request this, I will try to provide ASAP.

Thank you in advance for your help on this

Thorsten
Posts: 14720
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Voting issue

Post by Thorsten » Fri Jan 08, 2010 10:30 am

Hi,
der.vogt wrote:

Code: Select all

http://vogt-familie.nl/nedstatkb/Index.phpindex.php?action=savevoting
I tested it and I cannot reproduce this on my test systems. Where does the "Index.php" come from?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

der.vogt
Posts: 11
Joined: Thu Jan 07, 2010 4:05 pm
Location: Amsterdam
Contact:

Re: Voting issue

Post by der.vogt » Fri Jan 08, 2010 12:01 pm

I have downloaded the whole update package yesterday and have upgraded from 2.5.4 to 2.5.6, I had the same issue on the 2.5.4.

All files are original from your download site, no modifications.

If you want you can take a look at the site itself, I have sent you a PM with the detailed informations for replication.

UPDATE: 08-01-2010 12:11 CEST:

ISSUE FIXED, Made a stupid mistake and had a wrong entry in the htaccess file which added the second index.php, Thank you for the quick help on this, please disregard PM.

Thorsten
Posts: 14720
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Voting issue

Post by Thorsten » Fri Jan 08, 2010 12:24 pm

Hi,

ah... good news. :-)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply