[Closed] Installation with Oracle

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
wizdom
Posts: 2
Joined: Sun Dec 19, 2010 12:59 pm

[Closed] Installation with Oracle

Post by wizdom » Sun Dec 19, 2010 1:13 pm

Hi,

I'm currently trying to setup phpMyFaq 2.6.13 under Windows XP with a WAMP Server (Apache 2.2.11 and PHP 5.3.0).

Instead of MySQL, I want to use my Oracle XE database. So I've modified my php.ini to enable " extension=php_oci8.dll ". In order to check that the relation between PHP and Oracle is OK, I created a php file containing this little Oracle check :

Code: Select all

<?php
 if ($c = oci_connect("hr", "hr", "localhost/XE")) {
   echo "Successfully connected to Oracle.";
   oci_close($c);
 } else {
   $err = oci_error();
   echo "Oracle Connect Error " . $err['text'];
 }
 ?>
When I launch this page, it returns "Successfully connected to Oracle", so I know my server is now well configured.

Unfortunately, when I launch phpmyfaq setup, I can't select Oracle in the database combobox :

Image

I can't find anything about Oracle in the documentation ? Is it still supported ?
Last edited by wizdom on Thu Dec 23, 2010 11:33 am, edited 1 time in total.

Thorsten
Posts: 14722
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation with Oracle

Post by Thorsten » Sun Dec 19, 2010 7:11 pm

Hi,

we dropped the support for Oracle because almost no one used it and we got no feedback from the community.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

wizdom
Posts: 2
Joined: Sun Dec 19, 2010 12:59 pm

Re: Installation with Oracle

Post by wizdom » Thu Dec 23, 2010 11:33 am

OK thanks for you answer.

Merry Christmas to all :P

Post Reply