Ldap sucht keinen Nutzernamen

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
fahl5
Posts: 12
Joined: Mon Jun 27, 2011 4:19 pm

Ldap sucht keinen Nutzernamen

Post by fahl5 » Mon Jun 27, 2011 4:34 pm

Ich habe meinen OpenLDAP-Server erst nach der phpMyFAQ-Installation aufgesetzt. Ich habe daher meine Ldap-Daten per Editor in die Datei ldap.php eingetragen allerdings scheint mir da ein String zu fehlen, der überhaupt die Suche nach dem Nutzer selber bewirkt. Zumindest sucht phpMyFAQ offenbar nicht nach dem Nutzer und findet ihn dann natürlich auch nicht.
So sieht mein LDAP.php in etwa aus (hier natürlich nur eben nicht mit den Originaldaten.):

Code: Select all

<?php
$PMF_LDAP["ldap_server"] = 'ldap://ldap.mein.server';
$PMF_LDAP["ldap_port"] = '389';
$PMF_LDAP["ldap_user"] = 'cn=admin,dc=mein,dc=server';
$PMF_LDAP["ldap_password"] = 'adminpassword';
$PMF_LDAP["ldap_base"] = 'ou=user,dc=mein,dc=server';
Es wäre sehr nett, wenn jemand mir sagen, warum phpMyFAQ hier momentan noch die LDAP-Authetifikation verweigert, bzw. wie ich es trotzdem noch dazu bringen kann.
Danke und beste Grüße
fahl5

Thorsten
Posts: 14783
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Ldap sucht keinen Nutzernamen

Post by Thorsten » Tue Jun 28, 2011 2:56 pm

Hi,

hast du LDAP aktiviert in der Konfiguration? Welche Version verwendest du?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

fahl5
Posts: 12
Joined: Mon Jun 27, 2011 4:19 pm

Re: Ldap sucht keinen Nutzernamen

Post by fahl5 » Thu Jun 30, 2011 8:03 pm

Thorsten wrote:Hi,

hast du LDAP aktiviert in der Konfiguration? Welche Version verwendest du?

bye
Thorsten
Ja natürlich habe ich LDAP in der Konfiguration aktiviert.
Ich verwende Openldap. Bei den anderen Applikationen funktioniert alles, wenn ich Version 3 eingestellt habe.
Ein IT-Berater der sich das ganze mit Putty angesehen hat, meint phpMyFAQ, würde zwar den angegebenen Ordner mit den Nutzern finden, wüsste aber einfach nicht, dass es darin nach dem Namen suchen soll, der im Loginformular eingegeben wurde. Es fehle dafür seiner Meinung nach der nötige Searchstring.
Für einen Informatikdilletanten wie mich klingt das irgendwie nachvollziehbar, ob euch das wirklich weiterhilft, wisst ihr selber sicher besser.
Ich würde mich freuen, wenn es einen Weg gäbe das Login an den LDAP-Server anzubinden.
Gruß
Steffen

Thorsten
Posts: 14783
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Ldap sucht keinen Nutzernamen

Post by Thorsten » Sat Jul 02, 2011 11:39 am

Hi,

wie sieht denn deine LDAP Konfiguration in der Datei config/constants_ldap.php aus? Ich denke, da musst du was anpassen.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

fahl5
Posts: 12
Joined: Mon Jun 27, 2011 4:19 pm

Re: Ldap sucht keinen Nutzernamen

Post by fahl5 » Sun Jul 03, 2011 12:47 pm

Thorsten wrote:Hi,

wie sieht denn deine LDAP Konfiguration in der Datei config/constants_ldap.php aus? Ich denke, da musst du was anpassen.

bye
Thorsten
Ich nutze OpenLDAP. Ich vermute das passt das nicht mit den ADS-Mapping zusammen, das in constants_ldap.php eingetragen ist.
Die anderen Einstellungen in constants_ldap.php scheinen ja offenbar eher optional.
Wenn ich die Entsprechungen eintrage, die in phpLDAPadmin zu sehen sind, müsste doch eigentlich das hier eingetragen werden:

Code: Select all

    'name'     => 'cn',
    'username' => 'User Name',
    'mail'     => 'E-Mail');
Ich nehme aber an, dass Großbuchstaben und Leerzeichen sich da eigentlich nicht so gut machen.
Wenn ich mich an den Entsprechungen aus dem LDIF-Export orientiere stände da wohl:

Code: Select all

   'name'     => 'cn',
    'username' => 'uid',
    'mail'     => 'mail');
Beide Möglichkeiten haben aber meine Testnutzer bislang genausowenig erkannt wie das ADS-Mapping.
Vielleicht wisst ihr ja, was da für OpenLdap sonst stehen sollte.
Gruß
fahl5

Thorsten
Posts: 14783
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Ldap sucht keinen Nutzernamen

Post by Thorsten » Mon Jul 04, 2011 7:21 pm

Hi,

die Mapping Informationen sind schon wichtig, zwischen AD und OpenLDAP sind da einige Unterschiede bei der Abfrage. Ich denke, dein Mapping passt da noch nicht, kannst du in deiner Firma nicht nachfragen?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

fahl5
Posts: 12
Joined: Mon Jun 27, 2011 4:19 pm

Re: Ldap sucht keinen Nutzernamen

Post by fahl5 » Sun Jul 17, 2011 12:09 pm

1) Wonach sollte ich da überhaupt jemanden noch fragen?
- Ich habe doch hier alle Datenzuordnungen schon gepostet!

2) Habt ihr einmal die Verbindung mit Openldap getestet?
Gibt es überhaupt jemanden, der sein phpoMyFAQ über OpenLdap authentifizieren kann?

Gruß
fahl5

Thorsten
Posts: 14783
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Ldap sucht keinen Nutzernamen

Post by Thorsten » Sun Jul 17, 2011 6:50 pm

Hi,

ja, gibt es, einfach mal hier im Forum suchen. Ansonsten kann ich dir auch gerne per Mail einige Kontakte geben.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

fahl5
Posts: 12
Joined: Mon Jun 27, 2011 4:19 pm

Re: Ldap sucht keinen Nutzernamen

Post by fahl5 » Wed Aug 10, 2011 1:07 pm

Hi Thorsten,
Danke zunächst für deine Recherche und deinen Tipp. Das hat aber leider auch nicht wirklich geholfen. Es gibt einen Thread mit einem Beispiel für das Ausfüllen der ldap.php, aber keinen für die constants_ldap.php.

Ich glaube es braucht wohl doch noch eine klare Dokumentation hinsichtlich dessen, was man genau für welchen Typ LDAP-Server in die ldap.php und (!) die constants_ldap.php eintragen muss.
Es bleibt bei mir dabei, dass phpmyfaq die einzige von 7 Applikationen ist, die sich nicht mit unserem openLDAP-Server verbinden lässt.

Könnte man nicht z.B. versuchen, die erforderlichen Eingaben in Format und inhalt denen anderer LDAP-Schnittstellen soweit anzu gleichen, dass man eigentlich nur die vorhandenen Einträge z.B. von Drupal, Mediawiki, Moodle etc. hinüber kopieren muss?
Genau das geht momentan zumindest bei mir leider nicht.
Ich hoffe trotzdem, dass sich auch dieses Problem eines Tages lösen lässt und bin jedem dankbar, dem dazu ewtwas hilfreiches einfällt.

beste Grüße
fahl5

Thorsten
Posts: 14783
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Ldap sucht keinen Nutzernamen

Post by Thorsten » Wed Aug 10, 2011 1:30 pm

Hi,

wenn du mir die Konfig der anderen Systeme mal schickst, dann kann ich das erforschen.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

fahl5
Posts: 12
Joined: Mon Jun 27, 2011 4:19 pm

Re: Ldap sucht keinen Nutzernamen

Post by fahl5 » Thu Aug 11, 2011 8:26 am

Thorsten wrote:Hi,

wenn du mir die Konfig der anderen Systeme mal schickst, dann kann ich das erforschen.

bye
Thorsten
Hier kann man eine anonymisierte Version der funktionierenden Moodle und elgg Daten sehen.
http://moodle.org/mod/forum/discuss.php ... 56#p785362
Ich hoffe das hilft bei der Klärung.
Eigentlich düfte da phpmyfaq doch auch nicht so weltbewegend viel anderes kommunizieren oder?
gruß
Steffen

Thorsten
Posts: 14783
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Ldap sucht keinen Nutzernamen

Post by Thorsten » Tue Aug 16, 2011 12:32 pm

Hi,

das müsste so aussehen:

Code: Select all

// Datamapping - in this example for an ADS
$PMF_LDAP['ldap_mapping'] = array (
    'name'     => 'cn',
    'username' => 'givenname',
    'mail'     => 'mail'
);

// In a multi-domain environment, users may enter a prefix as domain, e.g. "DOMAIN\username"
// If possible, you should use the Microsoft Glocal Catalog as LDAP-Server, which comes
// with every ADS-Installation.
$PMF_LDAP['ldap_use_domain_prefix'] = false;

// LDAP-options to set
// refer to the documentation of ldap_set_option() for information on available options
$PMF_LDAP["ldap_options"] = array (
    LDAP_OPT_PROTOCOL_VERSION => 3,
    LDAP_OPT_REFERRALS        => 0 );

// Option for adding a check on LDAP groups
// Default: false
$PMF_LDAP['ldap_use_memberOf'] = false;
$PMF_LDAP['ldap_mapping']['memberOf'] = '';

// Option for binding to LDAP directory using SASL
// Default: false
$PMF_LDAP['ldap_use_sasl'] = false;
Ohne Gewähr, ich bin kein LDAP-Experte...

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

fahl5
Posts: 12
Joined: Mon Jun 27, 2011 4:19 pm

Re: Ldap sucht keinen Nutzernamen

Post by fahl5 » Sun Aug 21, 2011 3:38 pm

Puhhhhhhhh ! :oops:
...
Es geht !!!!!!!! :lol:
Damit ist mein SSO komplett
Danke Dank, Danke Thorsten, damit steigt auch dein cooles FAQ-System zum vollwertigen Teil unserer Infrastruktur auf :P
beste Grüße
Steffen

Thorsten
Posts: 14783
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Ldap sucht keinen Nutzernamen

Post by Thorsten » Sun Aug 21, 2011 6:47 pm

Hi,

coole Sache! :-)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Compadre
Posts: 2
Joined: Fri Jun 22, 2012 5:39 pm

Re: Ldap sucht keinen Nutzernamen

Post by Compadre » Fri Jun 22, 2012 5:42 pm

fahl5 wrote:
Thorsten wrote:Hi,

wenn du mir die Konfig der anderen Systeme mal schickst, dann kann ich das erforschen.

bye
Thorsten
Hier kann man eine anonymisierte Version der funktionierenden Moodle und elgg Daten sehen.
http://moodle.org/mod/forum/discuss.php ... 56#p785362
Ich hoffe das hilft bei der Klärung.
Eigentlich düfte da phpmyfaq doch auch nicht so weltbewegend viel anderes kommunizieren oder?
gruß
Steffen
Eigentlich ist die Kommunikation grundlegend die Gleiche. Weiß auch nicht, wieso es inkompatibel sein sollte.
With my mommy on my mind and my mind on my mommy :)

Post Reply