data base users host is incorrect

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
bamstead
Posts: 3
Joined: Sat Feb 04, 2012 7:40 am

data base users host is incorrect

Post by bamstead » Sat Feb 04, 2012 7:57 am

This has become a windmill for me. I could go and change the mysql users host parameter, but I want to be hard headed. I have a couple of virtual servers on a hosts, when I attempt to install phpMyFAQ I get a database connection error. It is pointing to the correct data base user but the @'hostname' is another site on the same server. (It to uses PHP) I pulled the site off the server and have looked through all but apparently the correct files to see where it is called. This is the error... Access denied for user 'myfaq_user'@'xxx.xxxxxx.net' (using password: YES) I understand why it's not connecting, I just dont understand why it is using the wrong host in the user name. I did try to use 'myfaq_user'@'the-correct.name.net' But the install script just added the '@'xxx.xxxxxx.net' to the end of it.
Your help in my understanding this would be greatly appreciated!

Thorsten
Posts: 14640
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: data base users host is incorrect

Post by Thorsten » Sat Feb 04, 2012 1:21 pm

Hi,

any default values in your php.ni file?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

bamstead
Posts: 3
Joined: Sat Feb 04, 2012 7:40 am

Re: data base users host is incorrect

Post by bamstead » Sat Feb 04, 2012 4:22 pm

Thanks for the reply.

No phpinfo () shows all the mysql values set to the defaults. When I looked at the php.ini file all the values were blank.

The mysql.allow_persistent is set to on (default) that is the only one that worries me. I did have a an open connection with another mysql user on another site on the server. But I have taken that site down, removed the files from /etc/apache2/sites-enabled.

The configuration is debian running on Virtual Box's. It's a test/learning environment. Both the mysql server and apache server running debian stable.

I did try to take it to it's most basic level. running it on the /var/www/ root. and systems "real" FQDN. I also renamed my phpMyFaq directory and created a new one in /var/www/.

I am being stubborn, because I want to better understand how things are working. I know it's easy enough to change the grant on the database, but that seems like a work around and not a fix...

Thanks again for your time and help.

bamstead
Posts: 3
Joined: Sat Feb 04, 2012 7:40 am

Re: data base users host is incorrect

Post by bamstead » Sat Feb 04, 2012 6:46 pm

"an inn is just an inn, not a castle"

Sorry for all the trouble... I am guessing at this time my trouble is some where in how I hacked my name resolution.... (host files) any way. I figured out that the error was in mysql. I flushed the host with mysqladmin and got rid of my stuck name. I got an incorrect address, but it at least indicated that my architecture was the problem...

I ended up dropping the users that accessed the database from this host, and re-adding them with the actual host name, not the sites name. It will mean taking this into account when I will eventually move them, hopefully I will remember when that occurs.

All database tables were successfully created.
Congratulation! Everything seems to be okay.

Thanks!

Thorsten
Posts: 14640
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: data base users host is incorrect

Post by Thorsten » Sat Feb 04, 2012 7:35 pm

Cool!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests