Reverse proxy

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
chrajsiel
Posts: 44
Joined: Tue Nov 06, 2012 1:53 pm

Reverse proxy

Post by chrajsiel » Wed Nov 14, 2012 4:14 pm

Hi, it's me again.

Need your help figuring out what the problem is. I'm not a DBA so I will explain it to the best of my ability. Everything is set up, phpmyfaq 2.7.9 downloaded, webserver, url has been created. But then, when we try to access the link, somewhere the link is broken. I was told that the problem is in the reverse proxy wherein the information from the backend server is lost in between the process. The site always goes back to the host. Does anyone have any idea what it is and how to fix it?

Thanks for any information that you may provide.

Regards,

chrajsiel

Thorsten
Posts: 14649
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Reverse proxy

Post by Thorsten » Wed Nov 14, 2012 8:40 pm

Hi,

you can change the URL in the admin configuration to the reverse proxy URL

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

chrajsiel
Posts: 44
Joined: Tue Nov 06, 2012 1:53 pm

Re: Reverse proxy

Post by chrajsiel » Thu Nov 15, 2012 8:53 am

It doesn't help. Changed the URL, cleared cache and restarted. It's the same.

Thorsten
Posts: 14649
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Reverse proxy

Post by Thorsten » Thu Nov 15, 2012 8:55 am

Hi,

then please explain what is broken exactly.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

chrajsiel
Posts: 44
Joined: Tue Nov 06, 2012 1:53 pm

Re: Reverse proxy

Post by chrajsiel » Thu Nov 15, 2012 9:08 am

I'll try to explain it as how I understood it from our network administrator.

The network administrator installed PHPMyFAQ on a localhost (kbphpfaq-dev.int). Then he created a URL for us at the backend server. Using the reverse proxy, we should be able to access phpmyfaq using http://ourdomain.int/dev/kbphpfaq, instead of the localhost, right? And if we navigate through the website, it should still show http://ourdomain.int/dev/kbphpfaq/.... The problem is, when we use http://ourdomain.int/dev/kbphpfaq, it showed the frontpage in a tree format without stylesheets. If we click on any options like All Categories, we would get an error message saying

"503 Service Unavailable
Failed to resolve the name of server kbphpfaq-dev.int"
because it is pointing to the localhost.

So, it looks like communication is broken or information coming from the backend server is not being sent/received?

I hope I'm able to explain the situation clearly.

chrajsiel

Thorsten
Posts: 14649
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Reverse proxy

Post by Thorsten » Thu Nov 15, 2012 9:32 am

Hi,

if you login into the admin backend and change the "URL for link verification" to the reverse proxy URL all things should work

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

chrajsiel
Posts: 44
Joined: Tue Nov 06, 2012 1:53 pm

Re: Reverse proxy

Post by chrajsiel » Thu Nov 15, 2012 9:41 am

Hi Thorsten,

I did change the URL link for verfication to http://ourdomain.int/dev/kbphpfaq. After I changed it, I saved and log-out. Then I cleared the cache and reopen a new browser. When I went to http://ourdomain.int/dev/kbphpfaq, it's the same thing. Frontpage in a tree format, no stylesheet and can't access anything.

Any other ideas or am I doing something wrong?

Thanks again,
chrajsiel

Thorsten
Posts: 14649
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Reverse proxy

Post by Thorsten » Thu Nov 15, 2012 9:44 am

Hi,

without looking deeply into the server it's really hard to say something valid...

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

chrajsiel
Posts: 44
Joined: Tue Nov 06, 2012 1:53 pm

Re: Reverse proxy

Post by chrajsiel » Thu Nov 15, 2012 9:47 am

Is there any extra work that the network administrator has to do to set it up properly? Or maybe someone else in the forum had the same experience and was able to solve it?

Thanks again!

Thorsten
Posts: 14649
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Reverse proxy

Post by Thorsten » Thu Nov 15, 2012 9:52 am

Hi,

I had one user and they had the same issue. We fixed some things in 2.7.1 and 2.7.2 for solving this.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

chrajsiel
Posts: 44
Joined: Tue Nov 06, 2012 1:53 pm

Re: Reverse proxy

Post by chrajsiel » Thu Nov 15, 2012 9:58 am

Thanks Thorsten.

Did that user do anything extra on their side or is it more a fix on the phpMyFAQ?

Thorsten
Posts: 14649
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Reverse proxy

Post by Thorsten » Thu Nov 15, 2012 3:13 pm

Hi,

no, it works out of the box like I described.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

chrajsiel
Posts: 44
Joined: Tue Nov 06, 2012 1:53 pm

Re: Reverse proxy

Post by chrajsiel » Thu Nov 15, 2012 3:27 pm

Thanks Thorsten. I sent you a pm.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest