Upgrade to 2.8.3 - problem with magic quotes

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
SimonS
Posts: 3
Joined: Mon Oct 07, 2013 9:34 pm

Upgrade to 2.8.3 - problem with magic quotes

Post by SimonS » Fri Nov 22, 2013 2:52 am

I am upgrading from 2.7.6 to 2.8.3. I have followed the instructions for upgrading, but when I run the install/update.php page I get an error message "Please disable magic_quotes_gpc!"

I have checked the PHP configuration settings and magic_quotes are set to "Off" at the server level. I have even added a php.ini file to make sure magic_quotes are set locally to Off. I am running on PHP 5.3.3

Please can you tell me how to disable this error message so that I can upgrade to the current version?

Thank you

Simon

Thorsten
Posts: 14774
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade to 2.8.3 - problem with magic quotes

Post by Thorsten » Fri Nov 22, 2013 8:49 pm

Hi,

this is the code that checks magic quotes in inc/PMF/System.php:

Code: Select all

    public function checkMagicQuotesGpc()
    {
        if (ini_get('magic_quotes_gpc')) {
            return false;
        }
        return true;
    }
If it's telling you, magic quotes are on, they are on. :-)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

hhullen
Posts: 38
Joined: Thu Mar 30, 2006 2:42 pm
Contact:

Re: Upgrade to 2.8.3 - problem with magic quotes

Post by hhullen » Fri Jan 17, 2014 1:57 pm

Thorsten wrote:Hi,

this is the code that checks magic quotes in inc/PMF/System.php:

Code: Select all

    public function checkMagicQuotesGpc()
    {
        if (ini_get('magic_quotes_gpc')) {
            return false;
        }
        return true;
    }
If it's telling you, magic quotes are on, they are on. :-)

bye
Thorsten
Und wie schalte ich diese Option aus?
Ich kann/darf die "php.ini" meines Providers nicht ändern.

Ich möchte ja gern von 2.6.17 nach 2.8.5 updaten ...
Viele Grüsse
Helmut

Thorsten
Posts: 14774
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade to 2.8.3 - problem with magic quotes

Post by Thorsten » Sat Jan 18, 2014 8:50 am

Hi,

du kannst das in der .htaccess eintragen:

Code: Select all

php_flag magic_quotes_gpc Off
bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply