Enable SSO

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
Gazatron
Posts: 3
Joined: Wed Aug 13, 2014 2:18 pm

Enable SSO

Post by Gazatron » Wed Aug 13, 2014 2:23 pm

Hi

I'm pretty new to php and have been trying to configure LDAP and SSO.

I have updated my LDAP settings etc, and this now works correctly. However, I would like to use SSO.

When I go to the Security Configuration page, the "Single Sign on Support" check box cannot be ticked.

I'm assuming there is a setting somewhere that I have missed, but so far I haven't been able to track it down?

Any help would be gratefully received.

Thanks

Thorsten
Posts: 14438
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Enable SSO

Post by Thorsten » Wed Aug 13, 2014 3:03 pm

Hi,

you have to enable SSO in your webserver. Which SSO technique do you use?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Gazatron
Posts: 3
Joined: Wed Aug 13, 2014 2:18 pm

Re: Enable SSO

Post by Gazatron » Wed Aug 13, 2014 4:01 pm

Hi

At present none which would no doubt explain the issue.

Apologies, my lack of php knowledge showing through.

Are there any techniques you would recommend?

Thanks

Thorsten
Posts: 14438
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Enable SSO

Post by Thorsten » Thu Aug 14, 2014 10:48 am

Hi,

I think you mis-understand what SSO means. You need an infrastructure at your network to support SSO, something like NTLM on Windows.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Gazatron
Posts: 3
Joined: Wed Aug 13, 2014 2:18 pm

Re: Enable SSO

Post by Gazatron » Fri Aug 15, 2014 10:54 am

Apologies

Thanks for the help!

Gareth

killlereye
Posts: 1
Joined: Tue Feb 10, 2015 5:55 am

Re: Enable SSO

Post by killlereye » Tue Feb 10, 2015 6:15 am

You have to enable SSO in your webserver. Which SSO technique do you use?
GUL

rocky
Posts: 2
Joined: Thu May 15, 2014 9:00 pm

Re: Enable SSO

Post by rocky » Wed Mar 30, 2016 5:57 pm

I too am attempting to get sso working. We are using CAS SSO.

From previous threads it looks like I need to authenticate with sso before I can enable sso. Sounds kind of chicken and egg to me.

The service is set in the CAS and a ticket is delivered when I log in via the CAS, however, because sso is not enabled, it doesn't check. So, I log in to phpmyfaq with my local phpmyfaq admin account and still can not enable sso. I'm sure I must be missing something simple. Any suggestions?

Thorsten
Posts: 14438
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Enable SSO

Post by Thorsten » Wed Mar 30, 2016 6:41 pm

Hi,

please login as admin and enable SSO. Then you can login with every user which has an SSO account and the user will automatically logged in.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests