Installation Trouble

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Remo
Posts: 25
Joined: Thu Feb 17, 2011 9:57 pm

Installation Trouble

Post by Remo » Fri Sep 19, 2014 11:25 am

Hello,

I am trying to setup phpmyfaq, since the sparc-solaris installation is getting too old.
Now an intel machine with lubuntu installed is subjecto for new phpMyFaq.
I installed the latest version phpMyFaq, together with the php and sclite3 database and lighttpd webserver.
While I am able to run the setup page, and sorted the missing directory's and permessions (chown -R www-data:www-data) the setup is unsuccesfull
phpSetup.png
[img]phpSetup.png[/img]
Nex screen: nothing usefull:
phpSetup2.png
[img]phpSetup2.png[/img]

The error in error.log:
2014-09-19 13:35:04: (mod_fastcgi.c.2673) FastCGI-stderr: PHP Fatal error: Uncaught exception 'Exception' with message 'Unable to open database: unable to open database file' in /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php:72
2014-09-19 13:35:04: (mod_fastcgi.c.2673) FastCGI-stderr: Stack trace:
2014-09-19 13:35:04: (mod_fastcgi.c.2673) FastCGI-stderr: #0 /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php(72): SQLite3->__construct('/var/www/phpmyf...')
2014-09-19 13:35:04: (mod_fastcgi.c.2673) FastCGI-stderr: #1 /var/www/phpmyfaq/inc/PMF/Installer.php(623): PMF_DB_Sqlite3->connect('/var/www/phpmyf...', 'www-data', 'www-data', 'pinnbook')
2014-09-19 13:35:04: (mod_fastcgi.c.2673) FastCGI-stderr: #2 /var/www/phpmyfaq/install/setup.php(396): PMF_Installer->startInstall()
2014-09-19 13:35:04: (mod_fastcgi.c.2673) FastCGI-stderr: #3 {main}
2014-09-19 13:35:04: (mod_fastcgi.c.2673) FastCGI-stderr: thrown in /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php on line 72


Actually, I have no clue on what to fill in in the setup, and maybe what I have to do additional to the databse. I only installed it.
I hope someone can help.
You do not have the required permissions to view the files attached to this post.

Thorsten
Posts: 14399
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Mon Sep 22, 2014 6:34 pm

Hi,

please upgrade to 2.8.13 and SQLite 3 will run smoothly. :)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 25
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Fri Oct 17, 2014 9:26 am

I installed 2.8.15.
The result is the same.
Do I need to do something before running this setup ?
I mean user names, create database, or whaterver ?
php en sqlite is installed.

Thorsten
Posts: 14399
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Sun Oct 19, 2014 4:15 pm

Hi,

where do you store the SQLite3 file?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

andrew.miller
Posts: 2
Joined: Tue Nov 18, 2014 11:05 pm

Re: Installation Trouble

Post by andrew.miller » Tue Nov 18, 2014 11:07 pm

I'm having this exact same problem. I fill out the setup page, click on the install, and nothing! Just the banner. Any ideas? it almost seems like a permissions issue to me

Thorsten
Posts: 14399
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Thu Nov 20, 2014 5:48 am

Hi Andrew,

which version do you want to install with what database?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

andrew.miller
Posts: 2
Joined: Tue Nov 18, 2014 11:05 pm

Re: Installation Trouble

Post by andrew.miller » Thu Nov 20, 2014 8:46 pm

Ubuntu 14.04
Phpmyfaw 2.8.17
sqlite 3
php 5.5.9

Any thoughts?

Thorsten
Posts: 14399
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Fri Nov 21, 2014 10:54 am

Hi,

please enable the debug mode in inc/Bootstrap.php and try a fresh installation. Thanks!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 25
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Mon Jun 22, 2015 6:04 pm

Hi, I am still unable to get trough this setup.
phpMyFaq 2.8.23
php5 5.5.12
sqlite3 3.8.6
lighttpd 1.4.23

Getting exact the same result.
2015-06-22 18:38:27: (mod_fastcgi.c.2673) FastCGI-stderr: Stack trace:
2015-06-22 18:38:27: (mod_fastcgi.c.2673) FastCGI-stderr: #0 /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php(72): SQLite3->__construct(.'/var/www/phpmyf..')
2015-06-22 18:38:27: (mod_fastcgi.c.2673) FastCGI-stderr: #1 /var/www/phpmyfaq/inc/PMF/Installer.php(623): PMF_DB_Sqlite3->connect('/var/www/phpmyf...', 'www-data', 'password', 'infobook')
2015-06-22 18:38:27: (mod_fastcgi.c.2673) FastCGI-stderr: #2 /var/www/phpmyfaq/install/setup.php(396): PMF_Installer->startInstall()
2015-06-22 18:38:27: (mod_fastcgi.c.2673) FastCGI-stderr: #3 {main}
2015-06-22 18:38:27: (mod_fastcgi.c.2673) FastCGI-stderr: thrown in /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php on line 72
2015-06-22 18:42:57: (mod_fastcgi.c.2673) FastCGI-stderr: PHP Fatal error: Uncaught exception 'Exception' with message 'Unable to open database: unable to open database file' in /var/www/phpmyfaq/
inc/PMF/DB/Sqlite3.php:72


__construct(.'/var/www/phpmyf..') is also not very helpfull, now I still don't know where what is going wrong.

Thorsten
Posts: 14399
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Mon Jun 22, 2015 6:09 pm

Hi,

didn't you add any database file during the installation?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 25
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Mon Jun 22, 2015 6:52 pm

I need to create a database file by hand ?

Thorsten
Posts: 14399
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Mon Jun 22, 2015 6:56 pm

Hi,

no, just add a path and a filename. phpMyFAQ setup creates the SQLite file automatically then.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 25
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Mon Jun 22, 2015 7:08 pm

2015-06-22 20:05:28: (mod_fastcgi.c.2673) FastCGI-stderr: PHP Fatal error: Uncaught exception 'Exception' with message 'Unable to open database: unable to open database file' in /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php:72
2015-06-22 20:05:28: (mod_fastcgi.c.2673) FastCGI-stderr: Stack trace:
2015-06-22 20:05:28: (mod_fastcgi.c.2673) FastCGI-stderr: #0 /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php(72): SQLite3->__construct('/var/www/phpmyf...')
2015-06-22 20:05:28: (mod_fastcgi.c.2673) FastCGI-stderr: #1 /var/www/phpmyfaq/inc/PMF/Installer.php(623): PMF_DB_Sqlite3->connect('/var/www/phpmyf...', 'admin', 'password', '/var/www/phpmyf...')
2015-06-22 20:05:28: (mod_fastcgi.c.2673) FastCGI-stderr: #2 /var/www/phpmyfaq/install/setup.php(396): PMF_Installer->startInstall()
2015-06-22 20:05:28: (mod_fastcgi.c.2673) FastCGI-stderr: #3 {main}
2015-06-22 20:05:28: (mod_fastcgi.c.2673) FastCGI-stderr: thrown in /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php on line 72


manually creating a database with sqlite works, so i think sqlite works.
But if I enter as database name /tmp/infobook -> same error.
/var/www/phpmyfaq/infobook -> same error
/var/www/phpmyfaq/infobook.db -> same error

Thorsten
Posts: 14399
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Mon Jun 22, 2015 7:11 pm

Hi,

looks like a permissions issue. I think your webserver has no rights to create the file.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 25
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Mon Jun 22, 2015 7:19 pm

I tryed all permissions, and

chmod -R 777/var/www/phpmyfaq
chown -R www-data:www-data /var/www/phpmyfaq

lighttpd run'als www-data.
rene@rene-VirtualBox:/var/www/faq$ ps -eaf | grep lightt
www-data 3446 1176 0 20:15 ? 00:00:00 /usr/sbin/lighttpd -f /etc/lighttpd/lighttpd.conf

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest