Installation Trouble

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Thorsten
Posts: 14481
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Mon Jun 22, 2015 7:23 pm

Hi,

quite strange, as this entry on StackOverflow describes the same issue: http://stackoverflow.com/questions/2322 ... in-var-www

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 27
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Mon Jun 22, 2015 7:32 pm

2015-06-22 20:28:15: (mod_fastcgi.c.2673) FastCGI-stderr: PHP Fatal error: Uncaught exception 'Exception' with message 'Unable to open database: unable to open database file' in /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php:72
2015-06-22 20:28:15: (mod_fastcgi.c.2673) FastCGI-stderr: Stack trace:
2015-06-22 20:28:15: (mod_fastcgi.c.2673) FastCGI-stderr: #0 /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php(72): SQLite3->__construct('/var/www/phpmyf...')
2015-06-22 20:28:15: (mod_fastcgi.c.2673) FastCGI-stderr: #1 /var/www/phpmyfaq/inc/PMF/Installer.php(623): PMF_DB_Sqlite3->connect('/var/www/phpmyf...', 'www-data', '', '/var/www/phpmyf...')
2015-06-22 20:28:15: (mod_fastcgi.c.2673) FastCGI-stderr: #2 /var/www/phpmyfaq/install/setup.php(396): PMF_Installer->startInstall()
2015-06-22 20:28:15: (mod_fastcgi.c.2673) FastCGI-stderr: #3 {main}
2015-06-22 20:28:15: (mod_fastcgi.c.2673) FastCGI-stderr: thrown in /var/www/phpmyfaq/inc/PMF/DB/Sqlite3.php on line 72

I tryed that too. with linking phpmyfaq to faq, without link, with lighttpd use /var/www/phpmyfaq al landing directory.
It would be nice if I could see which file where is giving a problem.

Thorsten
Posts: 14481
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Mon Jun 22, 2015 8:04 pm

Hi,

what value do you have in config/database.php?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 27
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Tue Jun 23, 2015 2:31 pm

This file is not getting generated.
There is only a database.php.original


rene@rene-VirtualBox:/var/www/faq/config$ ls -al
total 36
drwxrwxrwx 2 www-data www-data 4096 jun 23 15:27 .
drwxrwxrwx 14 www-data www-data 4096 jun 23 15:27 ..
-rwxr-xr-x 1 www-data www-data 1921 jun 13 11:35 constants_ldap.php
-rwxr-xr-x 1 www-data www-data 9141 jun 13 11:35 constants.php
-rwxr-xr-x 1 www-data www-data 119 jun 13 11:35 database.php.original
-rw-r--r-- 1 www-data www-data 194 jun 23 15:28 index.html
-rwxr-xr-x 1 www-data www-data 639 jun 13 11:35 ldap.php.original


Rene.

Thorsten
Posts: 14481
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Tue Jun 23, 2015 5:14 pm

Hi,

that's the issue, the webserver is not allowed to write the file.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 27
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Mon Jul 20, 2015 7:28 pm

I start to give-up on this.
It has been over one year now, and it seems there is no clue in the system why it does not work.


Kind regards.

Rene.

Thorsten
Posts: 14481
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Mon Jul 20, 2015 7:59 pm

Hi,

did you read my answers? The webserver doesn't have permissions to write the SQLite3 file. That's the issue.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 27
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Mon Jul 20, 2015 8:17 pm

I read the answer, but i don't see what file is written where, and why does it not have permissions.
The webserver run as www-data, and all directory's and files are owned by www-data. It should be able to write everywhere.

Remo
Posts: 27
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Mon Nov 30, 2015 1:15 pm

Hmm. There is a difference in the same version. I think I ask about one, and get answer about an other one.
This is what I don't understand, and have no clue about what to fill in.
lubuntu.png
However, on suse it looks like this, which explains what I have to fill in.
suse.png
Why do I get the wrong setup screen
You do not have the required permissions to view the files attached to this post.

Thorsten
Posts: 14481
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Mon Nov 30, 2015 8:38 pm

Hi,

on the first screenshot the switch to the filepath didn't work. On the second screenshot you see the path. SQLite saves the data in one database file which you have to set during the installation of phpMyFAQ.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Remo
Posts: 27
Joined: Thu Feb 17, 2011 9:57 pm

Re: Installation Trouble

Post by Remo » Mon Nov 30, 2015 9:17 pm

on the first screenshot the switch to the filepath didn't work
What is doing the switch. Is it looking for a file, or a command ?

Thorsten
Posts: 14481
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation Trouble

Post by Thorsten » Tue Dec 01, 2015 8:29 pm

Hi,

it checks what database is selected. If SQLite is selected, you have to enter a path to a SQLite file including the file, otherwise the database server.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: Exabot [Bot] and 2 guests