Please enable the PHP extension(s) in php.ini.

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
AugustusM
Posts: 3
Joined: Fri Sep 26, 2014 1:56 am

Please enable the PHP extension(s) in php.ini.

Post by AugustusM » Fri Sep 26, 2014 2:03 am

I am trying to install this on my webserver (Apache, PHP Version 5.3.28) and I get the error there are 2 extensions that are needed in my php.ini. ext/zip and ext/fileinfo

I only have one php.ini on the server, which I verified while going in through ssh. I included the extensions and also ran the pecl install for the zip extension. (filinfo didn't seem to install when I used the pecl version available on the pecl site) I verified the module directory and still I am getting this error. I have also included the extensions in the php.ini file.

How do I fix this?

Thorsten
Posts: 14769
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Please enable the PHP extension(s) in php.ini.

Post by Thorsten » Fri Sep 26, 2014 6:42 pm

Hi,

please restart your webserver as well.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

AugustusM
Posts: 3
Joined: Fri Sep 26, 2014 1:56 am

Re: Please enable the PHP extension(s) in php.ini.

Post by AugustusM » Fri Sep 26, 2014 7:23 pm

That was done too. To no avail. I did the restart through WHM and ssh both had not effect.

Thorsten
Posts: 14769
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Please enable the PHP extension(s) in php.ini.

Post by Thorsten » Fri Sep 26, 2014 7:26 pm

Hi,

how do your php.ini file look like?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist


Thorsten
Posts: 14769
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Please enable the PHP extension(s) in php.ini.

Post by Thorsten » Sat Sep 27, 2014 10:30 am

Hi,

your PHP was compiled with '--disable-fileinfo', so it doesn't work. :-(

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply