Upgrade Fail - 2.7.x to 2.8.x

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
CAVSUSA
Posts: 4
Joined: Mon Jun 08, 2015 9:52 pm

Upgrade Fail - 2.7.x to 2.8.x

Post by CAVSUSA » Mon Jun 08, 2015 10:05 pm

Help me, drowning in code.

Upgraded from 2.7.x to 2.8.x. Now I'm getting a blank page instead of my FAQ. Had a feeling I should've stayed away from an update, couldn't resist. Checked the debug, this is what I'm getting. Any help is appreciated. Can't have our FAQ down for much longer. >.< Let me know if I need to upload more data/info/files. Thanks for the help all!


phpMyFAQ notice [8]: Undefined index: search.useAjaxSearchOnStartpage in /home/content/10/9577410/html/kb/inc/PMF/Configuration.php on line 101

phpMyFAQ notice [8]: Undefined index: search.useAjaxSearchOnStartpage in /home/content/10/9577410/html/kb/inc/PMF/Configuration.php on line 109

phpMyFAQ warning [2]: Cannot modify header information - headers already sent by (output started at /home/content/10/9577410/html/kb/inc/Bootstrap.php:275) in /home/content/10/9577410/html/kb/inc/PMF/Helper/Http.php on line 65

phpMyFAQ warning [2]: Cannot modify header information - headers already sent by (output started at /home/content/10/9577410/html/kb/inc/Bootstrap.php:275) in /home/content/10/9577410/html/kb/inc/PMF/Helper/Http.php on line 66

phpMyFAQ warning [2]: Cannot modify header information - headers already sent by (output started at /home/content/10/9577410/html/kb/inc/Bootstrap.php:275) in /home/content/10/9577410/html/kb/inc/PMF/Helper/Http.php on line 67

phpMyFAQ warning [2]: Cannot modify header information - headers already sent by (output started at /home/content/10/9577410/html/kb/inc/Bootstrap.php:275) in /home/content/10/9577410/html/kb/inc/PMF/Helper/Http.php on line 68

phpMyFAQ warning [2]: Cannot modify header information - headers already sent by (output started at /home/content/10/9577410/html/kb/inc/Bootstrap.php:275) in /home/content/10/9577410/html/kb/inc/PMF/Helper/Http.php on line 69

phpMyFAQ warning [2]: Cannot modify header information - headers already sent by (output started at /home/content/10/9577410/html/kb/inc/Bootstrap.php:275) in /home/content/10/9577410/html/kb/inc/PMF/Helper/Http.php on line 70

phpMyFAQ warning [2]: Cannot modify header information - headers already sent by (output started at /home/content/10/9577410/html/kb/inc/Bootstrap.php:275) in /home/content/10/9577410/html/kb/inc/PMF/Helper/Http.php on line 71

CAVSUSA
Posts: 4
Joined: Mon Jun 08, 2015 9:52 pm

Re: Upgrade Fail - 2.7.x to 2.8.x

Post by CAVSUSA » Mon Jun 08, 2015 10:08 pm

I can get into /admin, although the login page is missing images and is spitting an error at the bottom. after that though the rest of /admin seems to work fine.

Thorsten
Posts: 14769
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade Fail - 2.7.x to 2.8.x

Post by Thorsten » Wed Jun 10, 2015 9:23 pm

Hi,

did you execute update.php?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

CAVSUSA
Posts: 4
Joined: Mon Jun 08, 2015 9:52 pm

Re: Upgrade Fail - 2.7.x to 2.8.x

Post by CAVSUSA » Thu Jun 11, 2015 8:31 pm

Yes, this was post update.

Thorsten
Posts: 14769
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade Fail - 2.7.x to 2.8.x

Post by Thorsten » Sun Jun 14, 2015 6:41 pm

Hi,

please upgrade to 2.8.23 and run update.php again. Please check, if the "URL of your FAQ" ends with a trailing Slash.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

CAVSUSA
Posts: 4
Joined: Mon Jun 08, 2015 9:52 pm

Re: Upgrade Fail - 2.7.x to 2.8.x

Post by CAVSUSA » Mon Jun 15, 2015 2:28 pm

Someone here at the office somehow fixed it while I was out.

Yes, the url does end with a "/"
http://cavsusa.com/kb/

No, I do not know how they fixed it. Thanks for your time, I'm hoping whatever they did will work out. From what I understand we don't even know how we fixed it.

Thorsten
Posts: 14769
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade Fail - 2.7.x to 2.8.x

Post by Thorsten » Mon Jun 15, 2015 3:25 pm

Hi,

okay, if you find out how you fixed it, it would be great to get feedback. :)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply