remote database not connecting

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
tim.mcintire
Posts: 2
Joined: Tue Aug 18, 2015 5:26 pm

remote database not connecting

Post by tim.mcintire » Tue Aug 18, 2015 5:32 pm

Hi,

I am trying to install my first instance of this and am having some issues. I am using phpmyfaq 2.8.24, redhat 66, mysql 5.1.73, php 5.3.3.

I have verified that my myfaq server can connect to the database with the user/password that I am going to use. the problem is that when I fill in the data on the setup page and click the setup button.. no attempt to connect to the mysql db on the remote server. I am looking at tcpdump and I dont see any connections being attempted.

Any suggestions?

Thanks..

Tim

Thorsten
Posts: 14450
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: remote database not connecting

Post by Thorsten » Tue Aug 18, 2015 7:00 pm

Hi,

maybe a firewall issue?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

tim.mcintire
Posts: 2
Joined: Tue Aug 18, 2015 5:26 pm

Re: remote database not connecting

Post by tim.mcintire » Tue Aug 18, 2015 7:09 pm

dont think so. they are on the same subnet and I have disabled iptables on both. also.. I can connect just fine from a mysql client on the server that I am trying to install phpmyfaq on. seems like a php config issue, but I dont know where.

Tim

Thorsten
Posts: 14450
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: remote database not connecting

Post by Thorsten » Tue Aug 18, 2015 7:11 pm

Hi,

please try this code example with your MySQL credentials: http://php.net/manual/de/mysqli.construct.php

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest