index.php not added

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
jaspersj
Posts: 15
Joined: Tue Jul 05, 2016 11:18 am

index.php not added

Post by jaspersj » Thu Jul 14, 2016 10:19 am

Hi,

Maybe someone can help me. I installed the latest version of phpmyfaq (stable release). I run it on IIS 8.5 with PHP5.5. When I go to http://localhost/ the page of phpmyfaq is not loaded, now this could be just a setting in IIS so no problems there cause when I go to http://localhost/index.php the home page comes up. Strange thing is, when I click on anything the weblink is not working.

Example;

I go to http://localhost/index.php the homepage comes up. From here I wanna sign in so I click on login, and look what happens to the URL.
The URL becomes: http://localhost/?action=login
The URL should be: http://localhost/index.php?action=login

A littlebit of googling tells me I need to change something in the web.config file but im to much of a noob in this to correctly understand what needs to be done in the web.config. Can anyone push me in the right direction?

Thorsten
Posts: 14352
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: index.php not added

Post by Thorsten » Thu Jul 14, 2016 12:02 pm

phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jaspersj
Posts: 15
Joined: Tue Jul 05, 2016 11:18 am

Re: index.php not added

Post by jaspersj » Thu Jul 14, 2016 1:29 pm

Thank you for the link but I already set this up. If I google on it i see that more people in the world have this problem, witch seems to be referring to the web.config

http://forums.iis.net/t/1155187.aspx?De ... nt+Problem

PS C:\Users\UserX> c:\windows\system32\inetsrv\appcmd.exe list config http://localhost/ -section:defaultDocument
<system.webServer>
<defaultDocument enabled="true">
<files>
<add value="index.php" />
<add value="Default.htm" />
<add value="Default.asp" />
<add value="index.htm" />
<add value="index.html" />
<add value="iisstart.htm" />
<add value="default.aspx" />
</files>
</defaultDocument>
</system.webServer>

jaspersj
Posts: 15
Joined: Tue Jul 05, 2016 11:18 am

Re: index.php not added

Post by jaspersj » Thu Jul 14, 2016 1:33 pm

Also if i check the web.config file I see the following;

"Rewrite" url="/phpmyfaq/index.php?action=show"
"Rewrite" url="/phpmyfaq/index.php?action=search"
"Rewrite" url="/phpmyfaq/opensearch.php"
"Rewrite" url="/phpmyfaq/index.php?action=add"
and so on...

In my case everything is in the root. So /phpmyfaq/... would not be needed.

jaspersj
Posts: 15
Joined: Tue Jul 05, 2016 11:18 am

Re: index.php not added

Post by jaspersj » Mon Jul 18, 2016 9:03 am

jaspersj wrote:Also if i check the web.config file I see the following;

"Rewrite" url="/phpmyfaq/index.php?action=show"
"Rewrite" url="/phpmyfaq/index.php?action=search"
"Rewrite" url="/phpmyfaq/opensearch.php"
"Rewrite" url="/phpmyfaq/index.php?action=add"
and so on...

In my case everything is in the root. So /phpmyfaq/... would not be needed.
Can anyone confirm this?

Thorsten
Posts: 14352
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: index.php not added

Post by Thorsten » Mon Jul 18, 2016 9:08 am

Hi,

this depends on your installation. If you do not have a folder called "phpmyfaq" you don't need it here.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jaspersj
Posts: 15
Joined: Tue Jul 05, 2016 11:18 am

Re: index.php not added

Post by jaspersj » Mon Jul 18, 2016 11:59 am

So for example this;
<rule name="rule 1L" stopProcessing="true">
<match url="^phpmyfaq/(.*)$" />
<action type="Rewrite" url="/phpmyfaq/index.php?action=show" appendQueryString="true" />
</rule>
<rule name="rule 2L" stopProcessing="true">
<match url="^phpmyfaq/(.*)$" />
<action type="Rewrite" url="/phpmyfaq/index.php?action=search" appendQueryString="true" />

should be;

<rule name="rule 1L" stopProcessing="true">
<match url="/(.*)$" />
<action type="Rewrite" url="/index.php?action=show" appendQueryString="true" />
</rule>
<rule name="rule 2L" stopProcessing="true">
<match url="/(.*)$" />
<action type="Rewrite" url="/index.php?action=search" appendQueryString="true" />

Thorsten
Posts: 14352
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: index.php not added

Post by Thorsten » Mon Jul 18, 2016 8:11 pm

Hi,

yes, looks okay.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests