Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

All about webserver configurations, PHP and databases.

Moderator: Thorsten

scape
Posts: 169
Joined: Tue Apr 08, 2003 1:16 pm

Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by scape » Tue Aug 23, 2016 11:58 am

Hi!

Ich bekomme, nachdem ich nach Beschreibung die Dateien gelöscht und die entsprechenden neuen Daten hochgeladen habe, immer folgende Meldung, wenn ich xx/setup/update.php aufrufe:
The connection to the database server could not be established.

The error message of the database server:
Invalid Database Type: mysql
Wir sind bei All-Inkl und hatten jahrelang keine Probleme.

Folgende Infos kann ich bereitstellen:
Datenbank-Server
Software: MySQL
Software-Version: 5.6.30-nmm1-log - (Ubuntu)
Protokoll-Version: 10
Server Zeichensatz: UTF-8 Unicode (utf8)

Webserver
Apache
Datenbank-Client Version: libmysql - mysqlnd 5.0.11-dev - 20120503
PHP-Erweiterung: mysqli
Woran kann das liegen? Benötigst du weitere Infos? Vielen Dank schonmal!

Viele Grüße
Roman

Thorsten
Posts: 14438
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by Thorsten » Tue Aug 23, 2016 7:23 pm

Hi,

ändere vor dem Update in der config/database.php den Typ von "mysql" auf "mysqli". Dann klappt das Update.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

scape
Posts: 169
Joined: Tue Apr 08, 2003 1:16 pm

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by scape » Wed Aug 24, 2016 8:12 am

Hi Thorsten!

Danke schonmal für die Antwort. Nun bekomme ich allerdings zwischen Schritt 1 und 2 im Update die Meldung:
Error: The backup file ../config/database.bak.php could not be written. Please correct this!
Hier scheint der Wurm drin zu sein. Liegt es an den Berechtigungen des config-Ordners (755)? Soll ich diese einfach solange ändern und später zurücksetzen oder ist hier mehr im Argen?

Viele Grüße
Roman

Thorsten
Posts: 14438
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by Thorsten » Wed Aug 24, 2016 8:15 am

Hi Roman,

ja, sonst kann das Backupfile nicht geschrieben werden.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

scape
Posts: 169
Joined: Tue Apr 08, 2003 1:16 pm

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by scape » Wed Aug 24, 2016 8:21 am

Jetzt ist zwar das Update ohne weitere Fehler durchgegangen, allerdings bekomme ich eine weiße Seite...

faq.schwitzen.com

Thorsten
Posts: 14438
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by Thorsten » Wed Aug 24, 2016 8:25 am

Hi,

http://faq.schwitzen.com/phpmyfaq/admin/ klappt.

Kannst du mal in der inc/Bootstrap.php den DEBUG Mode aktivieren, um zu sehen, was da falsch läuft.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

scape
Posts: 169
Joined: Tue Apr 08, 2003 1:16 pm

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by scape » Wed Aug 24, 2016 8:32 am

Habe ich gemacht. Nun erhält man auf der Starseite die Meldung:
Fatal error: Call to a member function fetch_object() on boolean in /www/htdocs/v158395/_phpmyfaq/phpmyfaq/inc/PMF/DB/Mysqli.php on line 153

scape
Posts: 169
Joined: Tue Apr 08, 2003 1:16 pm

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by scape » Wed Aug 24, 2016 9:47 am

Ich meine eigentlich nichts geändert zu haben, aber ich bekomme jetzt folgende Fehler auf der Startseite:
phpMyFAQ warning [2]: touch(): Unable to create file /www/htdocs/v158395/_phpmyfaq/phpmyfaq/data/tracking24082016 because No such file or directory in /www/htdocs/v158395/_phpmyfaq/phpmyfaq/inc/PMF/Session.php on line 145

phpMyFAQ warning [2]: Cannot modify header information - headers already sent by (output started at /www/htdocs/v158395/_phpmyfaq/phpmyfaq/inc/Bootstrap.php:317) in /www/htdocs/v158395/_phpmyfaq/phpmyfaq/inc/PMF/Session.php on line 464

Fatal error: Call to a member function fetch_object() on boolean in /www/htdocs/v158395/_phpmyfaq/phpmyfaq/inc/PMF/DB/Mysqli.php on line 153
Danke für deinen tollen Support!

Viele Grüße
Roman

scape
Posts: 169
Joined: Tue Apr 08, 2003 1:16 pm

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by scape » Wed Aug 24, 2016 12:44 pm

Wenn es für dich einfacher ist, können wir auch gerne telefonieren. Das Ergebnis mit Lösung könnte man natürlich anschließend hier posten. Ich bin montags bis freitags von 9 bis 15 Uhr erreichbar.

Wie es dir lieber ist.

Viele Grüße
Roman

Thorsten
Posts: 14438
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by Thorsten » Wed Aug 24, 2016 12:47 pm

Hi,

könntest du bitte in den Chat kommen: http://phpmyfaq.herokuapp.com/

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

scape
Posts: 169
Joined: Tue Apr 08, 2003 1:16 pm

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by scape » Wed Aug 24, 2016 12:50 pm

Sobald die E-Mail für den Beitritt ankommt, komme ich rein...

scape
Posts: 169
Joined: Tue Apr 08, 2003 1:16 pm

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by scape » Wed Aug 24, 2016 12:53 pm

Die angekündigte E-Mail kommt nicht :/

Thorsten
Posts: 14438
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by Thorsten » Wed Aug 24, 2016 1:00 pm

Liegt sie im Spam-Ordner?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

scape
Posts: 169
Joined: Tue Apr 08, 2003 1:16 pm

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by scape » Wed Aug 24, 2016 1:01 pm

Bin drin. Kamen nur mit starker Verzögerung an

R0CKY
Posts: 40
Joined: Mon May 19, 2008 9:18 pm

Re: Update-Error von 2.8.x auf 2.9.x - Invalid Database Type

Post by R0CKY » Wed Mar 08, 2017 5:40 pm

I also have the same error
The connection to the database server could not be established.

The error message of the database server:
Invalid Database Type: mysql
Also the upgrade instructions at http://www.phpmyfaq.de/docs/2.9#3.1 do not explain when you should upload the new files - ie, delete current installation apart from listed files (template/ etc) first, then upload new version and run installer?
Rocky.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest