SEO friendly URL

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
tm9
Posts: 5
Joined: Sun Aug 28, 2016 10:33 pm

SEO friendly URL

Post by tm9 » Sun Aug 28, 2016 10:44 pm

Dear sir,
I was playing around with the demo & it's all perfect, except one thing i noticed: "the URL structure".

I think it's a huge SEO advantage to have pretty URLs (exmaple :'%postname%' instead of 'id') : http://richmond.demo.phpmyfaq.de/index. ... t-good-for
(In place of : http://richmond.demo.phpmyfaq.de/index. ... artlang=en)

Is there any way to modify URL structures?

Thorsten
Posts: 14455
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: SEO friendly URL

Post by Thorsten » Mon Aug 29, 2016 7:49 pm

Hi,

sure, we have rewrite rules for Apache, nginx and IIS. Just enable them in the admin configuration. A howto is in our documentation.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

tm9
Posts: 5
Joined: Sun Aug 28, 2016 10:33 pm

Re: SEO friendly URL

Post by tm9 » Tue Aug 30, 2016 8:45 pm

Thorsten wrote:Hi,

sure, we have rewrite rules for Apache, nginx and IIS. Just enable them in the admin configuration. A howto is in our documentation.

bye
Thorsten
Hello sir, The 2 issues:

1.(on your demo-samples) I tried to enable 'URL_rewrite function in the admin-configuration page, but it's not saving the changes.
2. Also, i test-installed phpmyfaq-2.9.4 on my host.It got installed swiftly but now i can't add any user,any category,any new qusetion/faq OR anything else atall!(its saying : 'You are not authorized').

I tested all settings including PHP , mysql permissions/requirements etc. but i think the issue is in the scripts. If you wish, i can provide you login details to my test-installation.

Thanks!

Thorsten
Posts: 14455
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: SEO friendly URL

Post by Thorsten » Wed Aug 31, 2016 9:01 pm

Hi,
1.(on your demo-samples) I tried to enable 'URL_rewrite function in the admin-configuration page, but it's not saving the changes.
we'll update our demo the next days and it should be working again.
2. Also, i test-installed phpmyfaq-2.9.4 on my host.It got installed swiftly but now i can't add any user,any category,any new qusetion/faq OR anything else atall!(its saying : 'You are not authorized').

I tested all settings including PHP , mysql permissions/requirements etc. but i think the issue is in the scripts. If you wish, i can provide you login details to my test-installation.
A login would be nice

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

tm9
Posts: 5
Joined: Sun Aug 28, 2016 10:33 pm

Re: SEO friendly URL

Post by tm9 » Thu Sep 01, 2016 2:04 pm

Thorsten wrote:Hi,
1.(on your demo-samples) I tried to enable 'URL_rewrite function in the admin-configuration page, but it's not saving the changes.
we'll update our demo the next days and it should be working again.
2. Also, i test-installed phpmyfaq-2.9.4 on my host.It got installed swiftly but now i can't add any user,any category,any new qusetion/faq OR anything else atall!(its saying : 'You are not authorized').

I tested all settings including PHP , mysql permissions/requirements etc. but i think the issue is in the scripts. If you wish, i can provide you login details to my test-installation.
A login would be nice

bye
Thorsten
Please see the login-credentials:

Removed credentials

Thorsten
Posts: 14455
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: SEO friendly URL

Post by Thorsten » Thu Sep 01, 2016 3:58 pm

Hi,

looks like your session management is broken as I got kicked out every click after logging in. It works if I use the "log me in automattically" with the cookie authentication.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

tm9
Posts: 5
Joined: Sun Aug 28, 2016 10:33 pm

Re: SEO friendly URL

Post by tm9 » Fri Sep 02, 2016 3:22 am

Thorsten wrote:Hi,

looks like your session management is broken as I got kicked out every click after logging in. It works if I use the "log me in automattically" with the cookie authentication.

bye
Thorsten
Hi sir,
What could be the reason behind that? Also, it's still unable to add new-user/faq/questions(even after using 'log me in automattically').
Am i missing anything or the issue is associated with the scripts?

Thorsten
Posts: 14455
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: SEO friendly URL

Post by Thorsten » Fri Sep 02, 2016 8:16 pm

Hi,

I enabled your debug mode in inc/Bootstrap.php and this is the result:

phpMyFAQ warning [2]: session_start(): open(/var/php_sessions/sess_cdc75e390024efff1b12a6aead64f9bd, O_RDWR) failed: No such file or directory (2) in /hermes/bosnaweb11a/b308/ipg.xchangerpro/phpmyfaq/inc/Bootstrap.php on line 166

PHP is configured to store session files in /var/php_sessions, but this folder is not present or PHP is not allowed to store files in it.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

tm9
Posts: 5
Joined: Sun Aug 28, 2016 10:33 pm

Re: SEO friendly URL

Post by tm9 » Sun Sep 04, 2016 3:17 pm

Thorsten wrote:Hi,

I enabled your debug mode in inc/Bootstrap.php and this is the result:

phpMyFAQ warning [2]: session_start(): open(/var/php_sessions/sess_cdc75e390024efff1b12a6aead64f9bd, O_RDWR) failed: No such file or directory (2) in /hermes/bosnaweb11a/b308/ipg.xchangerpro/phpmyfaq/inc/Bootstrap.php on line 166

PHP is configured to store session files in /var/php_sessions, but this folder is not present or PHP is not allowed to store files in it.

bye
Thorsten
Thanks sir, just fixed the php issue.I didn't know there's a 'debug mode' option available. :o .
Another thing i'd like to ask,is there anyway to shorten the URL?
for example:

to
(or anything like that?)
Last edited by tm9 on Sun Sep 04, 2016 7:01 pm, edited 1 time in total.

Thorsten
Posts: 14455
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: SEO friendly URL

Post by Thorsten » Sun Sep 04, 2016 6:45 pm

Hi,

nope, that's not possible.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

past0809
Posts: 1
Joined: Thu Nov 02, 2017 1:05 pm

Re: SEO friendly URL

Post by past0809 » Thu Nov 02, 2017 1:15 pm

Thorsten wrote:
Fri Sep 02, 2016 8:16 pm
Hi,

I enabled your debug mode in inc/Bootstrap.php and this is the result:

phpMyFAQ warning [2]: session_start(): openwebsite design company(/var/php_sessions/sess_cdc75e390024efff1b12a6aead64f9bd, O_RDWR) failed: No such file or directory (2) in /hermes/bosnaweb11a/b308/ipg.xchangerpro/phpmyfaq/inc/Bootstrap.php on line 166

PHP is configured to store session files in /var/php_sessions, but this folder is not present or PHP is not allowed to store files in it.

bye
Thorsten
hello thorsten im getting same issue and going through your method its still not fixing.

Thorsten
Posts: 14455
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: SEO friendly URL

Post by Thorsten » Sun Nov 05, 2017 1:48 pm

Hi,

PHP needs write permissions in /var/php_sessions

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests