Error/Fehler in FAQ-View

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
GPKopiersysteme
Posts: 5
Joined: Thu Sep 01, 2016 3:14 pm

Error/Fehler in FAQ-View

Post by GPKopiersysteme » Thu Sep 01, 2016 3:44 pm

Guten Tag,

wir haben seit ein paar Tagen das Problem, dass wir nicht mehr ordentlich auf unsere FAQ's zugreifen können.
Und zwar kommt wenn man aus dem Userinterface heraus auf ein FAQ klickt bei aktiviertem Debugging folgenden Fehler:

Code: Select all

Fatal error: Uncaught exception 'Exception' with message 'Error while fetching result: Can't find FULLTEXT index matching the column list' in /mnt/webm/e2/04/5464804/htdocs/faq2/inc/PMF/DB/Mysqli.php:183 Stack trace: #0 /mnt/webm/e2/04/5464804/htdocs/faq2/inc/PMF/Relation.php(106): PMF_DB_Mysqli->fetchAll(false) #1 /mnt/webm/e2/04/5464804/htdocs/faq2/artikel.php(175): PMF_Relation->getAllRelatedById('6', 'Intranet - Imme...', '') #2 /mnt/webm/e2/04/5464804/htdocs/faq2/index.php(767): require('/mnt/webm/e2/04...') #3 {main} thrown in /mnt/webm/e2/04/5464804/htdocs/faq2/inc/PMF/DB/Mysqli.php on line 183
Die Datenbank an sich scheint intakt zu sein, da ich noch über die Administration soweit alles einsehen kann.
Wenn ich die besagte Zeile 183 entferne kommen auch andere Fehler, was ja verständlich ist.
Das System lief vorher über MySQL und bei der Aktualisierung auf die 2.9 (nicht sicher ob es die war) wurde ja das MySQL deaktiviert. Soweit kein Problem.
Alles auf MySQLi umgestellt und es lief. Nun kommt dieser Fehler und es nervt langsam.

Die Zähler für die Views auf den FAQ's steigt mit jeder Aktualisierung weiter an, also funktioniert die Basis anscheinend noch.

Vielen Dank im Vorraus


Please tell me if I should write this in english.

Thorsten
Posts: 14371
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Error/Fehler in FAQ-View

Post by Thorsten » Thu Sep 01, 2016 7:36 pm

Hi,

das habe ich mit der 2.9.5 gefixt. Bitte updaten. :-)

Danke!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

GPKopiersysteme
Posts: 5
Joined: Thu Sep 01, 2016 3:14 pm

Re: Error/Fehler in FAQ-View

Post by GPKopiersysteme » Fri Sep 02, 2016 7:11 am

Ich habe das Update gestern bereits installiert bevor ich hier den Post erstellt habe.

Deshalb gingen mir die Ideen aus.

Vielen Dank
Philip

Thorsten
Posts: 14371
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Error/Fehler in FAQ-View

Post by Thorsten » Fri Sep 02, 2016 4:17 pm

Hi,

ich schau mir das Problem an!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Thorsten
Posts: 14371
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Error/Fehler in FAQ-View

Post by Thorsten » Fri Sep 02, 2016 7:32 pm

Hi,

das sollte das Problem fixen: https://github.com/thorsten/phpMyFAQ/co ... e312e1849a

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

GPKopiersysteme
Posts: 5
Joined: Thu Sep 01, 2016 3:14 pm

Re: Error/Fehler in FAQ-View

Post by GPKopiersysteme » Thu Sep 08, 2016 8:31 am

Hallo Thorsten,

ich konnte jetzt erst das ganze testen.

Leider hat dies keinen Erfolg gebracht.

Auch wenn ich in der Zeile welche du hinzugefügt hast der Schreibfehler (Ich denke es ist einer) geändert wird oder noch am Ende ein Komma hinzukommt.

Die Fehlermeldung ist genau die selbe.

MfG
Philip

Thorsten
Posts: 14371
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Error/Fehler in FAQ-View

Post by Thorsten » Thu Sep 08, 2016 9:08 am

Hi,

ja, den Schreibfehler habe ich korrigiert. Welche MySQL Version nutzt du?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

GPKopiersysteme
Posts: 5
Joined: Thu Sep 01, 2016 3:14 pm

Re: Error/Fehler in FAQ-View

Post by GPKopiersysteme » Thu Sep 08, 2016 9:46 am

Hallo,

das FAQ ist bei Strato gehostet.

Hier sind einmal die SQL-Infos vom PHPmyAdmin:
Server: rdbms via TCP/IP
Server-Typ: MySQL
Server Version: 5.6.31-log - Source distribution
Protokoll-Version: 10
Benutzer: U*******@oomforafor.store.d0m.de
Server Zeichensatz: UTF-8 Unicode (utf8)

Apache/2.2.31 (Unix)
Datenbank-Client Version: libmysql - 5.5.46
PHP-Erweiterung: mysqli
Ich hoffe dass das weiterhelfen kann.

MfG
Philip

Thorsten
Posts: 14371
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Error/Fehler in FAQ-View

Post by Thorsten » Thu Sep 08, 2016 10:53 am

Hi Philipp,

ich habe das Problem gefunden. Bitte mal in phpMyAdmin ausführen:

Code: Select all

ALTER TABLE faqdata ADD FULLTEXT(keywords,thema,content);
bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

GPKopiersysteme
Posts: 5
Joined: Thu Sep 01, 2016 3:14 pm

Re: Error/Fehler in FAQ-View

Post by GPKopiersysteme » Thu Sep 08, 2016 11:25 am

Hallo,

auch dort leider kein Erfolg.
Die 3 Einträge existieren bereits in der Tabelle.

Ich werde ansonsten, wenn dir das zu viel Arbeit macht das FAQ einmal komplett neu einrichten und die FAQs einzeln kopieren.

Falls das für dich in Ordnung ist kannst du natürlich auch gerne weitersuchen. :D

MfG
Philip

Thorsten
Posts: 14371
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Error/Fehler in FAQ-View

Post by Thorsten » Thu Sep 08, 2016 11:28 am

Hi,

könntest du mir einen kompletten Dump der DB zusenden? Dann gucke ich mir das genauer an.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest