Page 1 of 1

[Solved] Cannot activate LDAP

Posted: Sat Jun 06, 2020 1:46 pm
by forstera
Hello all,
I'm working for a school and I just installed phpmyFAQ on a new centos 8 server. Everything's worfine fine. Now, I wanted to allow authentication using my ldap server. So, according to the doc, I modifed the config/ldap.php file with the informations of my ldap server and restared my apache.
In my phpmyfag config console, I can't activate the ldap option ; it renames greyed out.
Could this be due to the fact that the ldap option is not enabled for php?
if yes - sorry I'm not very php expert - do I reallay need to compile php with the ldap option or is there another way ?
Thanks to all for your help
Best Regards

Re: Cannot activate LDAP

Posted: Sun Jun 07, 2020 1:28 pm
by Thorsten

yes, PHP has to be compiled or bundled with LDAP, phpMyFAQ checks if the LDAP module of PHP is successfully loaded.


Re: Cannot activate LDAP

Posted: Mon Jun 08, 2020 6:47 am
by forstera
Hello Thorsten,
Thanks for your answer.
Yes, installing php-ldap solved my starting problem :)
Have a nice day