PHP 5 und MySQL 4

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply

Welche PHP-Version läuft auf Eurem Server?

4.1.1
0
No votes
4.1.2
1
10%
4.2.0
0
No votes
4.2.1
1
10%
4.2.2
0
No votes
4.2.3
2
20%
4.3.0
1
10%
4.3.1
0
No votes
4.3.2
5
50%
5.0.0b2
0
No votes
 
Total votes: 10

stephan
Posts: 129
Joined: Thu Feb 27, 2003 6:21 pm
Location: Bochum
Contact:

PHP 5 und MySQL 4

Post by stephan » Thu Aug 07, 2003 9:38 am

Tach!

In den Vorraussetzungen zur PHPmyFAQ steht, dass das System mit PHP5.0.0-dev läuft. Bei PHP5-beta sind nun keine MySQL Extensions mehr drin, daher meine Frage:

Wie habt ihr denn die Verbindung zur MySQL DB hinbekommen?
Ich würde gerne einen neuen Server testen, der eben PHP5, MySQL4 drauf haben soll, aber wenn PHP5 nicht auf die DB zugreifen kann wäre das übel.. :-/

Wie sieht es denn mit einer PostgreSQL Version aus? ;-)

Stephan

meikel
Posts: 135
Joined: Wed Feb 12, 2003 11:12 am
Location: Erfurt
Contact:

Re: PHP 5 und MySQL 4

Post by meikel » Thu Aug 07, 2003 2:09 pm

stephan wrote:In den Vorraussetzungen zur PHPmyFAQ steht, dass das System mit PHP5.0.0-dev läuft.
Ich hatte das vor einiger Zeit mal mit einem Snapshot getestet. Da ging es (noch). Heute kann ich wegen der XML Änderung PHP-5.0.0b1 nioch nicht einmal lauffähig compilieren.
Bei PHP5-beta sind nun keine MySQL Extensions mehr drin,
Das ist eigentlich falsch. Die MySQL 'Treiber' waren bei PHP 4.3.x als bundle enthalten. Jetzt existiert wieder der alte Zustand, daß man die Developer Files für MySQL selbst installieren muß.

Viel schlimmer ist das Hick-Hack mit der neuen XML Version, mit der PhpMyFaq erst noch getestet werden muß.
Wie sieht es denn mit einer PostgreSQL Version aus? ;-)
Thorsten will die v2.0 auf PEAR umstellen. Da sähe es relativ einfach aus...

stephan
Posts: 129
Joined: Thu Feb 27, 2003 6:21 pm
Location: Bochum
Contact:

Post by stephan » Thu Aug 07, 2003 2:27 pm

Was brauche ich denn, um MySQL mit der aktuellen 5.0 beta ansprechen zu können?
Bzw, wo kriege ich diese Developer files, auch auf php.net?

Muss ich für PEAR irgendwas spezielles, nicht-standardmässiges auf meinen Server packen, oder das schon dabei? Wo ich grad dabei bin ;)

Stephan

meikel
Posts: 135
Joined: Wed Feb 12, 2003 11:12 am
Location: Erfurt
Contact:

Post by meikel » Thu Aug 07, 2003 2:59 pm

stephan wrote:Was brauche ich denn, um MySQL mit der aktuellen 5.0 beta ansprechen zu können?
Bzw, wo kriege ich diese Developer files, auch auf php.net?
Beispiel SuSE:
mysql-dev installieren und PHP '--with-mysql=/usr' compilieren.
Muss ich für PEAR irgendwas spezielles, nicht-standardmässiges auf meinen Server packen, oder das schon dabei? Wo ich grad dabei bin ;)
Das wissen die Götter, welche weiteren PEAR Module Thorsten zu verwenden gedenkt. Er hatte mal angedeutet, daß er PEAR mitliefern will.

Ansonsten isses keine Hürde, mit

Code: Select all

pear install paketname
den Kram nachzuinstallieren.

Thorsten
Posts: 14671
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sat Aug 09, 2003 8:45 am

Hi,

derzeit setze ich nur PEAR::DB ein.

PHP 5.0.0 beta habe ich noch nicht getestet.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

meikel
Posts: 135
Joined: Wed Feb 12, 2003 11:12 am
Location: Erfurt
Contact:

Post by meikel » Sat Aug 09, 2003 5:56 pm

Thorsten wrote:PHP 5.0.0 beta habe ich noch nicht getestet.
Das wird Dir als debian fan echt schwerfallen (-> update libxml2)

Seit dem Zeitpunkt, seitdem die die neue XML2 Biblothek voraussetzen, kriege ich keine lauffähigen Module mehr gebacken.

Thorsten
Posts: 14671
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sat Aug 09, 2003 6:01 pm

Hi,
meikel wrote:Das wird Dir als debian fan echt schwerfallen (-> update libxml2)
nö, das gibts auch bei Debian:
libxml2 - GNOME XML library
libxml2-dev - Development files for the GNOME XML library
bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

meikel
Posts: 135
Joined: Wed Feb 12, 2003 11:12 am
Location: Erfurt
Contact:

Post by meikel » Sat Aug 09, 2003 6:17 pm

Thorsten wrote:nö, das gibts auch bei Debian:
libxml2 - GNOME XML library
libxml2-dev - Development files for the GNOME XML library
Eine alte XML2 Bibliothek habe ich auch. Aber die will PHP5 nicht.
Mit libxml2-2.5.7 klappt es allerdings nicht.

Thorsten
Posts: 14671
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sat Aug 09, 2003 6:40 pm

Hiho,

welche libxml2 Version will denn PHP 5 ?

Debian bringt libxml 2.4.19 mit.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

meikel
Posts: 135
Joined: Wed Feb 12, 2003 11:12 am
Location: Erfurt
Contact:

Post by meikel » Sun Aug 10, 2003 12:52 am

Thorsten wrote:welche libxml2 Version will denn PHP 5 ?
Debian bringt libxml 2.4.19 mit.
Zu alt: >=2.5.1

Thorsten
Posts: 14671
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Mon Dec 08, 2003 8:30 am

Hi,

mit PHP 5.0.0 beta2 läuft die phpMyFAQ ab Version 1.3.9.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply