Installation failed: PMF 2.5.3 on MS SQL 2005

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
Markus-SSI
Posts: 35
Joined: Thu Aug 20, 2009 8:34 am

Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Markus-SSI » Wed Sep 02, 2009 2:57 pm

Installing phpMyFAQ 2.5.3 (today's version) on MS SQL 2005 server is a problem for me.
I have successfully created the database on the server, but when I am trying to install PMF there is an error occuring.
DB error: 102

INSERT INTO faqstopwords (id, lang, stopword) VALUES
(0, 'cs', 'dnes'),
(1, 'cs', 'cz'),
(2, 'cs', 'timto'),
(3, 'cs', 'budes'),
(4, 'cs', 'budem'),
(5, 'cs', 'byli'),
(6, 'cs', 'jses'),
(7, 'cs', 'muj'),
(8, 'cs', 'svym'),
(9, 'cs', 'ta'),
(10, 'cs', 'tomto'),
(11, 'cs', 'tohle'),
(12, 'cs', 'tuto'),
(13, 'cs', 'tyto'),
(14, 'cs', 'jej'),
(15, 'cs', 'zda'),
(16, 'cs', 'proc'),
(17, 'cs', 'mate'),
(18, 'cs', 'tato'),
(19, 'cs', 'kam'),
(20, 'cs', 'tohoto'),
(21, 'cs', 'kdo'),
.
.
.
What could be the problem?
kind regards
Markus
- phpMyFAQ 2.6.2

Thorsten
Posts: 14718
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Thorsten » Wed Sep 02, 2009 7:05 pm

Hi,

strange... error 102 says there's a wrong order of keywords... I'll check this.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Markus-SSI
Posts: 35
Joined: Thu Aug 20, 2009 8:34 am

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Markus-SSI » Thu Sep 03, 2009 12:16 pm

I have just tested to install PMF by deleting the content of \install\stopwords.sql.php
That succeeded and it works normally now.
kind regards
Markus
- phpMyFAQ 2.6.2

Thorsten
Posts: 14718
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Thorsten » Thu Sep 03, 2009 12:40 pm

Hi,

okay... it seems, MS SQL Server doesn't like the queries in the file... I'll check that.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Compuman
Posts: 17
Joined: Wed Feb 04, 2009 11:58 am
Location: Germany-Essen

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Compuman » Tue Sep 08, 2009 8:33 am

Hallo Thorsten,
ich beschäftige mich grade wieder mit dem Update auf die Version 2.5.2.
Da das Update leider nicht funktioniert hat, habe ich mich für eine neuinstallation entschieden.
Ich habe alle Datenbanken gelöscht und die aktuelle Version 2.5.2 heruntergeladen und installiert.
nachdem ich http://xxx.xxx.xxx.xxx/install/installer.php im Server aufrufe und alle Daten eingebe bekomme ich follgende FM:

Error: Please install your version of phpMyFAQ once again or send us a bug report.

DB error: 102

Query:

INSERT INTO ITfaqstopwords (id, lang, stopword) VALUES


Es wurde keine Tabelle erstellt.

Was kann da klemmen? Welche informationen brauchst du noch?

Die Installation ist auf einem Win Server 2003 R2 mit dem IIS6 PHP 5.2.10

PHP Info:

mssql
MSSQL Support enabled
Active Persistent Links 1
Active Links 1
Library version 7.0

Directive Local Value Master Value
mssql.allow_persistent On On
mssql.batchsize 0 0
mssql.compatability_mode Off Off
mssql.connect_timeout 5 5
mssql.datetimeconvert On On
mssql.max_links Unlimited Unlimited
mssql.max_persistent Unlimited Unlimited
mssql.max_procs Unlimited Unlimited
mssql.min_error_severity 10 10
mssql.min_message_severity 10 10
mssql.secure_connection Off Off
mssql.textlimit Server default Server default
mssql.textsize Server default Server default
mssql.timeout 60 60


Bin für jeden Tip dankbar.
Es grüßt freundlich

Markus

Thorsten
Posts: 14718
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Thorsten » Tue Sep 08, 2009 8:50 am

Hi,

ich bin noch am verifizieren, warum MS SQL die Queries mit den Stopwörtern nicht ausführt. Was klappte denn beim Update nicht?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Compuman
Posts: 17
Joined: Wed Feb 04, 2009 11:58 am
Location: Germany-Essen

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Compuman » Tue Sep 08, 2009 9:07 am

Hi Thorsten

Beim Update habe ich eine ähnliche Meldung nur mit einer anderen Tabelle erhalten.

Nach dem Update waren zum Teil meine Tabellen leer. Ich kommte mich dann auch nicht mehr anmelden.
Da es verschiedene kurriose Dinge waren, habe ich mich für eine Neuinstallation auf einem anderen Server mit einer Xternen SQL Datenbank entschlossen. Ich hoffe, dass ich die Daten anschließend trotzdem irgenwie übertragen bekomme.

vielen Dank schon mal.

Markus
Es grüßt freundlich

Markus

Thorsten
Posts: 14718
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Thorsten » Tue Sep 08, 2009 9:23 am

Hi Markus,

dass Daten gelöscht werden, darf aber gar nicht sein. Kannst du mir Infos geben? Dann schaue ich mir das an!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Compuman
Posts: 17
Joined: Wed Feb 04, 2009 11:58 am
Location: Germany-Essen

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Compuman » Thu Sep 17, 2009 8:00 am

Hallo Thorsten,

habe grade den Server noch einmal komplett neu aufgesetzt, die alte installation aufgespielt und dann das update durchgeführt.
Das update war erfolgreich als ich "Update von 2.5.1 zu 2.5.2" ausgewählt habe. How ever...

Nun habe ich aber nach dem Erfolgserlebnis weitere Probleme.

wenn ich einen Artiklel öffnen will, bekomme ich die Meldung "Der Artikel wird zur Zeit überarbeitet und kann leider nicht angezeigt werden". Diese erscheint bei allen Artikeln. die Cookies habe ich bereits gelöscht, jedoch ohne Erfolg

in deiner Docu steht, das eine Anmeldung am ADS nun möglich ist. Was miss ich da genau einstellen? Muss ich dafür die LDAPDATA.PHP anpassen oder die inc/constants_ldap.php? Kannst du mir ggf. ein Beispiel zukommen lassen?

Mein Problem mit dem PDF Export scheint nun erledigt zu sein.

Du hattest mal erwähnt, dass es eine Auswertung geben soll, die die Artikel nach Author auflistet. Wo finde ich die denn?


Viele Fragen.... Leider finde ich hier aber nichts zu den Punkten....:-((

danke für deine Geduld

Markus
Es grüßt freundlich

Markus

Thorsten
Posts: 14718
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Thorsten » Thu Sep 17, 2009 9:25 am

Hi,
wenn ich einen Artiklel öffnen will, bekomme ich die Meldung "Der Artikel wird zur Zeit überarbeitet und kann leider nicht angezeigt werden". Diese erscheint bei allen Artikeln. die Cookies habe ich bereits gelöscht, jedoch ohne Erfolg
wie sehen denn die Spalten date_start und date_end in der Tabelle faqdata aus? Da scheint etwas nicht zu stimmen. Von welcher Version hast du aktualsiert?
in deiner Docu steht, das eine Anmeldung am ADS nun möglich ist. Was miss ich da genau einstellen? Muss ich dafür die LDAPDATA.PHP anpassen oder die inc/constants_ldap.php? Kannst du mir ggf. ein Beispiel zukommen lassen?
viewtopic.php?f=2&t=10013
Du hattest mal erwähnt, dass es eine Auswertung geben soll, die die Artikel nach Author auflistet. Wo finde ich die denn?
Gar nicht, ist noch nicht drin.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Compuman
Posts: 17
Joined: Wed Feb 04, 2009 11:58 am
Location: Germany-Essen

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Compuman » Thu Sep 17, 2009 9:56 am

Hallo Thorsten,

danke für die schnelle Antwort.

Bei allen Beiträgen steht als date_start: 00010101000000 und bei date_end: 99991231235959

Ich habe das update von 2.0.10 durchgeführt.


In deinem Link steht eine Beschreibung zum LDAP. Das hatte ich so auch schon eingerichtet. Er nimmt aber weiterhin die lokalen User für die Anmeldung obwohl ich bei "user" <domain>\User eingegeben habe.
Muss ich an der constants_ldap.php nichts machen?

LG
Markus
Es grüßt freundlich

Markus

Compuman
Posts: 17
Joined: Wed Feb 04, 2009 11:58 am
Location: Germany-Essen

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Compuman » Thu Sep 17, 2009 10:32 am

was mir grade noch aufgefallen ist:

Wennich einen Beitrag öffne wir er als bereits geöffnet angezeigt. Bei diesen Beiträgen steht "aktiviert" auf NEIN. In der Datenbank steht der gleiche Artikel aber "active=yes"

Ach wenn ich den Beitrag aktiviere und abspeicher ist er beim nächsten öffnen wieder inaktive.

Wenn ich dir irgendwelche LOGs zuschicken soll, kein Problem....
Es grüßt freundlich

Markus

Thorsten
Posts: 14718
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Installation failed: PMF 2.5.3 on MS SQL 2005

Post by Thorsten » Thu Sep 17, 2009 12:34 pm

Hi,
Compuman wrote:In deinem Link steht eine Beschreibung zum LDAP. Das hatte ich so auch schon eingerichtet. Er nimmt aber weiterhin die lokalen User für die Anmeldung obwohl ich bei "user" <domain>\User eingegeben habe.
Muss ich an der constants_ldap.php nichts machen?
ich glaube nicht... ich hab kein AD und kenne mich da auch nicht so wirklich aus...

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply