install problem

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
activ8
Posts: 11
Joined: Wed Dec 31, 2003 3:30 pm

install problem

Post by activ8 » Wed Dec 31, 2003 3:31 pm

Hi,

When I try to run the installer, I get this error:

Warning: open_basedir restriction in effect. File is in wrong directory in SYS:/Apache2/htdocs/test/install/installer.php on line 80

The file ../inc/data.php or the directory ../inc is not writeable.


Help !

Activ8

Thorsten
Posts: 14781
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Wed Dec 31, 2003 3:52 pm

Hi,

open_basedir, if set, limits all file operations to the defined directory and below. This directive makes most sense if used in a per-directory or per-virtualhost web server configuration file. This directive is *NOT* affected by whether Safe Mode is turned On or Off.

Edit your php.ini to

Code: Select all

SYS:/Apache2/htdocs/
bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

activ8
Posts: 11
Joined: Wed Dec 31, 2003 3:30 pm

Post by activ8 » Mon Jan 05, 2004 6:31 pm

Ok, that worked.
I was able to install it after the php.ini config change.

However.
I can post questions do all the stuff I'm sposed to..
but when I do a search I run into this problem:
Search for a know keyword.
I get a result page with this right above it:

Warning: Compilation failed: this version of PCRE is not compiled with PCRE_UTF8 support at offset -1137167700 in SYS:/Apache2/htdocs/phpmyfaq/inc/functions.php on line 1013

Warning: Compilation failed: this version of PCRE is not compiled with PCRE_UTF8 support at offset -1137167700 in SYS:/Apache2/htdocs/phpmyfaq/inc/functions.php on line 1014

I can then click on the result. and get this:

Warning: Compilation failed: this version of PCRE is not compiled with PCRE_UTF8 support at offset -1822936256 in SYS:/Apache2/htdocs/phpmyfaq/artikel.php on line 89

Ok thanks,

Ed

Thorsten
Posts: 14781
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Tue Jan 06, 2004 8:37 am

Hi Ed,

your PHP was not compiled completly correct. Which version do you use?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply