Attachment hochladen geht nicht

Please report bugs here!

Moderators: jason102178, Florian, Thorsten, JochenS

Attachment hochladen geht nicht

Postby gorelord_x » Wed Mar 07, 2012 1:32 pm

Hallo Thorsten
kannst du mir eine Tip geben?

Erhalte nach dem upload Dialog nur folgende Fehlermeldung
Leider ist ein Fehler beim hochladen des Anhangs aufgetreten.

System
IIS 6.0
MSSQL Server

neue FAQ Datenbank noch ohne Inhalt
hab nur eine Testeintrag erstellt.
Gruss
Stefan
gorelord_x
 
Posts: 11
Joined: Wed Feb 01, 2012 5:12 pm

Re: Attachment hochladen geht nicht

Postby Thorsten » Wed Mar 07, 2012 2:48 pm

Hi,

aktiviere mal in der inc/Init.php den DEBUG Modus und versuche es nochmal.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Thorsten
 
Posts: 12968
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq

Re: Attachment hochladen geht nicht

Postby gorelord_x » Wed Mar 07, 2012 4:06 pm

hier die Debug Infos
Anhang zur FAQ hinzufügen

phpMyFAQ warning [2]: filesize() [function.filesize]: stat failed for C:\WINDOWS\Temp\php9812.tmp in C:\Inetpub\wwwroot\faq\admin\attachment.php on line 164

phpMyFAQ warning [2]: fopen(C:\Inetpub\wwwroot\faq\attachments\\\\) [function.fopen]: failed to open stream: No such file or directory in C:\Inetpub\wwwroot\faq\inc\PMF_Attachment\Filesystem\File.php on line 71


Leider ist ein Fehler beim Hochladen des Anhangs aufgetreten.

Gruss
Stefan
gorelord_x
 
Posts: 11
Joined: Wed Feb 01, 2012 5:12 pm

Re: Attachment hochladen geht nicht

Postby Thorsten » Wed Mar 07, 2012 4:41 pm

Hi,

dein IIS darf nicht in den Temp-Ordner schreiben. Gib ihm Schreibrechte und es sollte funktionieren.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Thorsten
 
Posts: 12968
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq

Re: Attachment hochladen geht nicht

Postby gorelord_x » Thu Mar 08, 2012 10:08 am

Funktioniert
besten Dank


Erhalte im Debug Modus noch folgende Fehlermeldung
Scheint aber alles zu funktionieren
Kann ich die Meldung dann ignorieren?

phpMyFAQ warning [2]: Wrong parameter count for strstr() in C:\Inetpub\wwwroot\faq\inc\PMF_String\UTF8ToLatinConvertable.php on line 199

Viele Gruesse
Stefan
gorelord_x
 
Posts: 11
Joined: Wed Feb 01, 2012 5:12 pm

Re: Attachment hochladen geht nicht

Postby Thorsten » Thu Mar 08, 2012 10:22 am

Hi,

die schau ich mir an, ist aber unkritisch.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Thorsten
 
Posts: 12968
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq

Re: Attachment hochladen geht nicht

Postby SSP-Europe » Fri Mar 16, 2012 12:15 pm

Hallo,

habe in unserer Umgebung dasselbe Problem. Auf welchen Temp Ordner muss ich die Freigabe setzen? Direkt am Windows Temp-Ordner?

Gruß
SSP-Europe
 
Posts: 6
Joined: Tue Jan 03, 2012 11:03 am

Re: Attachment hochladen geht nicht

Postby Thorsten » Fri Mar 16, 2012 12:40 pm

Hi,

ja, der Webserver muss da halt Schreibrechte haben.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Thorsten
 
Posts: 12968
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq

Re: Attachment hochladen geht nicht

Postby SSP-Europe » Fri Mar 16, 2012 1:14 pm

Läuft bei uns aber unter Apache auf einem Linux System.
Auf welches Verzeichnes greift der da zu?
SSP-Europe
 
Posts: 6
Joined: Tue Jan 03, 2012 11:03 am

Re: Attachment hochladen geht nicht

Postby Thorsten » Fri Mar 16, 2012 1:23 pm

Hi,

normal /tmp

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Thorsten
 
Posts: 12968
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq

Re: Attachment hochladen geht nicht

Postby SSP-Europe » Fri Mar 16, 2012 2:46 pm

Hallo nochmal,

das sind die Rechte für den attachment Ordner und für die Unterordner im temp Ordner, die angelegt werden...funktioniert leider immer noch nicht.

drwxrwxrwx 5 root root 4096 16. Mär 13:13 attachments

drwxr-xr-x 3 www-data www-data 4096 15. Mär 15:20 10814
drwxr-xr-x 3 www-data www-data 4096 16. Mär 13:13 85c48
drwxr-xr-x 3 www-data www-data 4096 15. Mär 17:29 d0a0e
-rw-r--r-- 1 www-data www-data 373 9. Nov 13:42 index.html
SSP-Europe
 
Posts: 6
Joined: Tue Jan 03, 2012 11:03 am

Re: Attachment hochladen geht nicht

Postby Thorsten » Sat Mar 17, 2012 8:00 am

Hi,

der Ordner gehört auch root, das ist schlecht. :-)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Thorsten
 
Posts: 12968
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest