Upgrade 2.8 to 2.9. ldap bind fail

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
chrisam
Posts: 2
Joined: Wed Jan 11, 2017 4:36 pm

Upgrade 2.8 to 2.9. ldap bind fail

Post by chrisam » Wed Jan 11, 2017 4:51 pm

Upgraded from 2.8 to 2.9.5. The front-end is blank but when I browse the the admin page I enter my ad credentials and get an error. I enabled DEBUG mode.

When I try to log in I see the following error:

Code: Select all

phpMyFAQ warning [2]: ldap_bind(): Unable to bind to server: Invalid credentials in C:\xampp\htdocs\FAQ\inc\PMF\Ldap.php on line 179
Per the upgrade instructions I did not delete ldap.php from config/

chrisam
Posts: 2
Joined: Wed Jan 11, 2017 4:36 pm

Re: Upgrade 2.8 to 2.9. ldap bind fail

Post by chrisam » Thu Jan 12, 2017 8:35 pm

I tested by creating a new LDAP service account and I am now receiving the following notices and warnings.


Code: Select all

phpMyFAQ notice [8]: Undefined index: ldap_user in C:\xampp\htdocs\FAQ\inc\PMF\Configuration.php on line 254

phpMyFAQ notice [8]: Undefined index: ldap_password in C:\xampp\htdocs\FAQ\inc\PMF\Configuration.php on line 255

phpMyFAQ warning [2]: ldap_search(): Search: Operations error in C:\xampp\htdocs\FAQ\inc\PMF\Ldap.php on line 323

phpMyFAQ warning [2]: ldap_search(): Search: Operations error in C:\xampp\htdocs\FAQ\inc\PMF\Ldap.php on line 274

Thorsten
Posts: 14728
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade 2.8 to 2.9. ldap bind fail

Post by Thorsten » Sun Jan 15, 2017 10:15 pm

Hi,

I will check it.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

com
Posts: 184
Joined: Wed May 04, 2005 12:41 am

Re: Upgrade 2.8 to 2.9. ldap bind fail

Post by com » Mon Jan 16, 2017 9:58 am

Hi Thorsten,

bist du noch via Email erreichbar? Ich habe es per Direktnachricht (hier im Forum) versucht.

Danke & viele Grüße,

Jessy

Thorsten
Posts: 14728
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade 2.8 to 2.9. ldap bind fail

Post by Thorsten » Fri Jan 20, 2017 9:26 pm

Hi,

this hint should help: https://github.com/thorsten/phpMyFAQ/issues/1292

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply