Unable to upgrade from 2.7.9 to 2.97

Please report bugs here!

Moderator: Thorsten

Post Reply
Abolah
Posts: 3
Joined: Tue May 30, 2017 3:59 pm

Unable to upgrade from 2.7.9 to 2.97

Post by Abolah » Tue May 30, 2017 4:06 pm

Hello ,

I'm having troubles to upgrade PHPMyFAQ from 2.7.9 to 2.9.7.

I'm working on a CentOS 6 updated with the latest kernel and packages
My Web browser is Vivaldi 1.9
I updated PHP to 5.6 and Mysql.

When I follow the documentation to upgrade i encounter this error in my /var/log/httpd/error_log
parse error.PNG
And when i try to launch the update script on my web browser i get an error 500.

Could you help me to sort it out ?
You do not have the required permissions to view the files attached to this post.

Thorsten
Posts: 14489
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Unable to upgrade from 2.7.9 to 2.97

Post by Thorsten » Thu Jun 01, 2017 8:14 pm

Hi,

are you sure you're running PHP 5.6?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Abolah
Posts: 3
Joined: Tue May 30, 2017 3:59 pm

Re: Unable to upgrade from 2.7.9 to 2.97

Post by Abolah » Fri Jun 02, 2017 8:41 am

Hello,

Yes i'm running PHP 5.6 installed through the remi repository on CentOS.

I figured out how to solve this error tho (bad apache configuration).

The first and second steps are going well as you can see here
step1.PNG
step2.PNG

But now i'm encountering another error.

When i'm trying to upgrade by using the /setup/update.php script i'm having DB error like this.
step3.PNG
I followed the documentation precisely by the way.

Could you help me ?

Regards,

Abolah
You do not have the required permissions to view the files attached to this post.

Thorsten
Posts: 14489
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Unable to upgrade from 2.7.9 to 2.97

Post by Thorsten » Sun Jun 04, 2017 8:21 am

Hi,

looks like the update was already partly successful as a new table was already created. You can try to delete the table "faqinstances" and try it again.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Abolah
Posts: 3
Joined: Tue May 30, 2017 3:59 pm

Re: Unable to upgrade from 2.7.9 to 2.97

Post by Abolah » Tue Jun 06, 2017 8:42 am

Hello Thorsten,

I deleted the table faqinstances as you said and i got this error.
duplicata.PNG
Duplicata of the field 39 for the primary key

If I try to delete this field i have other dulpicata errors unfortunately.

Have you ever encountered this ?

Or is there i way to import my FAQ questions directly into a fresh install of PHPMyFAQ 2.9.7 ?

Bye,
Abolah
You do not have the required permissions to view the files attached to this post.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests