Die Funkion "Frage stellen" funktioniert nicht

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
Rudi
Posts: 2
Joined: Mon Sep 18, 2023 7:15 am

Die Funkion "Frage stellen" funktioniert nicht

Post by Rudi »

Schönen guten Tag an alle.
Dies ist mein erster Forum Eintrag, seid bitte nachsichtig mit mir.

Ich habe phpMyFAQ in der Version 3.2.2 installiert und es scheint so gut wie alles zu funktionieren.
Außer die Funktion "Frage Stellen". Ich kann hier eine Frage eintippen und den Button Absenden betätigen.
Ich bekomme auch eine Mail als Admin wo die Frage noch mal drin steht. Auch von welchem User diese kommt.
Die Frage kann ich aber in phpMyFAQ unter Offene Fragen nirgends finden.

leider konnte ich bis her noch nichts in den Forum Einträgen finden, was mir hätte helfen können.
Kann mir da jemand ein paar Tipps geben was ich probieren könnte?

Die Installation ist relativ frisch. Die Funktion Frage stellen hat aber von Anfang an nicht funktioniert.

Hier noch der Debugauszug:

⚠︎ DEBUG MODE ENABLED ⚠︎
DATABASE QUERIES
/html/aftersalesfaq/src/Bootstrap.php: phpMyFAQ\Configuration->getAll() in line 149:
SELECT config_name, config_value FROM faqconfig
/html/aftersalesfaq/src/phpMyFAQ/User/CurrentUser.php: phpMyFAQ\User->getUserById() in line 516:
SELECT user_id, login, account_status, is_superadmin, auth_source FROM faquser WHERE user_id = 1 AND account_status != 'blocked'
/html/aftersalesfaq/src/phpMyFAQ/User.php: phpMyFAQ\User\UserData->load() in line 799:
SELECT last_modified, display_name, email, is_visible, twofactor_enabled, secret FROM faquserdata WHERE user_id = 1
/html/aftersalesfaq/src/phpMyFAQ/User/CurrentUser.php: phpMyFAQ\User\CurrentUser->getSessionInfo() in line 526:
SELECT session_id, session_timestamp, ip, success FROM faquser WHERE user_id = 1
/html/aftersalesfaq/src/phpMyFAQ/User/CurrentUser.php: phpMyFAQ\Permission\MediumPermission->getUserGroups() in line 481:
SELECT fg.group_id AS group_id FROM faquser fu, faquser_group fug, faqgroup fg WHERE fu.user_id = 1 AND fu.user_id = fug.user_id AND fg.group_id = fug.group_id
/html/aftersalesfaq/index.php: phpMyFAQ\Session->checkSessionId() in line 242:
SELECT sid FROM faqsessions WHERE sid = 586 AND ip = '188.103.*.*' AND time > 1698756443
/html/aftersalesfaq/src/phpMyFAQ/Category.php: phpMyFAQ\Category->getOrderedCategories() in line 108:
SELECT fc.id AS id, fc.lang AS lang, fc.parent_id AS parent_id, fc.name AS name, fc.description AS description, fc.user_id AS user_id, fc.group_id AS group_id, fc.active AS active, fc.image AS image, fc.show_home AS show_home FROM faqcategories fc LEFT JOIN faqcategory_group fg ON fc.id = fg.category_id LEFT JOIN faqcategory_order fco ON fc.id = fco.category_id LEFT JOIN faqcategory_user fu ON fc.id = fu.category_id WHERE ( fg.group_id IN (-1, 1, 2, 3) OR (fu.user_id = -1 AND fg.group_id IN (-1, 1, 2, 3))) AND fc.active = 1 AND fc.lang = 'de' GROUP BY fc.id, fc.lang, fc.parent_id, fc.name, fc.description, fc.user_id, fc.group_id, fc.active, fc.image, fc.show_home, fco.position ORDER BY fco.position, fc.id ASC
/html/aftersalesfaq/src/phpMyFAQ/User.php: phpMyFAQ\User\UserData->get() in line 816:
SELECT display_name FROM faquserdata WHERE user_id = 1
/html/aftersalesfaq/src/phpMyFAQ/User.php: phpMyFAQ\User\UserData->get() in line 816:
SELECT display_name FROM faquserdata WHERE user_id = 1
/html/aftersalesfaq/src/phpMyFAQ/Tags.php: phpMyFAQ\Tags->getAllTags() in line 343:
SELECT MIN(t.tagging_id) AS tagging_id, t.tagging_name AS tagging_name FROM faqtags t LEFT JOIN faqdata_tags dt ON dt.tagging_id = t.tagging_id LEFT JOIN faqdata d ON d.id = dt.record_id WHERE 1=1 AND d.active = 'yes' GROUP BY tagging_name ORDER BY tagging_name ASC
/html/aftersalesfaq/src/phpMyFAQ/Tags.php: phpMyFAQ\Tags->getFaqsByTagName() in line 346:
SELECT dt.record_id AS record_id FROM faqtags t, faqdata_tags dt LEFT JOIN faqdata d ON d.id = dt.record_id WHERE t.tagging_id = dt.tagging_id AND t.tagging_name = '9001'
/html/aftersalesfaq/src/phpMyFAQ/Permission/MediumPermission.php: phpMyFAQ\User->getUserById() in line 96:
SELECT user_id, login, account_status, is_superadmin, auth_source FROM faquser WHERE user_id = 1 AND account_status != 'blocked'
/html/aftersalesfaq/src/phpMyFAQ/User.php: phpMyFAQ\User\UserData->load() in line 799:
SELECT last_modified, display_name, email, is_visible, twofactor_enabled, secret FROM faquserdata WHERE user_id = 1
/html/aftersalesfaq/src/phpMyFAQ/Permission/MediumPermission.php: phpMyFAQ\Permission\BasicPermission->getRightId() in line 104:
SELECT right_id FROM faqright WHERE name = 'viewadminlink'
/html/aftersalesfaq/src/phpMyFAQ/Permission/MediumPermission.php: phpMyFAQ\Permission\MediumPermission->checkUserGroupRight() in line 109:
SELECT fr.right_id AS right_id FROM faqright fr, faqgroup_right fgr, faqgroup fg, faquser_group fug, faquser fu WHERE fr.right_id = 18 AND fr.right_id = fgr.right_id AND fg.group_id = fgr.group_id AND fg.group_id = fug.group_id AND fu.user_id = fug.user_id AND fu.user_id = 1
/html/aftersalesfaq/src/phpMyFAQ/User.php: phpMyFAQ\User\UserData->get() in line 816:
SELECT display_name FROM faquserdata WHERE user_id = 1
/html/aftersalesfaq/index.php: phpMyFAQ\Faq->getRecordsWithoutPagingByCategoryId() in line 756:
SELECT fd.id AS id, fd.lang AS lang, fd.thema AS thema, fcr.category_id AS category_id, fv.visits AS visits FROM faqdata fd LEFT JOIN faqcategoryrelations fcr ON fd.id = fcr.record_id AND fd.lang = fcr.record_lang LEFT JOIN faqvisits fv ON fd.id = fv.id AND fv.lang = fd.lang LEFT JOIN faqdata_group fdg ON fd.id = fdg.record_id LEFT JOIN faqdata_user fdu ON fd.id = fdu.record_id WHERE fd.date_start <= '20231101134723' AND fd.date_end >= '20231101134723' AND fd.active = 'yes' AND fcr.category_id = 0 AND fd.lang = 'de' AND ( fdu.user_id = 1 OR fdg.group_id IN (-1, 1, 2, 3) ) GROUP BY fd.id,fd.lang,fd.thema,fcr.category_id,fv.visits ORDER BY id DESC


Danke schon mal im Voraus für die eure Unterstützung.

Gruß Rudi
Thorsten
Posts: 15570
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Die Funkion "Frage stellen" funktioniert nicht

Post by Thorsten »

Hi,

ich schau mir das Problem mal an.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Thorsten
Posts: 15570
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Die Funkion "Frage stellen" funktioniert nicht

Post by Thorsten »

Hi,

Fehler gefunden bzw. mehrere dort:

https://github.com/thorsten/phpMyFAQ/co ... 946fd1437c

Hinweis: du musst die JavaScript-Dateien neu bauen, wenn du es selber fixen willst.

Ansonsten kommt der Fix mit der kommenden phpMyFAQ 3.2.3

Danke!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Rudi
Posts: 2
Joined: Mon Sep 18, 2023 7:15 am

Re: Die Funkion "Frage stellen" funktioniert nicht

Post by Rudi »

Hi Thorsten,

super und danke für die schnelle Unterstützung.
Dann warte ich mal auf die neue Version.
Weißt du schon wann du die in etwa veröffentlichen wirst?

Viele Grüße

Rudi
Thorsten
Posts: 15570
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Die Funkion "Frage stellen" funktioniert nicht

Post by Thorsten »

Hi,

in den nächsten 2 oder 3 Wochen.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Post Reply