2 problems after upgrade to 2.8.2

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

ubellavance
Posts: 40
Joined: Fri Apr 05, 2013 7:46 pm

2 problems after upgrade to 2.8.2

Post by ubellavance » Mon Sep 16, 2013 4:17 pm

Hi,

I have two problems since I upgraded to 2.8.2:
  • I cannot create a group. When I try to create one, I get this error message: "Pas d'ID spécifié" (in French. Would translate into "No ID specified")
  • Users that have article edit permissions cannot edit FAQs. Actually, when they go into Contents, Edit Article, then click on a category, nothing happens. The category doesn't open up to show all the faqs.

Thorsten
Posts: 15024
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2 problems after upgrade to 2.8.2

Post by Thorsten » Tue Sep 17, 2013 5:47 am

Hi,

what database do you use?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

ubellavance
Posts: 40
Joined: Fri Apr 05, 2013 7:46 pm

Re: 2 problems after upgrade to 2.8.2

Post by ubellavance » Tue Sep 17, 2013 1:14 pm

Database Server mysql
Database Server Version 5.0.95
Database Client Version 5.1.47

Thorsten
Posts: 15024
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2 problems after upgrade to 2.8.2

Post by Thorsten » Thu Sep 19, 2013 3:57 pm

Hi,

when you created a group, did you add any users? If this happens this error message occurs.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

ubellavance
Posts: 40
Joined: Fri Apr 05, 2013 7:46 pm

Re: 2 problems after upgrade to 2.8.2

Post by ubellavance » Thu Sep 19, 2013 4:13 pm

Do you mean add a user while creating a group? I tried that and it doesn't work.

What I did is simply create a new group, to add users to the group after.

Did you have time to check the second problem? My users can't edit FAQ entries right now...

Thanks,

Thorsten
Posts: 15024
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2 problems after upgrade to 2.8.2

Post by Thorsten » Fri Sep 20, 2013 10:59 am

Hi,

we added a new permission setting in 2.8 for adding FAQs, please add this permissions for your users.

For group creation: I cannot reproduce this issue, is it possible to check it on your FAQ?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

ubellavance
Posts: 40
Joined: Fri Apr 05, 2013 7:46 pm

Re: 2 problems after upgrade to 2.8.2

Post by ubellavance » Fri Sep 20, 2013 2:24 pm

For the permission, I think I added it. Here is the summary of the rights based on what's in the database:

4-6, 10-15, 24, 31-35. Am I missing something?

For the group creation: I could eventually give you access, yes (it is not public-facing).

Thorsten
Posts: 15024
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2 problems after upgrade to 2.8.2

Post by Thorsten » Sat Sep 21, 2013 9:08 am

Hi,

looks okay, I need a deeper look on your FAQ.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

ubellavance
Posts: 40
Joined: Fri Apr 05, 2013 7:46 pm

Re: 2 problems after upgrade to 2.8.2

Post by ubellavance » Mon Sep 23, 2013 4:14 pm

Hi,

About the group add problem, I found it, it was my error.

About the other problem, we found out that it worked well under FF or Chrome, but not under Internet Explorer. Tested under Win7 (IE 9) and WinXP (IE 8). We now have a workaround, but a fix would be appreciated.

Thorsten
Posts: 15024
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2 problems after upgrade to 2.8.2

Post by Thorsten » Tue Sep 24, 2013 8:02 pm

Hi,

so the permission issue is only on IE?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

ubellavance
Posts: 40
Joined: Fri Apr 05, 2013 7:46 pm

Re: 2 problems after upgrade to 2.8.2

Post by ubellavance » Tue Sep 24, 2013 8:13 pm

Actually, it is not a permission problem. I figured out that even a full admin can't edit an FAQ entry in IE.

Thorsten
Posts: 15024
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2 problems after upgrade to 2.8.2

Post by Thorsten » Wed Sep 25, 2013 7:00 pm

Hi,

okay, I'll check that.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

ubellavance
Posts: 40
Joined: Fri Apr 05, 2013 7:46 pm

Re: 2 problems after upgrade to 2.8.2

Post by ubellavance » Tue Oct 08, 2013 2:07 pm

Did you have a chance to have a look at the Internet Explorer issue?

Thanks,

ubellavance
Posts: 40
Joined: Fri Apr 05, 2013 7:46 pm

Re: 2 problems after upgrade to 2.8.2

Post by ubellavance » Wed Oct 23, 2013 12:57 pm

Thorsten,

Would you like me to file a bug report?

Thorsten
Posts: 15024
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: 2 problems after upgrade to 2.8.2

Post by Thorsten » Wed Oct 23, 2013 7:37 pm

Hi,

yes, that's always the better way. :-)

Thanks!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply