upgrading from 1.5.0 to 1.5.1

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

upgrading from 1.5.0 to 1.5.1

Post by jazcyk » Wed Sep 21, 2005 11:37 am

the 1.5.x docs say:
3.d. Upgrading phpMyFAQ 1.5.x

Updating phpMyFAQ 1.5.x is fairly simple. Via FTP copy all new files from the update zip file except:
the files data.php and config.php in the directory inc/
all files in the template/ directory
However I can't find an update.zip file nowhere :?
Am I blind (has happend before!) or has it jut not been packed yet?

Since I have customized the index.tpl a little I would like to ask too if there is any change in that file form 1.5.0 to 1.5.1 (if not there is no idea in replacing the file!).

BTW: what is a realistic time-perspective for 1.6.x to be production-ready ?
Last edited by jazcyk on Wed Sep 21, 2005 11:47 am, edited 1 time in total.

Thorsten
Posts: 14973
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Wed Sep 21, 2005 11:44 am

Hi,

just take the full package and don't overwrite your template files. Sorry for the wrong documentation, I'll fix it as soon as possible.
BTW: what is a realistic time-perspective for 1.6.x to be production-ready ?
If everything goes well we have a first alpha version this year. 1.6 will be a big update due to the new authentication system.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

I want to be sure to do it right!

Post by jazcyk » Wed Sep 21, 2005 11:51 am

Replace everything exept the /template directory ?
What about the database? Any changes to this?
Should the update.php file be executed (if there is any) ?

Thorsten
Posts: 14973
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Wed Sep 21, 2005 11:52 am

Hi,

yes, all files... the database won't be upgraded, but run update.php.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

I get this error

Post by jazcyk » Wed Sep 21, 2005 12:33 pm

Warning: main(/home/httpd/vhosts/webyog.com/httpdocs/faq/inc/data.php): failed to open stream: No such file or directory in /home/httpd/vhosts/webyog.com/httpdocs/faq/install/update.php on line 27

Fatal error: main(): Failed opening required '/home/httpd/vhosts/webyog.com/httpdocs/faq/inc/data.php' (include_path='.:/usr/share/pear') in /home/httpd/vhosts/webyog.com/httpdocs/faq/install/update.php on line 27
What I did:

1) renamed the downloaded directory to "newfaq" and uploaded it as "newfaq"
2) deleted /newfaq/template directory and copied the /template directory from /faq to newfaq
3) renamed /faq to /oldfaq and renamed /newfaq to /faq

... that should be the same I think as overwriting the files - except that my old /faq directory still is intact in /oldfaq

running the ...install/update.php script returned the error.

So I now renamed /faq to /newfaq and renamed /oldfaq to /faq
... and is up and running again.

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

and of course ...

Post by jazcyk » Wed Sep 21, 2005 12:35 pm

I also replaced the .htaccess from the old /faq to the new.
Did that before running the script.

Thorsten
Posts: 14973
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Wed Sep 21, 2005 12:35 pm

Hi,

you still need inc/config.php and inc/data.php. They won't be overwritten from the full package because they were generate at installation.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

getting a little bit further

Post by jazcyk » Wed Sep 21, 2005 12:41 pm

but ..

Error: The file ../inc/data.php or the directory ../inc is not writeable. Please correct this!

Error: The file ../inc/config.php is not writeable. Please correct this!

Error: The backup file ../inc/data.php.bak could not be written. Please correct this!

Error: The backup file ../inc/config.php.bak could not be written. Please correct this!

Error: Your version of phpMyFAQ could not updated.

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

and just want to add

Post by jazcyk » Wed Sep 21, 2005 12:47 pm

CHMOD level is 755 and I log on with same credentials as when installing first time.

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

I remember ...

Post by jazcyk » Wed Sep 21, 2005 12:58 pm

.. that when we installed first time we had to log on the server from commandline as ROOT using SSH and change credentials to get write-access for installer.php - so that is probably it this time too. A special privilege problem on this server. Typical *nix issue!

Nice to be able to send work on to another person. Because I am not allowed to do this! :D

Thorsten
Posts: 14973
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Wed Sep 21, 2005 1:04 pm

Hi,

hm, you have a very restrictive PHP installation but chmod 755 should work. :-)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

Hi Thorsten

Post by jazcyk » Mon Sep 26, 2005 7:56 am

please have a look here:
http://www.webyog.com/faq/index.php?

I just upgraded to 1.5.2

It seems that only german and english are known with 1.5.2!?

Any fix?

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

sorry

Post by jazcyk » Mon Sep 26, 2005 10:35 am

but this
viewtopic.php?t=1772
should have been posted in this thread and not as a new thread.

Thorsten
Posts: 14973
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Mon Sep 26, 2005 11:00 am

Hi,

I see all languages in your FAQ. You should upgrade to 1.5.2 as soon as possible.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

hey you don't understand!

Post by jazcyk » Mon Sep 26, 2005 11:06 am

go to www.webyog.com/faqnew and choose any other language but german and english!

It returns:
Warning: mb_language(): Unknown language "da" in /home/httpd/vhosts/webyog.com/httpdocs/faqnew/index.php on line 132

and even more garbage in japanese etc ...

So /faqnew IS 1.5.2, but that language problem is not acceptable!
If there is moe I need to do I'll do it, but then please tell ALL of it this time![/b]

Post Reply