Upgrade problems

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
mjg
Posts: 5
Joined: Wed Apr 13, 2005 12:10 pm
Location: Porepunkah, Australia
Contact:

Upgrade problems

Post by mjg » Sun Sep 25, 2005 6:41 am

I've had some problems upgrading from 1.41 to 1.52. Firstly, I received this message at the end of the update:
Error: Unknown column 'user' in 'faqadminlog' and
Query:
ALTER TABLE faqadminlog CHANGE user usr INT(11) DEFAULT '0' NOT NULL
I was able to login to admin okay. The start page tells me I have 30 records. The articles and categories all show, but none of the questions! They're still in the database though.

I can create new questions, and they appear in the database, but not on the site or in the admin area for editing. What should I do?

Thorsten
Posts: 14977
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sun Sep 25, 2005 6:43 am

Hi,

how are the columns "lang" in faqdata, "category_lang" and "record_lang" look like in your database?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

mjg
Posts: 5
Joined: Wed Apr 13, 2005 12:10 pm
Location: Porepunkah, Australia
Contact:

Post by mjg » Sun Sep 25, 2005 7:05 am

lang looks fine with (en) in all entries.

I don't have columns for category_lang or record_lang. Should I?

Thanks,
Michael

Thorsten
Posts: 14977
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sun Sep 25, 2005 7:34 am

Hi,
mjg wrote:I don't have columns for category_lang or record_lang. Should I?
do you have a table called faqcategoryrelations?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

mjg
Posts: 5
Joined: Wed Apr 13, 2005 12:10 pm
Location: Porepunkah, Australia
Contact:

Post by mjg » Sun Sep 25, 2005 7:56 am

No, I don't have that table. I'm guessing I should have it.

What next? Thanks.

Thorsten
Posts: 14977
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sun Sep 25, 2005 8:02 am

Hi,

I think, you didn't select the correct version for update. Can you post you current table structure here?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

mjg
Posts: 5
Joined: Wed Apr 13, 2005 12:10 pm
Location: Porepunkah, Australia
Contact:

Post by mjg » Sun Sep 25, 2005 8:30 am

Here it is, thanks for looking:

CREATE TABLE `faqadminlog` (
`id` int(11) NOT NULL auto_increment,
`time` int(11) NOT NULL default '0',
`usr` int(11) NOT NULL default '0',
`text` text NOT NULL,
`ip` text NOT NULL,
PRIMARY KEY (`id`)
) TYPE=MyISAM AUTO_INCREMENT=68 ;

CREATE TABLE `faqadminsessions` (
`uin` varchar(50) binary NOT NULL default '',
`usr` tinytext NOT NULL,
`pass` varchar(64) binary NOT NULL default '',
`ip` text NOT NULL,
`time` int(11) NOT NULL default '0'
) TYPE=MyISAM;


CREATE TABLE `faqcategories` (
`id` int(11) NOT NULL auto_increment,
`lang` varchar(5) NOT NULL default '',
`parent_id` int(11) NOT NULL default '0',
`name` varchar(255) NOT NULL default '',
`description` varchar(255) NOT NULL default '',
PRIMARY KEY (`id`,`lang`)
) TYPE=MyISAM AUTO_INCREMENT=217240 ;

CREATE TABLE `faqchanges` (
`id` int(11) NOT NULL auto_increment,
`beitrag` int(11) NOT NULL default '0',
`lang` varchar(5) NOT NULL default '',
`usr` int(11) NOT NULL default '0',
`datum` int(11) NOT NULL default '0',
`what` text NOT NULL,
PRIMARY KEY (`id`)
) TYPE=MyISAM AUTO_INCREMENT=14 ;


CREATE TABLE `faqcomments` (
`id_comment` int(11) NOT NULL auto_increment,
`id` int(11) NOT NULL default '0',
`usr` varchar(255) NOT NULL default '',
`email` varchar(255) NOT NULL default '',
`comment` text NOT NULL,
`datum` int(15) NOT NULL default '0',
`helped` text NOT NULL,
PRIMARY KEY (`id_comment`)
) TYPE=MyISAM AUTO_INCREMENT=1 ;


CREATE TABLE `faqdata` (
`id` int(11) NOT NULL auto_increment,
`lang` varchar(5) NOT NULL default '',
`active` char(3) NOT NULL default '',
`rubrik` text NOT NULL,
`keywords` text NOT NULL,
`thema` text NOT NULL,
`content` longtext NOT NULL,
`author` varchar(255) NOT NULL default '',
`email` varchar(255) NOT NULL default '',
`comment` enum('y','n') NOT NULL default 'y',
`datum` varchar(15) NOT NULL default '',
PRIMARY KEY (`id`,`lang`),
FULLTEXT KEY `keywords` (`keywords`,`thema`,`content`)
) TYPE=MyISAM AUTO_INCREMENT=31 ;


CREATE TABLE `faqfragen` (
`id` int(11) unsigned NOT NULL auto_increment,
`ask_username` varchar(100) NOT NULL default '',
`ask_usermail` varchar(100) NOT NULL default '',
`ask_rubrik` varchar(100) NOT NULL default '',
`ask_content` text NOT NULL,
`ask_date` varchar(20) NOT NULL default '',
PRIMARY KEY (`id`)
) TYPE=MyISAM AUTO_INCREMENT=1 ;


CREATE TABLE `faqnews` (
`id` int(11) NOT NULL auto_increment,
`header` varchar(255) NOT NULL default '',
`artikel` text NOT NULL,
`datum` varchar(14) NOT NULL default '',
`link` varchar(255) NOT NULL default '',
`linktitel` varchar(255) NOT NULL default '',
`target` varchar(255) NOT NULL default '',
PRIMARY KEY (`id`)
) TYPE=MyISAM AUTO_INCREMENT=2 ;


CREATE TABLE `faqsessions` (
`sid` int(11) NOT NULL auto_increment,
`ip` text NOT NULL,
`time` int(11) NOT NULL default '0',
PRIMARY KEY (`sid`)
) TYPE=MyISAM AUTO_INCREMENT=271 ;


CREATE TABLE `faquser` (
`id` int(2) NOT NULL auto_increment,
`name` text NOT NULL,
`pass` varchar(64) binary NOT NULL default '',
`realname` varchar(255) NOT NULL default '',
`email` varchar(255) NOT NULL default '',
`rights` varchar(255) NOT NULL default '',
PRIMARY KEY (`id`)
) TYPE=MyISAM AUTO_INCREMENT=2 ;


CREATE TABLE `faqvisits` (
`id` int(11) NOT NULL auto_increment,
`lang` varchar(5) NOT NULL default '',
`visits` int(11) NOT NULL default '0',
`last_visit` int(15) NOT NULL default '0',
PRIMARY KEY (`id`,`lang`)
) TYPE=MyISAM AUTO_INCREMENT=31 ;


CREATE TABLE `faqvoting` (
`id` int(11) unsigned NOT NULL auto_increment,
`artikel` int(11) unsigned NOT NULL default '0',
`vote` int(11) unsigned NOT NULL default '0',
`usr` int(11) unsigned NOT NULL default '0',
`datum` varchar(20) NOT NULL default '',
`ip` varchar(15) NOT NULL default '',
PRIMARY KEY (`id`)
) TYPE=MyISAM AUTO_INCREMENT=3 ;

Thorsten
Posts: 14977
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sun Sep 25, 2005 8:34 am

Hi,

okay, re-run update.php and select "update from phpMyFAQ 1.4.4 and later" and everything should be alright.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

mjg
Posts: 5
Joined: Wed Apr 13, 2005 12:10 pm
Location: Porepunkah, Australia
Contact:

Post by mjg » Sun Sep 25, 2005 8:37 am

That's brilliant!. All is well. Many thanks for the prompt attention.

Thorsten
Posts: 14977
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sun Sep 25, 2005 8:52 am

Hi,

no problem. :-)

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

nice ...

Post by jazcyk » Tue Sep 27, 2005 2:26 am

nice to see our program at work!

Post Reply