Upgrade problem 2.8.27 to 2.9

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
tomperys
Posts: 67
Joined: Tue May 14, 2013 10:17 am

Upgrade problem 2.8.27 to 2.9

Post by tomperys » Wed May 25, 2016 3:06 pm

Hi
we get error if we follow your manual -delete all except:

database.php and ldap.php (if you use LDAP) in the directory config/
all files in the directory assets/template/
the directory attachments/
the directory data/
the directory images/

When we delete all except those file/folders and copy the files from phpmyfaq-2.9.0.zip and go to http://ourweb.../setup/update.php we got Error:

The connection to the database server could not be established.
The error message of the database server:
Invalid Database Type: mysql


(PS: firts we just tried to copy the files from phpmyfaq-2.9.0.zip to existing 2.8.27 installation without deleting anything and this worked, but the dministration was without styles and completely shattered.....we correct this by copy some styles from the new default template to our template but there was another problem.... in administration there were no posts at all from the previous version even when they still are in database and when we triet to open the posts in the frontend it just type access denied)

tomperys
Posts: 67
Joined: Tue May 14, 2013 10:17 am

Re: Upgrade problem 2.8.27 to 2.9

Post by tomperys » Wed May 25, 2016 3:39 pm

Ok when we changed mysql to mysqli the upgrade worked...
We also solved the htaccess problem

Now we are solwing changing the CSS and pages in templates. Its pitty you didnt make some teplate "default2" that would have the same layout as the 2.8.7 or previous versions because the new layout is much too different and we wish to maintain the previous one. Its a little hell now to figure out which styles are for what.... which to add to current style.min.css so we can maintain the old layout but have functional things like paging, viewing posts ect....

Thorsten
Posts: 14764
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade problem 2.8.27 to 2.9

Post by Thorsten » Thu May 26, 2016 7:15 pm

Hi,

yes, "ext/mysql" is not working any more in PHP 5.5 so we have to remove the support.

Your 2.8 layout should almost work out of the box with 2.9, please report all issues on Github and we'll fix them.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply