after upgrade - missing files, file verification check fails

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
pmfuser
Posts: 106
Joined: Tue Apr 01, 2014 7:00 am

after upgrade - missing files, file verification check fails

Post by pmfuser » Mon Jun 06, 2016 2:20 am

After an upgrade from 2.8.7 to 2.9.1, Online verification check lists those files as with local changes:

/inc/libs/phpseclib/Crypt/TripleDES.php
/inc/libs/phpseclib/Crypt/Rijndael.php
/inc/libs/phpseclib/Crypt/RSA.php
/inc/libs/phpseclib/Crypt/RC2.php
/inc/libs/phpseclib/Crypt/Hash.php
/inc/libs/phpseclib/Crypt/Base.php
/inc/libs/phpseclib/Crypt/RSA/PKCS.php
/inc/libs/phpseclib/Crypt/RSA/XML.php
/inc/libs/phpseclib/Crypt/RSA/MSBLOB.php
/inc/libs/phpseclib/Crypt/RSA/Raw.php
/inc/libs/phpseclib/Crypt/RSA/PuTTY.php
/inc/libs/phpseclib/Crypt/RSA/PKCS1.php
/inc/libs/phpseclib/Crypt/RSA/OpenSSH.php
/inc/libs/phpseclib/Crypt/RSA/PKCS8.php
/inc/libs/phpseclib/Crypt/Random.php
/inc/libs/phpseclib/Crypt/RC4.php
/inc/libs/phpseclib/Crypt/DES.php
/inc/libs/phpseclib/Crypt/Twofish.php
/inc/libs/phpseclib/Crypt/Blowfish.php
/inc/libs/phpseclib/Crypt/AES.php

In addition, I see some other files either missing or with their path misconfigured:

/assets/js/syntaxhighlighter/styles/shCore.css
/assets/js/syntaxhighlighter/styles/shThemeDefault.css
/assets/js/syntaxhighlighter/scripts/shAutoloader.js
/assets/js/syntaxhighlighter/scripts/shCore.js
/assets/js/libs/modernizr.min.js

I see that the file "modernizr.min.js" is right in "js" folder, not "libs" as expected. Those that are expected to be in "syntaxhighlighter" don't exist at all.

What would be the best way to fix all what's listed here?

Thank you

MRi
Posts: 39
Joined: Mon Sep 22, 2014 12:52 pm

Re: after upgrade - missing files, file verification check f

Post by MRi » Tue Jun 07, 2016 11:22 am

Similar here.
Online verification of 2.9.1 shows changes here:
•/inc/PMF/Export/Pdf/Wrapper.php
•/inc/libs/tcpdf/config/tcpdf_config.php
•/inc/libs/phpseclib/Crypt/AES.php
•/inc/libs/phpseclib/Crypt/Blowfish.php
•/inc/libs/phpseclib/Crypt/Hash.php
•/inc/libs/phpseclib/Crypt/Base.php
•/inc/libs/phpseclib/Crypt/DES.php
•/inc/libs/phpseclib/Crypt/Random.php
•/inc/libs/phpseclib/Crypt/RC2.php
•/inc/libs/phpseclib/Crypt/RC4.php
•/inc/libs/phpseclib/Crypt/Rijndael.php
•/inc/libs/phpseclib/Crypt/RSA.php
•/inc/libs/phpseclib/Crypt/TripleDES.php
•/inc/libs/phpseclib/Crypt/Twofish.php
•/inc/libs/phpseclib/Crypt/RSA/MSBLOB.php
•/inc/libs/phpseclib/Crypt/RSA/OpenSSH.php
•/inc/libs/phpseclib/Crypt/RSA/PKCS.php
•/inc/libs/phpseclib/Crypt/RSA/PKCS1.php
•/inc/libs/phpseclib/Crypt/RSA/PKCS8.php
•/inc/libs/phpseclib/Crypt/RSA/Raw.php
•/inc/libs/phpseclib/Crypt/RSA/PuTTY.php
•/inc/libs/phpseclib/Crypt/RSA/XML.php


But the files are identical to the downloaded ZIP file.

Thorsten
Posts: 14754
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: after upgrade - missing files, file verification check f

Post by Thorsten » Tue Jun 07, 2016 7:42 pm

Hi,

you see some leftovers from 2.8, we already updated our upgrade documentation for 2.9.2. Nothing to worry about.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pmfuser
Posts: 106
Joined: Tue Apr 01, 2014 7:00 am

Re: after upgrade - missing files, file verification check f

Post by pmfuser » Wed Jun 08, 2016 1:16 am

Thanks, but I don't fully get it. Does it mean it will get fixed in 2.9.2 or else?

For example, Glyphicons Halflings are in the CSS of the default template, but missing from the installation. Should they be there or not?

I have fixed some of the path issues, but files from syntaxhighlighter are missing. Should they be there or not?

Thank you

Thorsten
Posts: 14754
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: after upgrade - missing files, file verification check f

Post by Thorsten » Wed Jun 08, 2016 5:19 am

Hi,

we don't use Glyphicons. SyntaxHighlighter was removed, we know use HighlightJS.

The issue is that our documentation doesn't tell the user to delete almost all files and the old ones are still there to confuse the verification check.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pmfuser
Posts: 106
Joined: Tue Apr 01, 2014 7:00 am

Re: after upgrade - missing files, file verification check f

Post by pmfuser » Wed Jun 08, 2016 6:25 am

Thanks.

Well, Glyphicons Halflings are in the new 2.9.1 CSS file. SyntaxHighlighter is being requested by visitors, based on the 2.9 template.

Why is that and how to fix it?

Thanks

Thorsten
Posts: 14754
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: after upgrade - missing files, file verification check f

Post by Thorsten » Wed Jun 08, 2016 6:33 am

Hi,

I don't get any errors because of missing Glyphicons, do you?

As of SyntaxHighlighter, I don't see any reference any more in the code:

https://github.com/thorsten/phpMyFAQ/bl ... rtikel.tpl

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pmfuser
Posts: 106
Joined: Tue Apr 01, 2014 7:00 am

Re: after upgrade - missing files, file verification check f

Post by pmfuser » Wed Jun 08, 2016 7:30 am

In assets\template\default\css\style.css, starting from line 271, and glyphicon related styles going to line 1073. This is in the file marked as version 2.9. I already made a remark about this in previous posts. This is causing a lot of 404 errors.
You should get same errors after a clean install, that for sure according to the 2.9 code.

As for SyntaxHighlighter, I only found it in the "spacelab" template from the 2.8 version. I switched to the default template of 2.9, so this one is OK now.

Thanks

MRi
Posts: 39
Joined: Mon Sep 22, 2014 12:52 pm

Re: after upgrade - missing files, file verification check f

Post by MRi » Wed Jun 08, 2016 9:47 am

Thorsten wrote:you see some leftovers from 2.8, we already updated our upgrade documentation for 2.9.2. Nothing to worry about.
So I understand this correctly:
So the files are no longer used and are included into the 2.9.1 per accident?

Thorsten
Posts: 14754
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: after upgrade - missing files, file verification check f

Post by Thorsten » Wed Jun 08, 2016 11:27 am

Hi,

no, I think they are leftovers from 2.8

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pmfuser
Posts: 106
Joined: Tue Apr 01, 2014 7:00 am

Re: after upgrade - missing files, file verification check f

Post by pmfuser » Wed Jun 08, 2016 6:17 pm

Not the case, they are part of the 2.9.1 package. Just as the reference to those fonts is in the 2.9.1 CSS style file.

Thanks

Thorsten
Posts: 14754
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: after upgrade - missing files, file verification check f

Post by Thorsten » Thu Jun 09, 2016 4:59 am

Hi,

I added the files into the build process, quite interesting I don't 404 on my test systems and on our demos: http://jen.demo.phpmyfaq.de/

Here's the commit: https://github.com/thorsten/phpMyFAQ/co ... e5a09c2407

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

pmfuser
Posts: 106
Joined: Tue Apr 01, 2014 7:00 am

Re: after upgrade - missing files, file verification check f

Post by pmfuser » Thu Jun 09, 2016 5:11 am

The font files are actually a regular part of Bootstrap 3, that's what I realized earlier today (Glyphicon Halflings set). I simply copied them to fonts folder and that resolved the issue. I guess you should get the font files into the installation package as they're not there now.

But it is still about the verification complaining about files in that Crypt which are there in the 2.9 package.

Also, you may want to address the issue of modernizr.min.js location. I copied it over to what it was complaining about, but the new installation may be a problem.
Honestly, I started with using the version 2 Spacelab, and then switched to a fresh default theme. Now I'm not sure if this modernizr.min.js issue was theme pr package related.

Thanks

Thorsten
Posts: 14754
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: after upgrade - missing files, file verification check f

Post by Thorsten » Thu Jun 09, 2016 5:25 am

Hi,

re-checked the phpseclib and updated the bundled dependecies. We used an old version, updated for 2.9.2.

Thanks!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply