Importing backup to same version 2.9.6 gives SQL errors

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
rolflobker
Posts: 6
Joined: Sun Oct 23, 2016 4:18 pm

Importing backup to same version 2.9.6 gives SQL errors

Post by rolflobker » Sun Feb 24, 2019 2:00 pm

Hi!

I'm trying to migrate to a new server,
Setting up a new 2.9.6 install is quick and easy, intend to upgrade to 3.0 afterwards.
But the backup I make from the current running 2.9.6 cannot be imported.

The import process throws me this error, afterwards I am locked out and need to delete the database and start over;
I am using the same table prefix

This file is not UTF_8 encoded.
Preparing the database queries...

Querying...

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''
Log via SSH in op de ESXi host en verifieer de adapter:
\r\nQuery: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Se4ifpvH5VqbT/bRcflsW47XUQ29KF7yTwlAnwf9ufMmCfia/L5XLT1dSJxrOa9Nl3JQnQeFaSpv9lzR' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '9OJ74IOCyiStH93Gx4Cmiy7ezd89qfkiRbrATnEsrJnD2aHonrCblgsBUaxqcaRbWkq594fTbh8hvIP9' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'XQ5IiiX34sfkclBZuKqA9vHCLMn5aEVPoMHEK6MaA54EpqHQe+3E9NIIhw0LUkZpKdm0+mxYM3KKHW7u' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '3yr7cE1eV2wHagDb4JgZUjFNeRaHrtvDG00GnR6C4VLFlOvPcy2YCsRcfBM7pw1iqHtrXhlPXLFTnZ8/' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '4nJMYho/blnP55/tAKUXQtdbee/la+kcoEPZeSQzHxNRqr2oy09k98IHeH17fXHAfzCT7ryJe2Z1R6e3' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'eCFNxQ7UO1v/h63hI+ByC+nIFZTnPAw3hMEFzq7sIfCYIyM9XNo8aIC99NJUtstRFCI83A1WW7wmLz3r' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Q+JFDSi0izpAZkrZ5sFu4nR1VlMjwZpym0UYwSMuVIJJhy7ileqTJRSK2r00XBJZBK0BBS5WGj8JKes6' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''Om Domain Computers automatisch te laten activeren kan AD-Based Activation w' at line 1)



Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'xugIDLpjffiD20dqWfjzg4vQb8BAfP7FLuxs2YmjjuqN004egEH9T8A//lGFiyddgja04PIpF2LHm09g' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'rhe69ue9F/H7TcnzMsdNIXYTxgatQ5UA9u2KpF1alrt2Cr/mM0i049OCSqi9g16an1eb9N9s2YvTN2mb' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'SkmXXs22aFyhA3GlNKRE7ESnY2GcmN1qanCmvwRKzty5X2u6Bf1L1Vw7CvF5E+wCrXCsS8uQEFBMUJVt' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '+FuT1qeZh+VgYfmoZ28ZXx0ux11CYJmpZfKTAvSTAgONeOppsCwXyKTBjxgysXbsWr732Wt57enXEV4f' at line 1)

Query: "" failed (Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'dAmYYuYjM6fHAh/42RZtU95ymsOTVLlRL7y5C/cZliPWl4cRRhPYGbeBCVPlB1vahb1iwmRaeIlnrJqK' at line 1)

Thorsten
Posts: 14792
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Importing backup to same version 2.9.6 gives SQL errors

Post by Thorsten » Sun Feb 24, 2019 2:22 pm

Hi,

yes, you cannot import 2.9 backups into 3.0. You can upgrade your 2.9 installation to 3.0.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

rolflobker
Posts: 6
Joined: Sun Oct 23, 2016 4:18 pm

Re: Importing backup to same version 2.9.6 gives SQL errors

Post by rolflobker » Sun Feb 24, 2019 5:16 pm

Hi Thorsten! Yes, but this if from 2.9.6, same version to same version import

Sorry, I should not have mentioned 3.0 at all, was just saying i'm looking forward to upgrading this old 2.9.6 AFTER I have done a successful migration.
I should have made this clear in the original post, I only mentioned it in the title.

So importing a 2.9.6 backup into a new 2.9.6 installation

Thorsten
Posts: 14792
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Importing backup to same version 2.9.6 gives SQL errors

Post by Thorsten » Sun Feb 24, 2019 6:50 pm

Hi,

okay... can you send me your backup file to investigate what's going on?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

rolflobker
Posts: 6
Joined: Sun Oct 23, 2016 4:18 pm

Re: Importing backup to same version 2.9.6 gives SQL errors

Post by rolflobker » Sun Feb 24, 2019 10:20 pm

Done! See PM.

I was thinking of maybe updating the old installation first.
But I'm a bit hesitant now that I see an import might fail.

Or I all else fails I might copy paste all the articles, but that could take me an hour or so.
It's not like I have a whole lot of data in there, but if there's an easy 'fix'

rolflobker
Posts: 6
Joined: Sun Oct 23, 2016 4:18 pm

Re: Importing backup to same version 2.9.6 gives SQL errors

Post by rolflobker » Mon Feb 25, 2019 12:37 pm

Hi!

I just updated the old installatie to 3.0 (which went flawless)
Did not want to do this at first, because it also took me about 2hrs to update the old VM to a newer Debian, and update PHP

I exported the 'old' 3.0 and created a new 3.0 install on a new VM, then imported again.

Now all is working fine in the new environment.

Love the way 3.0 looks!
Keep up the good work Thorsten!

Thorsten
Posts: 14792
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Importing backup to same version 2.9.6 gives SQL errors

Post by Thorsten » Mon Feb 25, 2019 7:55 pm

Hi,

I checked your 2.9 backup file... it somehow breaks the import because of the big queries due to the Base64 embedded images. The import worked with phpMyAdmin...

Does it work on 3.0?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

rolflobker
Posts: 6
Joined: Sun Oct 23, 2016 4:18 pm

Re: Importing backup to same version 2.9.6 gives SQL errors

Post by rolflobker » Mon Feb 25, 2019 9:35 pm

Yes, as far as I can tell it worked fine with 3.0!

I also tried importing with PhpMyAdmin but that failed, could be it just did not work for me because the password hashes were different and I did not look into resetting the hash.

Post Reply