Error when creating a PDF from a single faq

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
olly
Posts: 15
Joined: Tue Mar 29, 2022 2:01 pm

Error when creating a PDF from a single faq

Post by olly »

When i click "PDF-Version" in an article i got this error:
AH01071: Got error 'PHP message: phpMyFAQ TypeError: Typed property phpMyFAQ\\Faq::$plurals must be an instance of phpMyFAQ\\Language\\Plurals, null used in /var/www/phpmyfaq/src/phpMyFAQ/Faq.php on line 127\nStack trace:\n#0 /var/www/phpmyfaq/pdf.php(96): phpMyFAQ\\Faq->__construct()\n#1 {main}'
Version 3.1.2 / PHP 7.4

Creating PDF in general seems to work as i can create an export in the adminsection as PDF without problems.

Any ideas?

-Olly
Thorsten
Posts: 15373
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Error when creating a PDF from a single faq

Post by Thorsten »

Hi,

I'll fix that, here's the bug issue: https://github.com/thorsten/phpMyFAQ/issues/2082

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
olly
Posts: 15
Joined: Tue Mar 29, 2022 2:01 pm

Re: Error when creating a PDF from a single faq

Post by olly »

Thank you!
Thorsten
Posts: 15373
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Error when creating a PDF from a single faq

Post by Thorsten »

phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
olly
Posts: 15
Joined: Tue Mar 29, 2022 2:01 pm

Re: Error when creating a PDF from a single faq

Post by olly »

Works perfectly. Thank you!
Post Reply