After upgrade, access for all users are disabled in Edit/New Faq

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
andersonhoffmann
Posts: 22
Joined: Tue Nov 14, 2017 1:25 pm

After upgrade, access for all users are disabled in Edit/New Faq

Post by andersonhoffmann »

Hello my friends

After successfully updating the faq from 2.9.13 to 3.0.12, when creating or editing a category or faq, the option 'access for all groups' and 'access for all users' are disabled. it is possible only to use the 'restricted access to' option. I can't create a new faq and make it public
Can anyone help me?
What should I do?
2022-05-08 18_34_11-Window.png
2022-05-08 18_32_19-Window.png
You do not have the required permissions to view the files attached to this post.
andersonhoffmann
Posts: 22
Joined: Tue Nov 14, 2017 1:25 pm

Re: After upgrade, access for all users are disabled in Edit/New Faq

Post by andersonhoffmann »

Please
Someone can help me?
andersonhoffmann
Posts: 22
Joined: Tue Nov 14, 2017 1:25 pm

Re: After upgrade, access for all users are disabled in Edit/New Faq

Post by andersonhoffmann »

Please
Someone can help me?
andersonhoffmann
Posts: 22
Joined: Tue Nov 14, 2017 1:25 pm

Re: After upgrade, access for all users are disabled in Edit/New Faq

Post by andersonhoffmann »

@Thorsten

Can you help me?
Thorsten
Posts: 15373
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: After upgrade, access for all users are disabled in Edit/New Faq

Post by Thorsten »

Hi,

can you please upgrade to 3.1.4 first as the v3.0 series is out of support as well.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
andersonhoffmann
Posts: 22
Joined: Tue Nov 14, 2017 1:25 pm

Re: After upgrade, access for all users are disabled in Edit/New Faq

Post by andersonhoffmann »

Hello

First I tried to upgrade from version 2.9.13 to 3.1.4
Our server is ubuntu 18.04 which does not support php v7.4. so i had to manually upgrade from version 7.2 to 7.4 to support the latest version
I also got a lot of problems after the migration like the articles that were not showing on the 'show all categories' screen
The searches were also wrong. Many problems with elasticsearch integration, whether in versions 5.6.x or newer, indexing does not occur and returns error in the apache logs
After wasting a lot of time trying to solve the problems, I chose to upgrade to an intermediate version, like 3.0.x
I think I managed to solve the problem I'm having after migrating to 3.0.12, I'm validating the resolution in test environment
But still, thanks for the support
Thorsten
Posts: 15373
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: After upgrade, access for all users are disabled in Edit/New Faq

Post by Thorsten »

Hi,

can you send me or post the errors here?

I think the upgrade process didn't ran correctly.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Post Reply