AJAX?

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
stylus740
Posts: 64
Joined: Sat Apr 01, 2006 6:29 pm

AJAX?

Post by stylus740 » Fri Jun 15, 2007 8:39 pm

Hallo,

beim Konvertieren einer FAQ wird unter Inhalte - FAQ bearbeiten ja das Ergebnis der Linküberprüfung angezeigt. Ein schwarz unterlegtes "Keine Script Unterstützung verfügbar" ist ja der Default und ein Anklicken dieses Feldes leitet in der Regel diese Linküberprüfung ein. So weit, so gut ...

Manchmal aber wechslt die Meldung beim Anklichen zu "Keine AJAX Unterstützung verfügbar". Was ist AJAX? Was bedeutet die Meldung? Handelt es sich ggf. um einen Bug? weil nach Öffnen und Neuspeichern des Artikels dann alles auf grün oder rot geht.

Es ist auch nicht reproduzierbar. Manchmal kommt das beim Anklicken und manchmal (öfters) nicht...

Bye

Thorsten
Posts: 15179
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sat Jun 16, 2007 7:07 am

phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

kai
Posts: 82
Joined: Sun Jul 03, 2005 5:39 pm

Post by kai » Wed Jun 20, 2007 5:48 pm

Hallo, ich kann nur bestätigen, was stylus schreibt. Die Anzeige dort ist manchmal nicht nachvollziehbar.
Beispiel: (meine erste Link-Überprüfung mit der gerade installierten 2.0.1)
Erster Artikel ok (bis auf einen offensichtlichen Anzeigebug im Popup-Fenster, da muß ich mich erst bei thinkforge anmelden). Dann habe ich den zweiten Artikel versucht.
Da erhalte ich dann im Popup die Login-Maske, obwohl gleichzeitig angezeigt wird, das noch 20 Minuten bis Ablauf sind. Hm.
Nächster Artikel: No Links, gut.
Nächster Artikel: No AJAX und Anzeige im Popup "No URLs compatible with link verifier feature found". Hm.
Nächster Artikel: Links ok und wieder die Login-Maske. Hm.
Nächster Artikel: No AJAX.
Nächster Artikel: Links ok, keine Login-Maske.
Also, irgendwo ist da der Wurm drin.

Thorsten
Posts: 15179
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Wed Jun 20, 2007 5:51 pm

Hi,

okay, dann guck ich mir das mal an. Kannst du das noch in den Bugtracker eintragen?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

kai
Posts: 82
Joined: Sun Jul 03, 2005 5:39 pm

Post by kai » Fri Jun 29, 2007 8:07 pm

Hat a bischle gedauert. Habe dir dafür heute gleich noch ein Dutzend andere reingestellt :twisted:

matteo
Posts: 572
Joined: Sun Nov 20, 2005 6:53 pm
Location: Italy

Setting cron for Linkchecker

Post by matteo » Mon Jul 02, 2007 9:08 am

Hi,
I cannot exactly understand what you're talking about (please remember that I'm not able to read German except when using the Google translation service and sometimes the translation is worse than the original ;) ) but I think it could be of some help for you to know that the Linkchecker functionality relies also on a cron to be set e.g. daily, calling the [PATH_TO_PMF_INSTALL]/cron.verifyurls.php file using CLI or a WEB hit.
This will give you the opportunity to update the status of all the links of all FAQ records w/o the need of a manual update.

Ciao,
Matteo
phpMyFAQ QA / Developer
Amazon.co.uk Wishlist

kai
Posts: 82
Joined: Sun Jul 03, 2005 5:39 pm

Post by kai » Mon Jul 02, 2007 5:40 pm

Thanks for the answer. I suggest if you prefer English questions you put a sticky note somewhere ;-)
Do you refer to my bug report or to something I said in this thread?
The problem is not related to cron.verifyurls.php. I see that I could run it and this would then be saved, so next time it's "just there" and won't be carried out online again. But I'm talking about the problems with the online verification (which don't seem to have anything to do with them timing out).

matteo
Posts: 572
Joined: Sun Nov 20, 2005 6:53 pm
Location: Italy

Post by matteo » Thu Jul 05, 2007 10:48 am

Hi,
I don't want to suggest PMF users to write only in English: I try each time with the automatic translation and, besides, Thorsten is usually faster than me in replying to users ;).

Back to your issue: could you drop me an email (matteo@phpmyfaq.de) with some screenshots and a short description in English? I'll try to replicate the issue in the next days and I'll report here the progress. The email is just to avoid to bother the Community w/ more posts just for my limits on reading German ;).

Ciao,
Matteo
phpMyFAQ QA / Developer
Amazon.co.uk Wishlist

kai
Posts: 82
Joined: Sun Jul 03, 2005 5:39 pm

Post by kai » Mon Jul 23, 2007 5:43 pm

Just back from vacation. I'll send the email in the next minutes. It's also on the Bugtracker (but in German).

Post Reply